Manjaro-xfce-20.1-200911-linux58 on Hyper-V : xfce won't start

Hi all,

I’m having issues with getting the DE to launch on Hyper-V in Windows 10. I’ve tried it on 2 different PCs, both running Intel/Nvidia CPU/GPUs on Windows 10. In both cases, the startup goes seemingly ok until the end when it halts with no desktop.

Note that when I boot from the USB stick, Manjaro starts up and displays the xfce desktop with no issue. It appears to be an interaction with Hyper-V.

The log files in both cases show the same issues with the graphics setup I believe. I would insert the text of the log file but I cannot figure out how to get it from the VM to my windows desktop other than the image of the virtual machine connection. So with your forgiveness, I post the image of the later part of the log file:

I’ve done some some searches to see if there were other Hyper-V related desktop issues and have found this (Install manjaro-kde-20.0.3 on hyper-v: Failed to start Simple Desktop Display Manager) but it doesn’t have a resolution.

I’m happy to learn how to get the actual logs from the VM if someone has that info to help provide more info for troubleshooting. I’ve looked pretty much all afternoon and can’t find a method.

I’m a beginner in the Linux world, but did have a portion of my career working in Unix environments (about 10 years ago) so I’m very rusty. My background is not IT/CS but I do like to dabble.

thanks for any help or tips,

mikehd

Hi and welcome!

Have look here: Hyper-V - ArchWiki

Otherwise… Virtualbox works great.

In your log it says, that no gpu driver has been loaded, therefore no screens.

Thanks for the pointer to the ArchWiki, I’ll check it out.

Yes, I see that no gpu driver was loaded, and the paths indicated indeed do not have the expected files. Odd to me that the same ISO would work perfectly when used as a bootable image, but not as a mounted image in Hyper-V.

I’ll update if anything I learn anything. I’m also going to try another distro to see if it some weird MS issue with Manjaro.


I’m back after viewing the ArchWiki. No new news there, pretty much the same as other Hyper-V resources with the added details for improved user experience after the VM is running. It assumes that there is no desktop launched and you’ll start one separately so they don’t really address what I’m encountering.

I think I’ll give Virtualbox a try.


I’m back with an update. I ended up trying alt distro on Hyper-V and it runs as expected with functional Gnome desktop. It is one of the supported distros for Hyper-V so its good that it runs…

Virtualbox next…

Same results with Virtualbox, perhaps even a bit worse? TBH I didn’t troubleshoot at all, but did try to get to the CL using CTRL+ALT+F3 and I get the logon prompts but no CL. Same results means no desktop was started.

I think this means I need to move on from Manjaro for VM usage.