Manjaro will not boot

Manjaro won’t boot.

When I’m trying to boot Manjaro I get the line »dev/sda11 clean, […] files, […] blocks« (as usual), but then the screen goes blank with a only a text cursor in top left corner. And nothing else happens. (I’m still able to return to GRUB by pressing Ctrl+Alt+Del.)

I tried different kernels and fall back images – every time the same problem.

I haven’t done any changes to the system since the last successful boot (as far as I remember …)

Edit: It seems to be a problem with gnome, now.

Edit2: Here are some Information about my system:

$inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.4.101-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=e12025e9-6e09-46c1-a43b-fcfabfd25bb5 rw quiet 
  Console: tty 2 DM: GDM Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 80N6 v: Lenovo Yoga 500-15IBD 
  serial: <filter> Chassis: type: 10 v: Lenovo Yoga 500-15IBD serial: <filter> 
  Mobo: LENOVO model: Lenovo Yoga 500-15IBD v: 31900058 WIN serial: <filter> 
  UEFI: Lenovo v: BDCN71WW date: 08/03/2016 
  ID-1: BAT0 charge: 23.5 Wh condition: 24.3/30.0 Wh (81%) volts: 8.1/7.4 
  model: SMP L14M2P21 type: Li-poly serial: <filter> status: Unknown 
  RAM: total: 7.68 GiB used: 442.6 MiB (5.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell family: 6 model-id: 3D (61) stepping: 4 microcode: 2F 
  L2 cache: 3 MiB bogomips: 17565 
  Speed: 798 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 3: 799 
  4: 799 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx 
  avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
  ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx 
  pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pti pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 class ID: 0300 
  Device-2: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus ID: 2-4:2 
  chip ID: 5986:0670 class ID: 0e02 serial: <filter> 
  Display: server: 1.20.10 driver: loaded: intel unloaded: modesetting 
  alternate: fbdev,vesa tty: 170x48 
  Message: Advanced graphics data unavailable in console. Try -G --display 
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c class ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  class ID: 0403 
  Sound Server: ALSA v: k5.4.101-1-MANJARO 
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: efa0 
  bus ID: 02:00.0 chip ID: 8086:08b4 class ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000 
  bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 465.76 GiB used: 119.54 GiB (25.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS545050A7E660 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: B230 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 165.03 GiB size: 161.44 GiB (97.82%) 
  used: 119.51 GiB (74.0%) fs: ext4 dev: /dev/sda11 maj-min: 8:11 label: N/A 
  uuid: e12025e9-6e09-46c1-a43b-fcfabfd25bb5 
  ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) 
  used: 32.2 MiB (12.6%) fs: vfat dev: /dev/sda2 maj-min: 8:2 
  label: SYSTEM_DRV uuid: 0264-B6E7 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda9 maj-min: 8:9 label: N/A 
  uuid: 845b0137-1d4f-4665-b683-95ee97a96a05 
  ID-1: /dev/sda1 maj-min: 8:1 size: 1000 MiB fs: ntfs label: WINRE_DRV 
  uuid: 3C7A62757A622C38 
  ID-2: /dev/sda10 maj-min: 8:10 size: 32.25 GiB fs: ext4 label: rootMX17 
  uuid: d64aa996-71e2-48af-8f55-4f64c587986b 
  ID-3: /dev/sda3 maj-min: 8:3 size: 1000 MiB fs: vfat label: LRS_ESP 
  uuid: 7667-8000 
  ID-4: /dev/sda4 maj-min: 8:4 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-5: /dev/sda5 maj-min: 8:5 size: 24.88 GiB fs: ntfs label: Windows8_OS 
  uuid: 4E0A6A8C0A6A713F 
  ID-6: /dev/sda6 maj-min: 8:6 size: 25 GiB fs: ntfs label: LENOVO 
  uuid: EC06768406764F96 
  ID-7: /dev/sda7 maj-min: 8:7 size: 12.34 GiB fs: ntfs label: PBR_DRV 
  uuid: CCD26CFED26CEDE0 
  ID-8: /dev/sda8 maj-min: 8:8 size: 200.01 GiB fs: ext4 label: N/A 
  uuid: 0c8b5d8f-5c73-4caf-b21c-080d018f5138 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip ID: 8087:8001 class ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 2-4:2 info: Acer Lenovo EasyCamera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 5986:0670 class ID: 0e02 
  serial: <filter> 
  Device-2: 2-5:3 info: Belkin Mouse [HT82M21A] type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 1241:1177 class ID: 0301 
  Device-3: 2-8:5 info: Elan Micro Touchscreen type: HID 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 04f3:2088 class ID: 0300 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 40.0 C mobo: 33.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 127 Uptime: 26m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1604 lib: 504 Shell: Bash 
  v: 5.1.0 running in: tty 2 inxi: 3.3.01 ```

When you get back to that screen, pressing Ctrl+Alt+f7 may open up the gui. If not
If not, pressing Ctrl+Alt+f2 should take you to a terminal where you can login and do a system update with sudo pacman -Syu.

Thats helped me in the past.

Thx for your answer.

I was able to get into tty2 by pressing Ctrl+Alt+f2 and did a system upgrade.

It didn’t solve the problem, but it helped to figure out what’s going wrong.

I tried to start gnome.

$gnome-session --debug --whale
gnome-session-binary[1580]: DEBUG(+): Enabling debugging
Unable to init server: Could not connect: Connection refused

** (gnome-session-failed:1586): WARNING**: 01:26:04.944: Cannot open display:

There seems to be a problem with gnome …

That sounds like a graphic card driver issue. It is hard to tell without enough information from your environment though. I would recommend you take a look at this thread first:

There is a very good guide for setting up the graphic cards on the Wiki

Thx for your answer and the hint.

I added information about my system to my opening post.

(Sorry, I’m new to the forum.)

It looks like you have already the i915 driver working in kernel mode. So the issue might be similar to the one discussed below:

EDIT: So, for your case, the issue might be the timing in which GDM boots up.

Hope that helps! :+1:

I read the article about graphics cards configuration.

It seems that all available (free) drivers are already installed.

But I got this:

$glxinfo | grep OpenGL
Error: unable to open display

(Is that something I should be concerned about?)

Should I force a re-installation of all drivers?

Or should I go on and play around with Early KMS?

I would go the EKMS route. It will ensure the video driver is loaded early enough before GDM starts.

If I’m not wrong, some people prefer to add delay to the GDM service unit in systemd so that it loads after the video driver. IMO, that’s not an optimal solution as you’d be adding delay to the overall boot time.

I added i915 to modules in /etc/mkinitcpio.conf and ran mkinitcpio -P.

It got some errors:

$mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-4.19-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-4.19-x86_64-fallback.img
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-5.4-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-5.4-x86_64-fallback.img
==> Building image from preset: /etc/mkinitcpio.d/linux54-rt.preset: 'default'
  -> -k /boot/vmlinuz-5.4-rt-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-rt-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-5.4-rt-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux54-rt.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-rt-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-rt-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-5.4-rt-x86_64-fallback.img

You need to do that as superuser. Try sudo mkinitcpio -P

I was able to execute the command as super user. – It worked.

But it did not solve the initial problem.

Can you post the output of the following commands?:
sudo mhwd -li
sudo cat /etc/mkinitcpio.conf

For EKMS to work, the output should look something like this:

sudo mhwd -li                                                                                                                                                                                                 

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI

~ >>> sudo cat /etc/mkinitcpio.conf                                                                                                                                                                              [1]
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

Looking at your previous posts, I can tell that you were not elevating any of the commands with sudo.

Note that most administration tasks like dealing with configuration files need to be run adding sudo as regular user accounts normally don’t have the ability to do so.

$sudo  mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
            video-vesa            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
         network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!
$sudo cat /etc/mkinitcpio.conf
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck"

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

The files look good. This is what I would do:

  1. I would uninstall video-vesa and video-linux as they might be just redundant. IMO, the advantage of using kernel modesetting is that it will persist across system upgrades. You’ll get also the latest firmware for your hardware along with the kernel updates. The disadvantage is that any failure with KMS may cause a kernel panic. I haven’t had any issues so far like this, though.

  2. Once you have removed the drivers, try to regenerate the initramfs again (sudo mkinitcpio-P)

That should get EKMS to work properly.

That works!

Thank you very much for your help and patience!

I also learned a lot about drivers and graphics cards configuration.


You’re welcome! and welcome aboard! :slight_smile:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.