LightDM doesn't start automatically on boot but works fine if I run it from terminal

Hi all,

Did a reboot today and suddenly lightdm won’t start. I poked around the forums to see if I could solve it, but it turns out lightdm runs just fine if i open a terminal and run it with sudo.

Things I did today that I think could possibly be connected:

  • Did a huge update where I just updated everything that had an update (about 300 updates)
  • Modified the LightDM Gtk greeter settings for the first time

Please let me know if there’s any log output I should be posting, however since lightdm is running fine without errors, I don’t know what to say other than sometimes it boots to a black screen, and other times it boots to the “lightdm failed to start” screen. In either case I can open a terminal and run lightdm manually, and it works fine.

1 Like

https://wiki.archlinux.org/index.php/LightDM#Troubleshooting

Respectfully, I’ve looked at this page and I don’t believe any of the described issues match the one I’m having. Here is the output of lightdm --show-config:

   [Seat:*]
A  greeter-session=lightdm-gtk-greeter
A  user-session=xfce
A  session-wrapper=/etc/lightdm/Xsession

   [LightDM]
A  run-directory=/run/lightdm

Sources:
A  /etc/lightdm/lightdm.conf

cat /etc/lightdm/lightdm.conf:

[Seat:*]
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
# backup-logs = True to move add a .old suffix to old log files when opening new ones
# dbus-service = True if LightDM provides a D-Bus service to control it
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7 # Setting this to a value < 7 implies security issues, see FS#46799
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-check-graphical=false
#log-directory=/var/log/lightdm
run-directory=/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
#backup-logs=true
#dbus-service=true

#
# Seat configuration
#
# Seat configuration is matched against the seat name glob in the section, for example:
# [Seat:*] matches all seats and is applied first.
# [Seat:seat0] matches the seat named "seat0".
# [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
#
# type = Seat type (local, xremote)
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
# xserver-config = Config file to pass to X server
# xserver-layout = Layout to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
greeter-session=lightdm-gtk-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
user-session=xfce
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8

Update: here is the output of /var/log/Xorg.0.log on boot. However, once I run lightdm manually, the new log doesn’t have any errors.

[     3.576] 
X.Org X Server 1.20.10
X Protocol Version 11, Revision 0
[     3.576] Build Operating System: Linux Manjaro Linux
[     3.576] Current Operating System: Linux alex-b450aorusm 5.9.16-1-MANJARO #1 SMP PREEMPT Mon Dec 21 22:00:46 UTC 2020 x86_64
[     3.576] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=e502f584-8f76-43f6-a65e-3a2aa18ef213 rw quiet apparmor=1 security=apparmor udev.log_priority=3
[     3.576] Build Date: 16 December 2020  10:33:32PM
[     3.576]  
[     3.576] Current version of pixman: 0.40.0
[     3.576] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     3.576] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     3.576] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 10 11:09:42 2021
[     3.577] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     3.577] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     3.577] (==) No Layout section.  Using the first Screen section.
[     3.577] (==) No screen section available. Using defaults.
[     3.577] (**) |-->Screen "Default Screen Section" (0)
[     3.577] (**) |   |-->Monitor "<default monitor>"
[     3.577] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     3.577] (==) Automatically adding devices
[     3.577] (==) Automatically enabling devices
[     3.577] (==) Automatically adding GPU devices
[     3.577] (==) Automatically binding GPU devices
[     3.577] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     3.577] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     3.577] 	Entry deleted from font path.
[     3.577] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     3.577] 	Entry deleted from font path.
[     3.577] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     3.577] 	Entry deleted from font path.
[     3.577] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     3.577] 	Entry deleted from font path.
[     3.577] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF
[     3.577] (==) ModulePath set to "/usr/lib/xorg/modules"
[     3.577] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     3.577] (II) Module ABI versions:
[     3.577] 	X.Org ANSI C Emulation: 0.4
[     3.577] 	X.Org Video Driver: 24.1
[     3.577] 	X.Org XInput driver : 24.1
[     3.577] 	X.Org Server Extension : 10.0
[     3.578] (++) using VT number 7

[     3.578] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     3.583] (--) PCI:*(9@0:0:0) 1002:731f:1da2:e416 rev 202, Mem @ 0xe0000000/268435456, 0xf0000000/2097152, 0xfcc00000/524288, I/O @ 0x0000f000/256, BIOS @ 0x????????/131072
[     3.583] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     3.583] (II) LoadModule: "glx"
[     3.583] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     3.584] (II) Module glx: vendor="X.Org Foundation"
[     3.584] 	compiled for 1.20.10, module version = 1.0.0
[     3.584] 	ABI class: X.Org Server Extension, version 10.0
[     3.584] (==) Matched ati as autoconfigured driver 0
[     3.584] (==) Matched modesetting as autoconfigured driver 1
[     3.584] (==) Matched fbdev as autoconfigured driver 2
[     3.584] (==) Matched vesa as autoconfigured driver 3
[     3.584] (==) Assigned the driver to the xf86ConfigLayout
[     3.584] (II) LoadModule: "ati"
[     3.584] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[     3.585] (II) Module ati: vendor="X.Org Foundation"
[     3.585] 	compiled for 1.20.8, module version = 19.1.0
[     3.585] 	Module class: X.Org Video Driver
[     3.585] 	ABI class: X.Org Video Driver, version 24.1
[     3.585] (II) LoadModule: "radeon"
[     3.585] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[     3.586] (II) Module radeon: vendor="X.Org Foundation"
[     3.586] 	compiled for 1.20.8, module version = 19.1.0
[     3.586] 	Module class: X.Org Video Driver
[     3.586] 	ABI class: X.Org Video Driver, version 24.1
[     3.586] (II) LoadModule: "modesetting"
[     3.586] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     3.586] (II) Module modesetting: vendor="X.Org Foundation"
[     3.586] 	compiled for 1.20.10, module version = 1.20.10
[     3.586] 	Module class: X.Org Video Driver
[     3.586] 	ABI class: X.Org Video Driver, version 24.1
[     3.586] (II) LoadModule: "fbdev"
[     3.586] (WW) Warning, couldn't open module fbdev
[     3.586] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     3.586] (II) LoadModule: "vesa"
[     3.586] (WW) Warning, couldn't open module vesa
[     3.586] (EE) Failed to load module "vesa" (module does not exist, 0)
[     3.586] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
	ATI Radeon Mobility X600 (M24), ATI FireMV 2400,
	ATI Radeon Mobility X300 (M24), ATI FireGL M24 GL,
	ATI Radeon X600 (RV380), ATI FireGL V3200 (RV380),
	ATI Radeon IGP320 (A3), ATI Radeon IGP330/340/350 (A4),
	ATI Radeon 9500, ATI Radeon 9600TX, ATI FireGL Z1, ATI Radeon 9800SE,
	ATI Radeon 9800, ATI FireGL X2, ATI Radeon 9600, ATI Radeon 9600SE,
	ATI Radeon 9600XT, ATI FireGL T2, ATI Radeon 9650, ATI FireGL RV360,
	ATI Radeon 7000 IGP (A4+), ATI Radeon 8500 AIW,
	ATI Radeon IGP320M (U1), ATI Radeon IGP330M/340M/350M (U2),
	ATI Radeon Mobility 7000 IGP, ATI Radeon 9000/PRO, ATI Radeon 9000,
	ATI Radeon X800 (R420), ATI Radeon X800PRO (R420),
	ATI Radeon X800SE (R420), ATI FireGL X3 (R420),
	ATI Radeon Mobility 9800 (M18), ATI Radeon X800 SE (R420),
	ATI Radeon X800XT (R420), ATI Radeon X800 VE (R420),
	ATI Radeon X850 (R480), ATI Radeon X850 XT (R480),
	ATI Radeon X850 SE (R480), ATI Radeon X850 PRO (R480),
	ATI Radeon X850 XT PE (R480), ATI Radeon Mobility M7,
	ATI Mobility FireGL 7800 M7, ATI Radeon Mobility M6,
	ATI FireGL Mobility 9000 (M9), ATI Radeon Mobility 9000 (M9),
	ATI Radeon 9700 Pro, ATI Radeon 9700/9500Pro, ATI FireGL X1,
	ATI Radeon 9800PRO, ATI Radeon 9800XT,
	ATI Radeon Mobility 9600/9700 (M10/M11),
	ATI Radeon Mobility 9600 (M10), ATI Radeon Mobility 9600 (M11),
	ATI FireGL Mobility T2 (M10), ATI FireGL Mobility T2e (M11),
	ATI Radeon, ATI FireGL 8700/8800, ATI Radeon 8500, ATI Radeon 9100,
	ATI Radeon 7500, ATI Radeon VE/7000, ATI ES1000,
	ATI Radeon Mobility X300 (M22), ATI Radeon Mobility X600 SE (M24C),
	ATI FireGL M22 GL, ATI Radeon X800 (R423), ATI Radeon X800PRO (R423),
	ATI Radeon X800LE (R423), ATI Radeon X800SE (R423),
	ATI Radeon X800 XTP (R430), ATI Radeon X800 XL (R430),
	ATI Radeon X800 SE (R430), ATI Radeon X800 (R430),
	ATI FireGL V7100 (R423), ATI FireGL V5100 (R423),
	ATI FireGL unknown (R423), ATI Mobility FireGL V5000 (M26),
	ATI Mobility Radeon X700 XL (M26), ATI Mobility Radeon X700 (M26),
	ATI Radeon X550XTX, ATI Radeon 9100 IGP (A5),
	ATI Radeon Mobility 9100 IGP (U3), ATI Radeon XPRESS 200,
	ATI Radeon XPRESS 200M, ATI Radeon 9250, ATI Radeon 9200,
	ATI Radeon 9200SE, ATI FireMV 2200, ATI Radeon X300 (RV370),
	ATI Radeon X600 (RV370), ATI Radeon X550 (RV370),
	ATI FireGL V3100 (RV370), ATI FireMV 2200 PCIE (RV370),
	ATI Radeon Mobility 9200 (M9+), ATI Mobility Radeon X800 XT (M28),
	ATI Mobility FireGL V5100 (M28), ATI Mobility Radeon X800 (M28),
	ATI Radeon X850, ATI unknown Radeon / FireGL (R480),
	ATI Radeon X800XT (R423), ATI FireGL V5000 (RV410),
	ATI Radeon X700 XT (RV410), ATI Radeon X700 PRO (RV410),
	ATI Radeon X700 SE (RV410), ATI Radeon X700 (RV410),
	ATI Radeon X1800, ATI Mobility Radeon X1800 XT,
	ATI Mobility Radeon X1800, ATI Mobility FireGL V7200,
	ATI FireGL V7200, ATI FireGL V5300, ATI Mobility FireGL V7100,
	ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
	ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
	ATI Mobility Radeon X1400, ATI Radeon X1550 64-bit,
	ATI Mobility Radeon X1300, ATI Radeon X1300, ATI FireGL V3300,
	ATI FireGL V3350, ATI Mobility Radeon X1450,
	ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
	ATI FireMV 2250, ATI Radeon X1650, ATI Mobility FireGL V5200,
	ATI Mobility Radeon X1600, ATI Radeon X1300 XT/X1600 Pro,
	ATI FireGL V3400, ATI Mobility FireGL V5250,
	ATI Mobility Radeon X1700, ATI Mobility Radeon X1700 XT,
	ATI FireGL V5200, ATI Radeon X2300HD, ATI Mobility Radeon HD 2300,
	ATI Radeon X1950, ATI Radeon X1900, ATI AMD Stream Processor,
	ATI RV560, ATI Mobility Radeon X1900, ATI Radeon X1950 GT, ATI RV570,
	ATI FireGL V7400, ATI Radeon 9100 PRO IGP,
	ATI Radeon Mobility 9200 IGP, ATI Radeon X1200, ATI RS740,
	ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro,
	ATI Radeon HD 2900 GT, ATI FireGL V8650, ATI FireGL V8600,
	ATI FireGL V7600, ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
	ATI Radeon HD 4850 x2, ATI FirePro V8750 (FireGL),
	ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,
	ATI Mobility RADEON HD 4850 X2, ATI FirePro RV770,
	AMD FireStream 9270, AMD FireStream 9250, ATI FirePro V8700 (FireGL),
	ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
	ATI FirePro M7750, ATI M98, ATI Mobility Radeon HD 4650,
	ATI Radeon RV730 (AGP), ATI Mobility Radeon HD 4670,
	ATI FirePro M5750, ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
	ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
	ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
	ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
	ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
	ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI RV610,
	ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,
	ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI Radeon HD 2350,
	ATI Mobility Radeon HD 2400 XT, ATI Mobility Radeon HD 2400,
	ATI RADEON E2400, ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
	ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
	ATI Mobility Radeon HD 3850 X2, ATI Mobility Radeon HD 3870,
	ATI Mobility Radeon HD 3870 X2, ATI Radeon HD3870 X2,
	ATI FireGL V7700, ATI Radeon HD3690, AMD Firestream 9170,
	ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon HD 4350,
	ATI Mobility Radeon 4300 Series, ATI Mobility Radeon 4500 Series,
	ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
	ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
	ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
	ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
	ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
	ATI FireGL V3600, ATI Radeon HD 2600 LE,
	ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
	ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
	ATI Radeon HD 3450, ATI Radeon HD 3430, ATI FirePro V3700,
	ATI FireMV 2450, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP,
	ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,
	ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
	ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
	ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
	ATI Radeon HD 3300 Graphics, ATI Radeon 3000 Graphics, SUMO, SUMO2,
	ATI Radeon HD 4200, ATI Radeon 4100, ATI Mobility Radeon HD 4200,
	ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
	AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
	AMD Radeon HD 6300 Series Graphics,
	AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
	ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
	AMD Firestream 9350, ATI Radeon HD 5800 Series,
	ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
	ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
	ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
	ATI Radeon HD 5670, ATI Radeon HD 5570, ATI Radeon HD 5500 Series,
	REDWOOD, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
	ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
	AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
	AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
	ARUBA, TAHITI, PITCAIRN, VERDE, OLAND, HAINAN, BONAIRE, KABINI,
	MULLINS, KAVERI, HAWAII
[     3.589] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     3.589] (EE) open /dev/dri/card0: No such file or directory
[     3.589] (WW) Falling back to old probe method for modesetting
[     3.589] (EE) open /dev/dri/card0: No such file or directory
[     3.589] (EE) Screen 0 deleted because of no matching config section.
[     3.589] (II) UnloadModule: "modesetting"
[     3.589] (EE) Device(s) detected, but none match those in the config file.
[     3.589] (EE) 
Fatal server error:
[     3.589] (EE) no screens found(EE) 
[     3.589] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[     3.589] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     3.589] (EE) 
[     3.589] (EE) Server terminated with error (1). Closing log file.

Hi, I would say the issue is not lightdm but your video drivers. I recommend you take a look first at Kernel Mode Setting in Arch wiki.

Hi, thanks for your help.

I am a newbie and not really understanding the arch wiki page about kernel mode setting. What exactly do I need to do?

Also, between the last post and now, I’ve tried a few more things and made some more observations:

startx flashes the screen black then terminates due to $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined

sudo lightdm works fine and brings me to my desktop, however I have to run it manually from the terminal

If I let the computer go to sleep, it will freeze on a black screen and the only way I’ve found out of it is stopping lightdm and starting it again.

Thanks again for your help.

No worries, I’m glad to help!
I had a similar issue on GDM, turns out it was the way my video drivers were loaded at boot time.

Can you post the output of the commands below:
sudo mhwd -li
sudo inxi -G

sudo mhwd -li:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

sudo inxi -G:

Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  driver: amdgpu v: kernel 
  Display: server: X.Org 1.20.10 driver: amdgpu,ati 
  unloaded: modesetting,radeon resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.39.0 
  5.9.16-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.3.1 

Looks like your driver is already working on Kernel mode by default. I would give a try to this:

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

If that doesn’t help, the problem might be the timing in which the driver is being loaded in the boot sequence. Most likely, lightdm is starting up before the video driver is ready.

You might want to play around with Early KMS as explained in the Arch Wiki.

Hope the above helps! :slightly_smiling_face:

1 Like

I’ve already tried reinstalling drivers with mhwd, so I’m going to try early kms.

I added amdgpu to modules in /etc/mkinitcpio.conf and ran mkinitcpio -P. Putting this here so I can restart and check if it works, so I don’t forget what I did.

3 Likes

Worked like a charm! Thank you so much!

You’re welcome. Cheers! :slightly_smiling_face:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.