Manjaro update/ upgrade fails

Hello. I have lost access to my old Manjaro forum account, so I created this one.
I have been trying to update my system for quite a while, but honestly been days of trying to fix the issue and nothing on this forum I found did the trick for me.

Some of the simple commands I tried are:
sudo pacman -Syyuu and its derivatives. I tried to refresh the mirrors, etc. But I always get errors, now I ended up with this following error which would not allow me to update/ upgrade my machine. Here is the error I am getting now. Whether I choose yes / no for all or none, it doesn’t matter, always ending up with the same error. I have used manjaro for about 3 years now, I have similar issues, but this one I can’t seem to resolve. Any help is greatly appreciated!

[sudo] password for userx: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] y
:: Replace libappletdecoration with community/plasma5-applets-window-buttons? [Y/n] y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
:: Replace python-dbus with extra/dbus-python? [Y/n] y
:: Replace python-dbus-common with extra/dbus-python? [Y/n] y
resolving dependencies...
:: There are 2 providers available for phonon-qt5-backend:
:: Repository extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Enter a number (default=1): 
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

Always check Announcement posts:


I love you bro/ sis!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.