Manjaro update failed, how do I proceed?

Today after updating manjaro (and likely shutdown before completed), a restart gives error message:

error file: ‘/boot/inittramfs-6.2-x86_64.img’ not found
press any key to continue
then hangs

I have a timeshift backup, but no bootable disk. How do I proceed?

Am newcomer to linux, have been using it for about a year.

You’ll have to obtain a bootable disk somewhere…either by making a new one, or stealing one, or something, or whatever…

Because I doubt this can be fixed from the emergency prompt…

1 Like

Is there one available to down load on my mac and copy to a flashdrive?

You can download and write it with anything. I’ve just never done it on Mac.

But, since it is a relatively simple process for you, I’ll go into more details for you:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

When in the chroot environment, run the following to do a complete sync of your system:

pamac upgrade && pamac upgrade --aur --devel || echo -e '\033[0;91mThere was an error upgrading the system. AUR packages not upgraded.\e[0m'

This will update your system and ONLY if that was successful update any AUR packages.

a Reminder: While use of the AUR is possible, it’s neither recommended nor supported.

I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing than pacman.


step 3 - I copied the iso file to the flash, put into drive and rebooted. Same message. How do I tell Linux to boot from it?

You have to choose the flash drive as the boot device in BIOS.

1 Like

How? Sorry.

Just copying it onto the drive won’t work. You’ll need to transfer it with Balena Etcher or dd or something similar for Mac.

Then when done, you have to select the USB drive for booting when you start the PC. It’ll give you options, I don’t really know what yours would be, but it’s displayed right at startup.

1 Like

Disk Utility on mac says no mountable partition on the iso

Well, if you received a manual with it, then you should RFTM.

If not, you can google.


It’s usually F2 or Delete

1 Like

I don’t know anything about Mac. Except that I want to keep it that way. At least for now…

1 Like

The Disk Utility on mac says
Restoring “Generic MassStorageClass Media” from “manjaro-xfce-21.2.1-220103-linux515.iso”

Validating target…
Validating source…
Could not find any mountable partitions in image “/Users/stephen/To Test/manjaro-xfce-21.2.1-220103-linux515.iso”
Could not validate source - Operation not supported
The operation couldn’t be completed. (OSStatus error 45.)

Operation failed…

I did erase the target flash drive formatting for exFAT.

I am guessing you are sayin to delete a partition with F2 or Delete? But I did not create mutiple partions.

So I am confused how to proceed.

You should be able to write the ISO to thumb drive using Balena Etcher, still:

No that’s choosing your boot method when your computer starts.



Specifically Writing to a USB Stick on a Macintosh

1 Like

Etcher worked, flash created. Thank you!

F2 puts me into bios, could not figure out more.

Is there a command that normally says to boot from a list of alternative?

No, there’s nothing standard.

But, instead of F2 you could try F8 or F12 and see if a boot menu pops up where you can select the USB drive to boot from.

1 Like

tried them but the machine ignores the flash and boots from hard drive as per the first message posted.

How about

1 Like

Thank you, but it is the Linux machine that needs to use a different startup disk, the Mac is fine.

If it helps, this is the file I used with Etcher to create the flash drive