Manjaro - Sound Not Working After Update

In Gnome,
Just updated to latest version of Manjaro and found that sound not working.
Searched in forum and found these commands -
pulseaudio -k results - E: [pulseaudio] main.c: Failed to kill daemon: No such process
pulseaudio --start enables the sound and got it working. BUT, after restart, same problem. No sound. I don’t want to run this command every time.
I have Nvidia 750 Ti graphics card. Is this the graphic driver conflict?

Anyone ?

Can’t help you, except to say you’re not alone. My problem started about the same time as yours (based on your date of post), and pulseaudio --start gets it working again but only until the next reboot.

However, I found your post because I searched from duckduckgo. I use i3, not Gnome, so the lack of responses may be because it’s not a Gnome issue.

If you posted somewhere else, or otherwise found a solution, please share.

I use the pulse audio equalizer (qpaeq) and after update i had no sound, when i was restarting i didnt start qpaeq and sound was back. Seems the problem lies in pulse audio:
I think they changed the audio driver with the last update so it has to do with new libcanberra driver (warning popped up with dependancies to pulse audio) and that the new driver somehow includes pulse, but deletes the previous settings??

( wiki . archlinux . org/title/Libcanberra )
libcanberra no longer requires any backends for ALSA, pulseaudio or gstreamer, as they are now built in to the libcanberra package.

I dont know if I’m right with this, dont have enough knowlage to solve this, but this might bring some light into the case?!

I found the solution.
commented the autospawn = no on etc/pulse/client.conf
because it was uncommented after update. I dont know which software settings did this but I found the solution somewhere yesterday.

1 Like

Check my solution. I hope it work for you too.

thank you for the fast solution, I opened the client.conf and added the missing semicolon in the line, now the equalizer works again, greets

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.