Manjaro only boots in initramfs-fallback

I installed Manjaro 20.2 on my Asus Zenbook UX433FN laptop. Since the laptop has both CPU and GPU (Nvidia), I selected nonfree drivers while installing (otherwise it wouldn’t boot to Manjaro live). After installation, I cannot boot normally and it loads a blank screen. But if I boot to initramfs-fallback, it boots normally. At first, I tried installing Nvidia drivers, but mwhd seemed to do it already yet I’m not certain the Nvidia drivers are correctly installed.

I tried rebuilding all boots using

sudo mkinitcpio -P

or more specifically the initramfs boot using
sudo mkinitcpio -g /boot/initramfs-5.4-x86_64-fallback.img

I also reinstalled and updated grub using
sudo grub-install /dev/nvme0n1
sudo update-grub

None of the attempts work and the problem persists. If anyone would suggest a solution, I would much appreciate it.

Here is my system info:

~ >>> pacman -Q linux                                                                                                                                                          
linux54 5.4.74-1
~ >>> uname -a                                                                                                                                                              
Linux berserk 5.4.74-1-MANJARO #1 SMP PREEMPT Sun Nov 1 13:43:13 UTC 2020 x86_64 GNU/Linux

~ >>> inxi -Fxxxza --no-host                                                                                                                                                
System:    Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=84346fe4-08d6-4461-a81d-ed8320c7fb23 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: ZenBook UX433FN_UX433FN v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: UX433FN v: 1.0 serial: <filter> UEFI: American Megatrends v: UX433FN.301 date: 11/21/2018 
Battery:   ID-1: BAT0 charge: 20.0 Wh condition: 40.8/50.1 Wh (81%) volts: 11.9/11.9 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: N/A status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: B (11) microcode: 98 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 901 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 901 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: ASUSTeK driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm 
           bus ID: 02:00.0 chip ID: 10de:1d12 
           Device-3: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo bus ID: 1-5:3 chip ID: 13d3:56cb 
           serial: <filter> 
           Display: x11 server: 1.20.9 compositor: gnome-shell driver: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.2.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:9dc8 
           Sound Server: ALSA v: k5.4.74-1-MANJARO 
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
           chip ID: 8086:9df0 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 17.88 GiB (3.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1002 size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 20110000 scheme: GPT 
Partition: ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) used: 17.88 GiB (3.8%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 278 Uptime: 35m Memory: 15.46 GiB used: 2.94 GiB (19.0%) Init: systemd v: 246 Compilers: gcc: N/A 
           Packages: pacman: 1178 lib: 334 flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08 

~ >>> sudo parted --list                                                                                                                                                    
Model: WDC PC SN520 SDAPNUW-512G-1002 (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      2097kB  317MB  315MB  fat32              boot, esp
 2      317MB   512GB  512GB  ext4

Hello, did you get an error while doing grub-install?

I recently had to do it and got a blocklist error.

Had to perform sudo grub-install --target=i386-pc --force /dev/sdX

Thank you for your respond. No, I didn’t get any error. Here is the result:

 ~ >>> sudo grub-install /dev/nvme0n1                                           
Installing for x86_64-efi platform.
Installation finished. No error reported.

I’m not familiar with nvme.
Can you do a lsblk and show your drives? It’s on this partition that the boot is installed?

Yes, this is the only partition I have. I have solely a 512GB SSD. And the partition nvme is split into nvme0n1p1 (fat32-boot,esp) & nvme0n1p2 (ext4), and I believe boot is installed on the former (as also shown in sudo parted --list command in the question.)

Here is lsblk output:

nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part /boot/efi
└─nvme0n1p2 259:2    0 476.6G  0 part /

Try sudo grub-install --force /dev/nvme0n1 then update-grub to see if it changes something.

I did it but unfortunately, no change.

I don’t know if this is relevant but I also tried this solution:
“Unable to find root device” on a fresh ArchLinux install
The link’s proposition also didn’t work and I hope it didn’t worsen and interfere anything. If you think that I should roll back the link’s suggestions, please notify me.

Which HOOKS did you modify?
Can you share your mkinitcpio?

I put block before autodetect as suggested in the link.

~ >>> mkinitcpio                                                                                                                                                         [1]
==> Starting dry run: 5.4.74-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [block]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Dry run complete, use -g IMAGE to generate a real image

And here is the 'HOOKS=...' line in my /etc/mkinitcpio.conf

HOOKS="base udev block autodetect modconf keyboard keymap filesystems"


Please have a look here and let us know if you did those steps

Also check this for some details about the boot loader and more things about

Thanks for sending the links. I checked both of them. I verified the steps in the link for Asus Zenbook except for power saving which is out of the context for my problem.
As for the 2nd link, Manjaro does most of the work during installation. However, i’m afraid that it has messed up the grub installation part. In the link, there is an install boot loader section, in which these comments are stated:
# pacman -S grub efibootmgr dosfstools os-prober mtools
# mkdir /boot/EFI
# mount /dev/nvme0n1p1 /boot/EFI #Mount FAT32 EFI partition
# grub-install --target=x86_64-efi --bootloader-id=grub_uefi --recheck
# grub-mkconfig -o /boot/grub/grub.cfg

I tried to run the grub-install command in the above form, but I confronted error. Do I have to follow these steps again?

Can you post the error?

Actually, it is not an error. It is a warning regarding nvme0n1 being an unknown device. I searched but it seems that others ignore this warning. I’m not certain whether it implies something important.

Here is the work I did:

~ >>> sudo grub-install --target=x86_64-efi --bootloader-id=grub_uefi --recheck
Installing for x86_64-efi platform.
Installation finished. No error reported.

~ >>> sudo grub-mkconfig -o /boot/grub/grub.cfg                                
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

~ >>> sudo update-grub                                                         
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

This is where I was talking about: warning: unknown device type nvme0n1.

I searched again and detected the problem! It was about the kernel. It turned out my system is incompatible with kernel 5.4. I installed kernel 4.19 and it booted normally. Thank you guys very much for your support and patience.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.