Manjaro not booting after removing a kernel and adding a new one

Hi, I’ve been using manjaro for quite some time but today I installed a new LTS kernel (I’m not sure if it was successful), I removed the old real time one. Other than that I had an old LTS kernel. I tried to restart my laptop (asus vivobook 14) but manjaro isn’t booting up. I have a dual boot and it does show manjaro as an option but when I try to open, it’s not working. Is there anything I can do with the grub? I currently only have kernel 5.4.116-1-MANJARO x64. Another option I get is the fallback initramfs

can you boot on USB iso manjaro

sudo manjaro chroot -a
mhwd-kernel -li
mhwd-kernel -i linux510
mhwd-kernel -i linux511
mhwd-kernel -i linux512
exit ( end chroot )

then reboot and press Esc to See Grub
go to advanced and select kernel version

you can return after

inxi -Fza 

Hi @samya-ryz5,
I suggest you to try the fallback initramfs option first, to see what happen.
You can also read the following post in order to reinstall the kernel, it is always a good practice not to remove and install the kernels at the same time. You should install the new one, reboot and then remove the old one. Perhaps, you could consider to keep both kernels whether you have problems with one of them.
If you have no response on the fallback optiion try to login from the tty with Ctrl+Alt+F2, login with your name and password and install the kernel you remove and the new one again.

Manjaro Kernels - Manjaro

Here is another post whether you could boot only in fallback mode, which could also help to find the solution.
Manjaro only boots in initramfs-fallback - #15 by Berserk

Hope this help, regards

Thank you for the help. i wanted to see if it would work without using a usb. It worked when i updated it and used the tty for installing the kernel

Thank you for your suggestion! I used the Ctrl+Alt+F2 and logged in, then I installed a new linux kernel using-
sudo mhwd-kernel -i linux511
Then I rebooted it and it worked.
`Yes! I will keep that in mind. will install, then remove after reboot.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.