Manjaro on old HP Pavilion

Hello everyone,

I’m looking for some help with installing Manjaro on an old HP Pavilion dv6. I wanted to try to upgrade it with some more RAM and a new SSD and install Manjaro on it.
This specific pavilion has Intel i5, Nvidia Geforce 320M and now 8GB of ram and and a 500g ssd.

The problems rise when trying to install some distro on it.
I tried several (every Ubuntu distro, Zorin and Mint) and none of them even boots up, I get always the same error:

kernel panic - no syncing - Attempted to kill init!

I had more luck with Manjaro but still I have some troubles during the installation. I am able to live boot and start Calamares, able to set up install configs and start the installation. Still, after creating the partitions, when the installer tries to unpack the image the installation stops, the pc freezes and the caps log starts blinking. Kernel panic again?

I also tried to run sudo calamares -d to see the debug log (which I can’t post for the freezing problem) but the last few lines say:

00.13.13 [6]: static CalamaresUtils::ProcessResult CalamaresUtils::System::runCommand(CalamaresUtils::System::RunLocation, const QStringList&, const QString&, const QString&, std::chrono::seconds)
Running "env" ("mount", "-t", "squashfs", "-o", "loop", "/run/miso/bootmnt/manjaro/x86_64/root.sfs", "/tmp/tmpw8bmitk5/rootfs")
.. Finished. Exit code: 0 output:
mount: /tmp/tmpw8bmitk5/rootfs: WARNING: source write-protected, mounted read-only.

00.13.13 [6]: static CalamaresUtils::ProcessResult CalamaresUtils::System::runCommand(CalamaresUtils::System::RunLocation, const QStringList&, const QString&, const QString&, std::chrono::seconds)
Running "env" ("udevadm","Settle")
.. Finished. Exit code: 0

00.13.13 [6]: static CalamaresUtils::ProcessResult CalamaresUtils::System::runCommand(CalamaresUtils::System::RunLocation, const QStringList&, const QString&, const QString&, std::chrono::seconds)
Running "env" ("sync")
.. Finished. Exit code: 0

and after that it freezes, nothing more.

Also, I’m trying to install Manjaro BIOS mode, with the boot loader on the MBR of the SSD: the laptop is really old, I have basicall no settings in the BIOS: I have a little power saving management, cpu virtualization and fan always on/off. I know a lot of problems comes from the CSM mode, but I have no way of checking that setting.

The SSD should not have any problem, since I previously tried on the installed HDD and the problem was the same.

Any suggestion? Would be really appreciated. Thanks!

Hello @NicolaM94 :wink:

So let me summarize:

  1. Any other Distro, when booting from a USB, got a kernel panic.
  2. Manjaro starts, but freeze after a sync.

So the sync is definitely related to the flash drive where the squashfs image is located. udevadm settle is command that just waits until the mount process succeed.

So judging, I would say your flash drive is defect, and by mounting root.sfs you triggered a badblock on the flash drive, which leads to this problem.

Thanks for the reply, my head is hurting a bit less now :pray:
Unfortunately I tried two different flash drives and both lead me to the same error. Still, you gave me an interesting idea: I tried to flash both drives with Etcher, maybe I’ll give a shot with Rufus! Maybe tweaking a bit with that one will give me some more hope.
Thank you very much, can I leave the thread open to share any update? …If I ever manage to get one :thinking:

Maybe try also Ventoy

Quick update: no results with both Rufus and Ventoy.
Always the same error: Calamares stuck at
unpacking image 1/2 and laptop freezes.
I really have no idea at this point!

So you can boot Manjaro… can provide some system information?

inxi --full --admin --filter --width 80

Test the flash drive, if it contains badblocks:

sudo badblocks -w -s -o ~/usbstick_log.txt /dev/sdz

:warning: Of course it cannot be the device which is used for booting. It must be unmounted.

Also check if the ISO matches the SHA1 checksum on the download page.

I did the badblocks test, the log was empty. From console:

sudo badblocks -wso ~/usb_log.txt /dev/sdb
Testing with pattern 0xaa: done                                                 
Reading and comparing: done                                                 
Testing with pattern 0x55: done                                                 
Reading and comparing: done                                                 
Testing with pattern 0xff: done                                                 
Reading and comparing: done                                                 
Testing with pattern 0x00: done                                                 
Reading and comparing: done

No errors shown.
I previously ran a test on the drive directly with Rufus, which also gave me no errors.

More specs from the laptop:

inxi --full --admin --filter --width 80 > ~/inxi.txt
  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=it tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCEM_2112 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Hewlett-Packard product: HP Pavilion dv6 Notebook PC 
  v: 049D210000241210000020000 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 3659 v: 32.25 serial: <filter> 
  BIOS: Hewlett-Packard v: F.1C date: 05/17/2010 
  Info: Dual Core model: Intel Core i5 M 430 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 2 microcode: 11 cache: 
  L2: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 18092 
  Speed: 1463 MHz min/max: 1199/2267 MHz boost: enabled Core speeds (MHz): 
  1: 1463 2: 1441 3: 1388 4: 1463 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GT216M [GeForce GT 320M] vendor: Hewlett-Packard 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:0a2d class-ID: 0300 
  Device-2: Quanta HP Webcam type: USB driver: uvcvideo bus-ID: 2-1.5:3 
  chip-ID: 0408:03f1 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: NVA5 v: 3.3 Mesa 21.2.1 direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:3b56 class-ID: 0403 
  Device-2: NVIDIA GT216 HDMI Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0be2 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Device-1: Broadcom BCM43225 802.11b/g/n vendor: Hewlett-Packard 
  driver: bcma-pci-bridge v: N/A modules: bcma port: 6000 bus-ID: 02:00.0 
  chip-ID: 14e4:4357 class-ID: 0280 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  IF-ID-1: wlp2s0b1 state: down mac: <filter> 
  Local Storage: total: 454.6 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G 
  size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  type: SSD serial: <filter> rev: 1103 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Lexar model: JD FireFly 
  size: 7.47 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1100 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No partition data found. 
  Alert: No swap data was found. 
  System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 60.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 214 Uptime: 1m wakeups: 2 Memory: 7.76 GiB 
  used: 1022.3 MiB (12.9%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 958 lib: 268 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 

Edit SHA1 is correct:

[nicola@nicola-desktop Downloads]$ sha1sum manjaro-xfce-21.1.2-minimal-210904-linux513.iso
12db54e62da3eaa036f3eef40e10de57a8c57b69  manjaro-xfce-21.1.2-minimal-210904-linux513.iso


Well then, we have ruled out the usual sources of error.

I would say that some part of the hardware is defect. A Kernel Panic appears always when a core module cannot run properly. It can be the RAM, HDD, PCIE, GPU …

Maybe it is a feature on kernel 5.13 which leads to this? Try maybe the ISO with kernel 5.4? It is the so called Minimal LTS

Maybe an Update of the BIOS could solve it?

It could be also possible that the nouveau driver did this or the GPU is vastly overheating… No idea, since the hardware is old…

1 Like

Have you run a memtest (RAM) and let it go through a few passes to make sure? It’s another possible culprit to rule out.

Thanks for the advice, I will give a shot with the 5.4!
I know the hardware is so old it’s hard even to find solutions on the internet, so double thanks for the troubleshooting.
What really intrigues me is that the pc is perfectly running with the live boot, so I can’t see how an HW failure could lead me to this. Only when I try to install it it freezes, that’s really annoying…
Anyway, I’ll give a shot with the minimal kernel and let you know. Thanks again!

Thanks for the reply!
I did a memtest directly from the BIOS, because if I try from GRUB it says that can’t find the mount point for the memtest.
The test passed right away with no errors anyway, plus the ram module is recognized from the bios if I check system informations.

Not sure how much I would trust those quick RAM tests that are included in some BIOS setups.

A proper memtest would run multiple passes, and take some time to complete.

The reason for ruling out bad RAM is because a faulty memory address might be exposed when extracting a large file, such as the squashfs during installation. Which is why simply detecting the sticks won’t tell you if there’s a problem until your system happens to hit that area.

You can boot from System Rescue CD (USB) and try running memtest from either the boot menu (if booting in legacy mode), or from within the live system from a terminal.

1 Like

Last update (I guess?)

Turns out it might actually be a RAM problem. I tried with System Rescue but the ram test keeps crashing and rebooting the machine. Swapping with the old banks of rams seems to solve the problem, but leaves me with 4gb of ram.

That said, I’m not yet sure about what the problem is. My options are these:

  1. Both 8gb banks of ram are faulty;
  2. The system does not support a single bank, it needs 2 to work;
  3. The banks I bought are not compatible.

So maybe I’ll try with 2 banks of 4gb to fill the slots and reach the max of 8gb.

What do you think?

Thanks again for everything! :grinning_face_with_smiling_eyes:

Sounds similar to a problem I had with a faulty RAM stick when I built a custom PC for someone else a while back. We ended up using a single stick until the replacement arrived from Amazon, in which we could safely use both new sticks together as dual-channel. (Once we confirmed all was well, we returned the previous dual-channel kit.)

See if you can proceed with the installation on a known good stick (or your 4GB known working setup.)

If you are able to successfully finish the installation, then it does indeed strongly hint at bad RAM. You can use Manjaro on 4GB of RAM in the meantime, while you decide how to move forwards, perhaps ordering a new dual-channel kit? While it’s safe to mix-and-match RAM, it can sometimes yield strange behaviours if they are different timings (“latency”) and speeds, not to mention brands. I like to stick to the same brands / timings.

I thought I could do that too. I bought 2 sticks of 8gb of ram, that’s why I think it’s a bit implausible that are both faulty. Still, it does not support 16gb of ram and I tried with one single stick. No results.

I think I’ll try with 2 banks of 4gb, to me the problems is that it needs 2 sticks of ram to work properly.

Installation completed with no problems on 4gb! Maybe I’ll try to experiment some more in the future though, rams sticks are so easy to detach :grimacing:

Thanks everyone again for the help, it was fun to tweak and tinker!

Bad RAM strikes again!


But now you got Manjaro installed, and so there’s no time constraint on getting a different RAM kit.

For future reference, you mean your HP Pavilion cannot read all 16GB if they are installed? (It only reads 12, for example?)

It might be possible to do two sticks of 4GB each, dual-channel, get yourself a comfy 8GB total. :sunglasses:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.