Manjaro not visible in boot manager and not booting in grub

I succesfully installed manjaro(kde) alongside windows 10 but when i clicked the reboot now button. It did not boot into grub/manjaro but windows directly, I restarted in order to manually boot into manjaro through the boot manager but manjaro was not there in the uefi boot menu(for some reason I am not able to attach the photos). I do have a bit of experience with manjaro as I was using manjaro-gnome before but this has happened for the first time. I did some googling nd tried to reinstall and recover grub from manjaro wiki (title: rescue the grub bootloader, again not able to attach a hyperlink ) and I probably did the same thing but it still nothing. If you know anything please do share!

EDIT: I tried installing it in virtual machine too but its nothing just a black screen after rebooting and ejecting the iso.

Hi @NoobGamer2703, and welcome!

Have you ensured secure boot and fast boot is turned off in the BIOS? Sounds like it could be something like that.

If it is disabled, well, then I’ m out of ideas. :man_shrugging:

Boot your live ISO, chroot into Manjaro, open a terminal and enter

inxi -Fxxxza
lsblk -f
parted -l
test -d /sys/firmware/efi && echo efi || echo bios

and post the output.

Also make sure you have fully shutdown Windoze and not only hibernate, which often is the case.

Yeah both secure and fast boot are turned off. Thanx anyways.

the output:

  Kernel: 5.10.26-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC misobasedir=manjaro misolabel=MANJARO_KDE_2101 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 320-15ISK 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> 
  UEFI: LENOVO v: 4WCN29WW date: 09/30/2017 
  ID-1: BAT0 charge: 14.6 Wh (97.3%) condition: 15.0/35.0 Wh (42.9%) 
  volts: 8.4 min: 7.6 model: LGC L16L2PB3 type: Li-poly serial: <filter> 
  status: Unknown 
  Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: E2 
  cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 16006 
  Speed: 500 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: 
  conditional, IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:1921 class-ID: 0300 
  Device-2: NVIDIA GM108M [GeForce 920MX] vendor: Lenovo driver: nouveau 
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:134f class-ID: 0302 
  Device-3: Acer EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:5 
  chip-ID: 5986:210f class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) 
  v: 4.6 Mesa 21.0.1 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d70 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.26-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth 
  driver: iwlwifi v: kernel port: 3000 bus-ID: 03:00.0 
  chip-ID: 8086:3166 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus-ID: 1-7:4 chip-ID: 8087:0a2a class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] 
  driver: ahci v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086.282a 
  rev: 21 class-ID: 0104 
  Local Storage: total: 946.91 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LCM2 
  scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: MXT-USB Storage Device 
  size: 15.4 GiB block-size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1308 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Partition data was found. 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 200 Uptime: 3m wakeups: 1 Memory: 7.56 GiB 
  used: 1.89 GiB (25.0%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1217 lib: 326 flatpak: 0 Shell: Bash 
  v: 5.1.0 running-in: konsole inxi: 3.3.03

the output: the sdb is my usb, sda8 - efi partition (fat32), sda9 - swap, sda10 - partition on which i installed manjaro

     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
│    ntfs         Recovery
│                       F2F863E4F863A617                                    
│    vfat   FAT32 SYSPART
│                       6687-3F69                                           
│    ntfs               5662CC4162CC2817                                    
│    ntfs               30F88711F886D48E                                    
│    ntfs         Dhruv D2EECF3FEECF1A9D                                    
│    ntfs               346EF27A6EF23468                                    
│    vfat   FAT32 NO_LABEL
│                       32ED-866C                                           
│    swap   1           24a97ff1-0fdc-45fa-8325-a72a5f7d6b2c                
     ext4   1.0         eaff4c47-8c6d-4083-bc6f-1f02ddf6c02d                
sdb  iso966 Jolie MANJARO_KDE_2101
│                       2021-04-10-10-33-18-00                     0   100% /run/miso/
│    iso966 Jolie MANJARO_KDE_2101
│                       2021-04-10-10-33-18-00                              
     vfat   FAT12 MISO_EFI

the output: no output

[manjaro@manjaro ~]$ parted -l
[manjaro@manjaro ~]$

the output:

[manjaro@manjaro ~]$ test -d /sys/firmware/efi && echo efi || echo bios
[manjaro@manjaro ~]$ 

That’s all.

Have you set the boot order in your UEFI firmware to boot from the newly implemented EFI partition /dev/sda8 to boot Manjaro’s grub?

Please, also share output of

sudo parted -l

there was no output for it it was just like I shared before

[manjaro@manjaro ~]$ parted -l
[manjaro@manjaro ~]$

With sudo it must…

and also, what does it mean, when I installed linux for the first time I made the respective distro as priority but this time manjaro wasn’t there.
nd how do I do it manually I don’t see an option for manjaro in the boot manager that’s what I am saying.

Boot manager is not firmware, at least it is not clear what you mean by that. If you have no option to boot into Manjaro from your UEFI firmware then something went wrong when you installed.

Again, please provide output of

sudo parted -l

It can’t be nothing. It provides information about sizes of your partitions.

okay I don’t know about that but, I installed it 3 times nd it was still the same :sweat_smile:.

the output was there with sudo this time :sweat_smile:

[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST1000LM035-1RK1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  524MB   523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB   105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB   16.8MB                  Microsoft reserved partition  msftres
 4      646MB   318GB   317GB   ntfs            Basic data partition          msftdata
 5      318GB   319GB   544MB   ntfs                                          hidden, diag
 6      319GB   581GB   262GB   ntfs            Basic data partition          msftdata
 7      581GB   895GB   315GB   ntfs            Basic data partition          msftdata
 8      895GB   895GB   33.6MB  fat32                                         msftdata
 9      895GB   900GB   4245MB  linux-swap(v1)                                swap, legacy_boot
10      900GB   1000GB  101GB   ext4

Model: MXT-USB Storage Device (scsi)
Disk /dev/sdb: 16.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2842MB  2846MB  4194kB  primary               esp

Here you are. You have a disk with physical sector size of 4096 Bytes, in this case I would not use the EFI partition (no. 2) of Windoze (it’s too small) but use a separate one. You have a partition (no. 8) which looks like it should be your new EFI partition, but it’s not flagged as EFI partition and it’s too small as well, it should be at least 500 MiB. So assigning EFI partition and size of new EFI partition was most likely not OK when you installed Manjaro. Try again.

It’s the first time I made the no.8 partition so small usually it used to be 512Mb, but i’ll make one with 1Gb if you say so because with manjaro gnome and other distros 512 mb would work that’s why.

Nd also why isn’t the no.8 flaged with efi it should be I guess and if not then how do I make it happen
in short how do I boot into manjaro/grub :sweat:.

You simply need to set the esp and boot flag (means removing boot flag from partition no. 2). 500 MiB is enough. If you prefer 512MB - that’s fine.

okay so now I installed it again but the same thing it doesn’t appear in the boot manager, and now when i am checking from the live usb the flags are gone.
how do i mount them again and save it?

how do I do it?

and thanx for staying with me for so long :grin: .

Hello @NoobGamer2703 :wink:

Here is an example whch works on my laptop:

$ LANG=C sudo parted -l
Model: ATA ST320LT012-1DG14 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16,8MB               Microsoft reserved partition  msftres
 3      123MB   51,9GB  51,8GB  ntfs         Basic data partition          msftdata
 4      51,9GB  52,4GB  538MB   ntfs                                       hidden, diag
11      52,4GB  52,5GB  105MB   fat32        efi_manjaro_xfce              boot, esp
 5      52,5GB  320GB   268GB   ext4         manjaro_xfce

You have to do manual partitioning and set the new efi partition (explicitly choose the correct efi partition). Also flag in gparted both efi partitions with “boot”. Now you should be able to boot both through the efi.

1 Like

yeah but there aren’t any flags, but this time I noticed something all the times whenever I was done with my installation nd clicked reboot now there comes this number of processes where I noticed that one process has failed which was

failed  /run/miso/bootmnt

is this why manjaro doesnt show up in my UEFI firmware and the boot manager?


You did a fresh installation. Could please post:

 sudo parted -l

and (when booted into your local drive OR on a live session with manjaro-chroot -a

sudo blkid
cat /etc/fstab