Manjaro not showing in GRUB. After messing around, cannot get into GRUB at all

Hi everyone, I REALLY screwed something up.

After doing a full system update a couple days ago, Manjaro was no longer appearing in my boot list in GRUB. GRUB had a shiny new look, which I’m guessing means a new GRUB update messed things up. I realize this is a common issue popping up here in the last few months, and I should have checked those threads before trusting random Google results.

After trying random things suggested around the internet, I cannot boot into GRUB at all. My Manjaro partition has the highest boot priority. When I power my computer on, instead of booting into GRUB, I instead get a black screen. After a few seconds, my computer switches itself off and reboots into the BIOS. From there, I’m still able to boot into Windows (I am dual-booting). I’m guessing my BIOS is smart enough to reboot into the BIOS when I am unable to load GRUB.

Because of my (very) limited understanding of BIOS/EFI, mounting, bootloaders, I am unsure what to do now. I am afraid of messing my system up even further.

If it is useful, here is the output of fdisk -l after I manjaro-chroot from a live USB (only showing the output including the “Device”, “Start”, etc. columns):

Device          Start        End    Sectors   Size Type
/dev/sda1        2048    1085439    1083392   529M Windows recovery environm
/dev/sda2     1085440    1288191     202752    99M EFI System
/dev/sda3     1288192    1320959      32768    16M Microsoft reserved
/dev/sda4     1320960 1426877101 1425556142 679.8G Microsoft basic data
/dev/sda5  1426877103 1953523711  526646609 251.1G Linux filesystem

Device     Boot      Start        End    Sectors  Size Id Type
/dev/sdb1  *          2048     206847     204800  100M  7 HPFS/NTFS/exFAT
/dev/sdb2           206848 3906105343 3905898496  1.8T  7 HPFS/NTFS/exFAT
/dev/sdb3       3906105344 3907026943     921600  450M 27 Hidden NTFS WinRE

Additionally, here is the output of lsblk -f after I manjaro-chroot from a live USB:

NAME   FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
loop0                                         
loop1                                         
loop2                                         
loop3                                         
sda                                           
|-sda1                                        
|-sda2                          117.9G    47% /boot/efi
|-sda3                                        
|-sda4                                        
`-sda5                          117.9G    47% /boot/efi
sdb                                           
|-sdb1                                        
|-sdb2                                        
`-sdb3                                        
sdc                                           
|-sdc1                                        
`-sdc2

Any ideas?

The best you can do is to create a usb iso live system, boot it and, from there, chroot into the system and try to restore GRUB.

1 Like

I have already tried to the GRUB restoration process several times. No luck.

Also, UPDATE: I can no longer boot into Windows either. When I try to boot into Windows from my BIOS bootloader, nothing happens.

I’m a full-time student and I’m really in trouble. I was hoping somebody could identify an issue with my BIOS/EFI settings or something similar.

do you have a /home partition separate ? if so try reinstalling the system maintaining your /home parition

Additionally, here is the output of lsblk -f after I manjaro-chroot from a live USB:

1 - please DO lsblk -fs BEFORE chroot
2 - under chroot see for cat /etc/fstab
3 - report sudo parted -l ( full report )

check before UUID from /etc/fstab & lsblk -fs

1 Like

@stephane Here is lsblk -fs before chroot:

NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash 4.0                                                    0   100% /run/miso/
loop1
     squash 4.0                                                    0   100% /run/miso/
loop2
     squash 4.0                                                    0   100% /run/miso/
loop3
     squash 4.0                                                    0   100% /run/miso/
sda1 ntfs         Recovery
│                       263CE62C3CE5F6A9                                    
└─sda
                                                                            
sda2 vfat   FAT32       32E8-124F                                           
└─sda
                                                                            
sda3                                                                        
└─sda
                                                                            
sda4 ntfs               3622EC1822EBDB3F                                    
└─sda
                                                                            
sda5 ext4   1.0         e8632386-21b1-468a-8e96-fc5e733c9db7                
└─sda
                                                                            
sdb1 ntfs         System Reserved
│                       5C96630A9662E44C                                    
└─sdb
                                                                            
sdb2 ntfs               B206658106654805                                    
└─sdb
                                                                            
sdb3 ntfs               20BC2F79BC2F489C                                    
└─sdb
                                                                            
sdc1 iso966 Jolie MANJARO_KDE_2012
│                       2020-10-19-13-06-32-00                              
└─sdc
     iso966 Jolie MANJARO_KDE_2012
                        2020-10-19-13-06-32-00                     0   100% /run/miso/
sdc2 vfat   FAT12 MISO_EFI
│                       DBA6-6BFC                                           
└─sdc
     iso966 Jolie MANJARO_KDE_2012
                        2020-10-19-13-06-32-00                     0   100% /run/miso/

Here is cat /etc/fstab after using manjaro-chroot:

UUID=32E8-124F                            /boot/efi      vfat    umask=0077 0 2
UUID=e8632386-21b1-468a-8e96-fc5e733c9db7 /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

And here is sudo parted -l after manjaro-chroot:

Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  556MB   555MB   ntfs         Basic data partition          hidden, diag
 2      556MB   660MB   104MB   fat32        EFI system partition          boot, esp
 3      660MB   676MB   16.8MB               Microsoft reserved partition  msftres
 4      676MB   731GB   730GB   ntfs         Basic data partition          msftdata
 5      731GB   1000GB  270GB   ext4


Model: ATA ST2000DM001-1ER1 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  106MB   105MB   primary  ntfs         boot
 2      106MB   2000GB  2000GB  primary  ntfs
 3      2000GB  2000GB  472MB   primary  ntfs         msftres


Model: Samsung Flash Drive (scsi)
Disk /dev/sdc: 64.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3079MB  3083MB  4194kB  primary               esp

@WernerRomling It’s been quite a while since I installed Manjaro, so I am unsure if I have a separate /home partition. I do not think so, because I have a /home/ directory in my root directory.

So, Your System was working previously ? How much time did it work fine ? Because by this log of sudo parted -l looks like you have 2 boot partitions on 2 different drives

@WernerRomling Yes, my system was working fine until I did a system upgrade a couple days ago (when GRUB updated). I had this system working for about 11 months. My PC has a SSD that is dual-booted with Manjaro and Windows. That is what I primarily use. My system also has a 2TB hard drive that is from an older computer of mine. Feel free to ignore the 2TB hard drive entirely.

1 Like

Are you sure that other HDD is not the problem ? it has a boot partition too

Strange, Usually the EFI partition has to have 200MB up to 512MB of size:

https://wiki.manjaro.org/index.php/UEFI_-_Install_Guide#Switching_from_BIOS_to_UEFI

Be patient, @stephane will probably have more insight of what is the cause of the problem, since it was her?him? that asked you the logs. By the way your system is configured there’s still recovery. I have ask too, @Soup did you use timeshift ? it could be of help

can you report

sudo efibootmgr -v

i think that micro$oft has removed entry UEFI that are not window$

1 Like

@stephane
Here is the output of sudo efibootmgr -v before manjaro-chroot:

BootCurrent: 0006
Timeout: 1 seconds
BootOrder: 0000,0001,0005,0006,0007
Boot0000* Windows Boot Manager  HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb00
7,0x109000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x.
..B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.
2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* manjaro       HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb007,0x1090
00,0x31800)/File(\EFI\manjaro\grubx64.efi)
Boot0005* Linux Boot Manager    HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb00
7,0x109000,0x31800)/File(\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI)
Boot0006* UEFI: Samsung Flash Drive 1100        PciRoot(0x0)/Pci(0x14,0x0)/U
SB(4,0)/CDROM(1,0x5bc3c0,0x8000)..BO
Boot0007* UEFI: Samsung Flash Drive 1100, Partition 2   PciRoot(0x0)/Pci(0x1
4,0x0)/USB(4,0)/HD(2,MBR,0x0,0x5bc3c0,0x2000)..BO

And here is the output of sudo efibootmgr -v after manjaro-chroot:

BootCurrent: 0006
Timeout: 1 seconds
BootOrder: 0000,0001,0005,0006,0007
Boot0000* Windows Boot Manager  HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb007,0x109000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.
4.d.4.7.9.5.}...a................
Boot0001* manjaro       HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb007,0x109000,0x31800)/File(\EFI\manjaro\grubx64.efi)
Boot0005* Linux Boot Manager    HD(2,GPT,b8aaf972-4da4-4d27-9e01-4c15313fb007,0x109000,0x31800)/File(\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI)
Boot0006* UEFI: Samsung Flash Drive 1100        PciRoot(0x0)/Pci(0x14,0x0)/USB(4,0)/CDROM(1,0x5bc3c0,0x8000)..BO
Boot0007* UEFI: Samsung Flash Drive 1100, Partition 2   PciRoot(0x0)/Pci(0x14,0x0)/USB(4,0)/HD(2,MBR,0x0,0x5bc3c0,0x2000)..BO

@WernerRomling No, I have not used TimeShift.

Looks lik, for me that you have 2 boot managers.

@WernerRomling Yes, I added the second boot manager (Linux Boot Manager) after I could no longer boot into GRUB. I was still having the GRUB issue before I tried adding the Linux Boot Manager (which I believe is systemd-boot-manager). The problem still existed without the second boot manager.

I can’t ask you to do anything since I can’t reproduce the problem, but May I ask if previously you had only the Linux Boot Manager or only the windows boot manager?

Hi everyone, I ended up doing a full reinstall of both operating systems. I had several projects due and could not afford to spend anymore time fixing my existing setup. It’s unfortunate GRUB decided to break itself (and even more unfortunate that I screwed it up even worse). Thanks to everyone for their help, though!

1 Like