Manjaro not recognising/unable to partition M.2 ssd (trying to dual boot with windows)

I was installing manjaro on my asus fx505dt
It has
512gb M.2
500gb WD Scorpion
8gb ram
GTX 1650
Ryzen 3550H

And during install it threw out this error

imgur com/a/ysYJbOk

I rebooted, it did not recognise the SSD
Then I rebooted again and it recognised the SSD
But threw out the same error
So I partitioned the drive through gparted but then the same error. The drive has windows on it.
The SSD is in AHCI
Safe and Fast boot is off
I am installing with open source drivers
Version is Nibia 20.2

Here is the lsblk

imgur com/a/ysYJbOk

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information in your posts - Tutorials - Manjaro Linux Forum
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

    An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  2. Please also read this:
    [HowTo] post screenshots and links
    because imgur needs cookies so a lot of us can’t see those.