Manjaro Live Boot (USB) fails

Ladies and Gentleman: I am stucked. :slight_smile:

As already mentioned by some others, most prominently here - Not able to boot Manjaro USB - I also have the problem of Manjaro Live not booting to the GUI, meaning, I can not install Manjaro.

I have used manjaro for two years now and was more than happy and glad to finally get rid of Windows, without being forced in the Ubuntu world. Now I configured a new Desktop PC:
CPU: AMD Ryzen 5 3600
Board: MSI Tomahawk MAG X570 (AM4)
GPU: Nvidia RTX 3070

I tried to install manjaro, but got stuck at this:

Removing the ‘quiet’ parameter from the boot options shows exactly the same output above. I also tried different versions of manjaro (older kernels in all variations), but to no prevail.

Secure boot is disabled, I tried the free drivers and I also tried most of the steps (ACPI related) from the “Not able to boot Manjaro from USB” thread. What really quirks me, is that there does not seem to be any error related to the stuck situation. See the journalctl -b -0 --reverse output here:


continued…

I am completely lost. I do not want to return to Windows and I need my Desktop PC for my work up and running asap.

I am glad for any assistance.
Julius

Addendum: When I mask TLP in the grub menu of the live boot via systemd.mask=tlp.service, it gets stuck at Reached target Graphical Interface.

I suggest, it must be the new RTX 3070 - not supported?

Hello and welcome on the forum. If I’m right, this GPU just came out. I guess it’s not yet kernel supported.
Does it appear yet on Nvidia website, under supported Linux drivers?

2 Likes

Try booting with free drivers You can always change after manjaro is installed.

1 Like

It really does look like a screen card/graphics driver issue, as you suspect?

Just a suggestion I have is to use a different screen card, or as suggested to change the drivers. Unfortunately I do not know how to do that from the GRUB start up menu.

Try using a different graphics card.

Hi Falav,

Yes, it is officially supported:
https://www.nvidia.de/Download/driverResults.aspx/166227/de

Also, it definitely runs on other Distros, because:
https://www.phoronix.com/scan.php?page=article&item=rtx3080-linux-gaming&num=1

Additionally, I did notice that, when using non-free Drivers, the startup terminal does change the resolution to monitor native, meaning, a driver is being fired up.

The problem is Arch/Manjaro specific it seems.

As stated in the original post, I tried both, of course :slight_smile:

Using a different setup is not really an option in my use case. The hardware components should be Linux compatible (says this internet) :slight_smile:

Yes agreed. What I meant is that if you have another graphics card to temporarily use to confirm it is the driver for your current card.

If that is the case Manjaro will boot successfully. Then you can change the drivers after which you can reinstall your nVidia card again to debug further.

1 Like

Hi @Knecker … the gpu is really new. Just checked the versions:

While 455.28 support 3080/3090, it does not support 3070. You need version 455.38 of the nvidia driver. There is 3070 support included.

Check it here:

https://download.nvidia.com/XFree86/Linux-x86_64/455.28/README/supportedchips.html

https://download.nvidia.com/XFree86/Linux-x86_64/455.38/README/supportedchips.html

I assume then at your iso is 455.28 included and not 455.38, Did you try installing with architect iso?

2 Likes

Hi @megavolt, if I’m correct he cannot boot at all from Iso and get to LiveCD environment.
But yes maybe architect iso would work, as I guess there is no GUI?

1 Like

Hi @Falav :wave:

Yes, the architect version just uses the vesa driver, which works on all gpu cards. It is just the command line and have a menu which guide you through the setup process step by step. But then you will have the current drivers installed.

2 Likes

Thank you everyone for your help! The architect dit the trick, though I have to admit, for a noob this is a very very complicated matter :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.