Manjaro fails to ask for / save / acess passwords (?)

Hi everyone,

recently, I bought a new system and was forced to install Manjaro (KDE) via the Architect. See this post for reference why:

I suceeded though and the installation worked out fine.

Unfortunately, now I encounter a very strange bug. It occured for the first time when trying to connect to WiFi: After entering my password, the Networks Tab would blink for a second, then stating “No available connections”. By chance, I changed the Wi-Fi Security setting to from encrypted to “Store Password for all users (not encrypted)”. Then miraculously, it connected!

Now, I plugged in an LUKS-encrypted external HDD, which I used on my laptop shortly before that. It gets recognized, but when trying to decrypt - meaning opening dolphin and clicking on the removable device - there is no password prompt. Nothing happens.

Also: When using the package manager (trying to update or install something), it says “Authentication failed”.

Ouch.

Something is off… Manjaro does not seem to be able to handle decryption. Or the KDE Wallet ist corrupt? I have no idea…
I am afraid, I missed something (a package) when installing via Architect?

Any help would be much appreciated.

Solved it by reinstalling. Maybe I accidently deleted an important “orphan”. Still it would be interesting to know, what could’ve caused it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.