Manjaro keeps randomly crashing on a fresh installation

hi everyone so im a newbie to linux i just recently shifted to manjaro os and for like some reason i have this weird issue with the os crashing randomly while i was surfing the web

then happened again while streaming a video im not really sure what to do cause this is getting kinda annoying thinking of going back to windows if i can’t fix this lol also i was speaking with a friend of mine and he says he also has the same issue regarding the random crashes so im not really alone in this situation :frowning:

all my drivers are updated and im on the latest kernel as well

  Kernel: 6.4.0-2-rt6-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.4-rt-x86_64
    root=UUID=a0c5e70a-47ef-4ae8-a0ed-d147ab7e8e5c rw quiet splash
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 3
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude E7470 v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 0T6HHJ v: A00 serial: <superuser required> UEFI: Dell
    v: 1.16.4 date: 06/02/2017
  ID-1: BAT0 charge: 0% condition: 5.9/55.0 Wh (10.8%) volts: 6.9 min: 7.6
    model: LGC-LGC3.65 DELL 242WD75 type: Li-ion serial: <filter>
    status: not charging
  Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3029 high: 3400 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3400 2: 2890 3: 2492
    4: 3335 bogomips: 22399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell Latitude E7470
    driver: i915 v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:1916 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:2 chip-ID: 0bda:5686
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel HD Graphics 520 (SKL
    GT2) direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell Latitude E7470
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
    snd_sof_pci_intel_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  API: ALSA v: k6.4.0-2-rt6-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.75 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I219-LM vendor: Dell Latitude E7470 driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: wwp0s20f0u5i12 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:5 chip-ID: 8087:0a2b
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 30.44 GiB (12.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: KSG60ZMV256G M.2 2280
    256GB size: 238.47 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 4102 scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 30.44 GiB (13.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 53.0 C pch: 46.0 C mobo: 43.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
  Processes: 225 Uptime: 22m wakeups: 2 Memory: total: 16 GiB
  available: 15.51 GiB used: 2.85 GiB (18.4%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 1360 pm: pacman pkgs: 1344 libs: 370 tools: pamac pm: flatpak
  pkgs: 16 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.28```


hi i just done that :slight_smile:

Your BIOS is out of date.

You may want to add swap.

how would i go about doing that " adding swap " ? sorry x_x im completely new to linux world

Welcome to the forum! :vulcan_salute:

What exactly are the symptoms of what you call “a crash”? That’s a very vague term that could mean just about anything — and it often does.

Can you still toggle the NumLock key when it “crashes”? Also, your CPU temperature appears to be a bit on the high side, which could indicate either a hardware problem — i.e. inadequate cooling — or simply a stuck process.

I also notice that you’re running Plasma on Wayland. Have you tried running on X11 instead?

Lastly, I would advise you to try a different kernel. You’re running 6.4, which is still bleeding edge. Try the 6.1 LTS kernel instead. It’s already quite mature and it’s still supported until at least December 2026 — it’s a long-term-support kernel, hence the LTS moniker.

Note: After installing the new kernel, you’ll need to select it at the GRUB boot menu. :arrow_down:

Advanced Options for Manjaro Linux → Linux 6.1

With 16 GiB of RAM and less than 3 GiB in use, that’s not really necessary. I also have 16 GiB and I too run without swap here. Even with lots of stuff open — including chromium — I’m still only hitting 3.2 GiB of RAM usage. :wink:

Hi and welcome to the Forum :+1:

One difference between Linux and Windows you need to understand is that Linux doesn’t give any BSOD due to usage of some applications…
You might think your OS has crashed while in fact it is still running perfectly fine under the hood, it’s just your application that can crash and give that impression.

So think 10x before even thinking of going back to Micro$@$ :rofl:

If you use video intensive application it might over heat your Laptop which might cause your graphics driver to become non-responsive because your GPU shutdown due to the overheating.

How is this a Fresh install? :thinking:

1 Like

@Aragorn no num lock lights show when i get the crashes it use to work when i press alt+ tab but now nothing at all

how do i activate X11 ?

i will switch kernels and let you know whay happens :slight_smile:

im gonna do a little maintenance on this laptop during the weekend cause i need to replace the keyboard on here " though on windows i never use to have this issue with high cpu

will update on the kernel switch out :slight_smile:

Don’t use the rt kernels. Try another one.


i recently changed kernal’s been using manjaro for a few days now so like i said before this is a new install of manjaro os lol

That is not what I meant. If you can still switch NumLock on and off, then the kernel is still alive, and then whatever crashes is something at a higher level — possibly Plasma or just your browser.

That sounds like Plasma, but it is possible that you may have to wait longer due to a stuck process. If there’s a process consuming all of your CPU cycles, then what you’ve got is a local denial-of-service, and then the system needs (a lot more) time to process the Alt+Tab.

It should be available as an option on the login screen.

There is currently a kernel bug that appears to consume 100% CPU load, but that’s only a cosmetic bug. In reality, it all still works fine. Your CPU temperature on the other hand is a better indicator.

I was going to say that next. :wink:

Don’t use an -rt kernel unless you know what you’re doing. Those kernels have special patches for real-time responsiveness, which is often a demand among people who do professional audio and/or video processing.

If you’re not one of those people, use a regular kernel, and preferably one of the still supported LTS kernels, i.e.:

  • 4.19
  • 5.4
  • 5.10
  • 5.15
  • 6.1

so i’ve done that and also can i change kernals by just removing the one i currently have ?

os still crashes though

You can change kernels by using your menu in your bootloader, IF you have multiple kernels installed…
Both Grub and systemd-boot have this menu you can display by holding a key if they are not shown at machine boot.

Be careful NOT to remove your current kernel before you install another :rofl:

You can remove it after you’ve booted with another kernel first. So, you first have to install a new kernel — I recommend one of the LTS kernels that I’ve listed higher up — and then reboot with that new kernel, and only then you can remove the old one, like so… :arrow_down:

sudo mhwd-kernel -r linux64-rt

This isn’t even possible anymore these days. mhwd-kernel will throw a warning if you try. :wink:

Meh warnings are for mortals :rofl:

hey guys ok so it seems to be kde plasma causing the havoc i switched over to manjaro xfce and it’s been behaving fine for now lol

to bad though i really loved the kde plasma look :frowning:

i’ve been using the laptop for awhile after installation and updates yesterday and like no crashes etc as yet

As it just so happens to be, I have had a couple of serious issues myself with Plasma only a few days ago, and it took me until yesterday to — with the help of several forum members — hunt down the cause and remedy the problems.

If you’re having stability problems with Plasma itself — and as you can read on the thread linked above, it does unfortunately occasionally happen — then the cause is most likely something in your home directory.

In many cases, it’s the use of an old and buggy theme that’s no longer compatible with the recent Plasma versions. In my case, it was most likely caused by a couple of corrupted configuration files as the result of a glitch while changing a few settings, and yes, even one single corrupted configuration file can do this, because the way Plasma is written, it is very sensitive to that.

Either way, the problem is most likely caused by something in your home directory — a corrupted configuration file or database, a broken theme, et al — and thus, it can be fixed, even if it means having to delete your Plasma configuration files and starting all over again from the template in /etc/skel.

Still, if you would prefer to stick with XFCE, then that is of course your prerogative. Overall, Plasma is pretty good, but its occasional quirks have driven people away from it before, and XFCE is a pretty robust environment with a decent reputation, even though it’s not my personal style. :wink:

i was looking for a way to reset plasma lol most of the stuff i was reading said you had to to reinstall in order to do a reset so i was like f*ck it moving on to xcfe if i had to reinstall all over again

though i think it might of been a theme issue since i did install some custom themes but even before that it did crash at least once while i was setting up a few extra software like brave during the installation process

No no no no, reinstalling is absolutely unnecessary. That’s Microsoft-think. UNIX systems don’t work that way.

In UNIX, the software is installed system-wide and comes with a set of default configuration files that define the system-wide settings. These system-wide configuration files are all located under /etc somewhere. On the other hand, user accounts have their own settings, which are stored in their home directory only.

Unlike in that monstrosity called Windows, UNIX does not use any Registry. So the configuration is always truly split between system-wide and user-specific. :wink:

Hey guys got a question is there a way i can sudo install xrdp ? i’ve tried downloading freexrdp-x11 but it keeps failing im trying to rdp in to a vm i set up

i’ve tried sudo packman -s freexrdp-x11 packages doesn’t exist also via software centre the installation fails