Manjaro keeps blacking my screen forcing me to restart, nothing seems to help, It's making me go crazy!

Ever since I have Linux 5.10 (LTS), I have this problem.

What you see there is me entering xflock4 and being able to go back to the login screen within five seconds or so, but on the second try I wait a little longer for the screen to fall asleep and then I no longer am able to have my display show anything no matter what input I give to it.

So these are my issues:

  1. My DE goes black after x minutes of inactivity, no matter what.
  2. I can’t turn it back on in any shape or form, except for a miracle. The display gets out of sleep, but instead of the lock screen, it refreshes to black again and remains completely unresponsive to any output.

Screenlock is off.

Screensaver is off.

Energy Star features (DPMS) are off.

xset s off
xset -dpms

Nothing seems to help.
And why do I seem to be the only one with this problem?

Additional information

[folaht@pjehrsohmehj ~]$ inxi -SCGM
System:    Host: pjehrsohmehj Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux
Machine:   Type: Desktop Mobo: ASRock model: J5005-ITX serial: <superuser required> UEFI: American Megatrends v: P1.40
           date: 08/06/2018
CPU:       Info: Quad Core model: Intel Pentium Silver J5005 bits: 64 type: MCP cache: L2: 4 MiB
           Speed: 2695 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 2695 2: 2696 3: 2738 4: 2748
Graphics:  Device-1: Intel GeminiLake [UHD Graphics 605] driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.11 driver: loaded: intel unloaded: modesetting resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 21.1.5


SN: UHBA2021041182
1 Like

Did you check Display tab in Power Manager? There are few more options.


That’s good. Perhaps that will stop my screen from going black.

Although, I do wish I could simply return to being able to simply get out of display sleep and lock screen, by moving my mouse and entering my password.

You can replace default settings for Lock Screen in Commands tab with dm-tool lock.
Right click on menu > Properties > Commands

For suspend with screen lock, you can add for example systemctl suspend; dm-tool lock

If you don’t want to lock screen, but only turn off screen, you can for example create launcher in panel and put this: xset dpms force off in Command

1 Like

I tried dm-tool lock in terminal and it gives me the same issue. After five seconds of black screen, the display falls asleep and I’m unable to get out.
Even with xset dpms force off and with display power management completely turned off.

It goes out of sleep, but the screen stays black and is unresponsive.

My other lock command xflock4 now does nothing.

Hi! xflock4 is just a shell script which queries the xfce session for the screen locking mechanism that it’s configured for. This is the first line of the file:
# First test for the command set in the session's xfconf channel LOCK_CMD=$(xfconf-query -c xfce4-session -p /general/LockCommand)
You can see what your session is actually using to lock the screen.

1 Like

I don’t have much experience in this field and can be wrong, but my suspect is kernel. I had some issues before, and I’m facing it now with system suspend when inactive. It doesn’t work :grin: Switching kernels from 5.13 to 5.10 not help also (but you can try to switch, maybe it will help you). At the moment I’m waiting for update which fix it :grinning:


I am on 5.10. That’s where it went wrong. 5.4 did not have this issue, but had another one.

There is one more option, but not sure if it will be safe, so creating backup on timeshift or other software you prefer will be good idea. If one of previous versions of kernel worked correctly, you can try to downgrade the package. Downgrading packages - ArchWiki

1 Like

Alright, now we’re getting somewhere.
At least with issue #3.
It’s using light-lokcer that I deleted a week ago because of this issue as advised to go back to Manjaro XFCE standards.

What is the default?
What is everyone else’s result to this command?

xfconf-query -c xfce4-session -p /general/LockCommand
$ xfconf-query -c xfce4-session -p /general/LockCommand
light-locker-command --lock
1 Like

Wait, so light-locker is the default and not xfce4-screensaver?

I don’t remember to change something here, but after you asked, I’m no more sure :smiley:
Probably screensaver is installed to lock screen after blank. Xfce power manager don’t have that ability from what I’ve learned.

1 Like

I vaguely remember having changed the lockscreen to light-locker, but I don’t know if that was this Manjaro version, or the previous one, or Arch Linux before that.
I’m downloading a clean one into virtualbox to see.


light-locker-command --lock

It’s the same.


Reinstalled light-locker.
I’m probably back on the same issues except light-locker works again.

password seems to be accepted when just running the light-locker-command --lock command.

1 Like

I’ve added a video on top of this thread.
Maybe it can shed some more light on this.

+1 facing on Linux 5.10 (LTS)


You have this issue too?
What’s the result of inxi -SCGM for you?
What’s your monitor model?

We might get this to the Linux kernel devs.


I now have an extra issue, because a setup requires me to use Linux 5.10.

$ docker run --runtime=sysbox-runc -it dockerfile
docker: Error response from daemon: failed to create shim: OCI runtime create failed: kernel version check failed: manjaro kernel release 5.4.135-1-MANJARO is not supported; need >= 5.5: unknown.
ERRO[0000] error waiting for container: context canceled