Manjaro KDE stable: sddm leaving system without a graphical interface

I made no relevant changes to the system. Nothing relevant was installed, modified, upgraded, or removed. Last boots were just fine.

Today rebooting, I noticed I still had the UEFI splash. It seems, that sddm is failing.

Outtakes from journalctl -xe (-u sddm didn’t have some of the information what’s here)

journalctl -xeu sddm: (no text files allowed)

journalctl -x -p3 -b1:

dmesg has nothing relevant.

inxi -Fazy:

Automatic login is enabled.

I tried starting sddm, Xorg manually, results being the same.

(please help, I can help in debugging etc, but will reinstall in a few, since I don’t have a backup system to work on)

It sounds like you made some changes but are dubbing them irrelevant.
I think they may be relevant - what have you done?

(for example - package transactions can be found in /var/log/pacman.log)

1 Like

Now I can’t trust my own memory anymore…

It appears, on last boot, I messed with pulseaudio, and joplin.

Besides that, automagic has installed xf86-video-vesa (???)

[2020-12-30T12:58:34+0200] [PAMAC] synchronizing package lists
[2020-12-30T14:25:35+0200] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Sy'
[2020-12-30T14:25:35+0200] [PACMAN] synchronizing package lists
[2020-12-30T14:25:41+0200] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-vesa'
[2020-12-30T14:25:41+0200] [PACMAN] synchronizing package lists
[2020-12-30T14:25:42+0200] [ALPM] transaction started
[2020-12-30T14:25:42+0200] [ALPM] installed xf86-video-vesa (2.5.0-1)
[2020-12-30T14:25:43+0200] [ALPM] transaction completed
[2020-12-30T14:25:43+0200] [ALPM] running '30-systemd-update.hook'...
[2020-12-30T14:25:43+0200] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -D --asexplicit xf86-video-vesa'

Tried removing and rebooting, no change.

yeah that would mess up some things … I can see ‘vesa’ is used in your inxi as well … and the logs you showed usually correlate to a partial upgrade.
The lines above could very well be that as it contains strings like:

pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-vesa'

Which is almost certainly a partial-upgrade … besides which you dont want vesa.

So lets start by doing a real update:

sudo pacman -Syu

Then make sure to remove vesa and reinstall open video-linux
(using mhwd, not packages directly, as it should be unless you know what youre doing):

sudo mhwd -r pci video-vesa
sudo mhwd -f -i pci video-linux

(take note of anything funny and reboot)

1 Like

edit: copying text had some weird issues with forum, didn’t diplay; so here’s an image:

hurr… I don’t even have Nvidia stuff, only intel onboard.

also, stable 2020-12-30 happened, so it’ll take some time.

the nvidia stuff is just the db for mhwd - has nothing to do with having a card or anything … its a few kb for driver recognition.

1 Like

Upgraded the system. Along with that, made minor changes, as a reaction to upgrade logs.

Switched to linux510, then removed vesa (installation seemed to be partial, thus that wss probably why), and reinstalled video-linux.

Thanks for your time.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.