Manjaro KDE screen flickers on my ASUS laptop

I have an ASUS E410MA laptop (with 14" screen) with the following components (courtesy of Speccy)…

Operating System
Windows 10 Home 64-bit

Intel Pentium N5000 @ 1.10GHz 51 °C
Gemini Lake 14nm Technology

4.00GB Unknown


Generic PnP Monitor (1920x1080@60Hz)
Intel UHD Graphics 605 (ASUStek Computer Inc)

238GB Inland NVMe SSD 256GB (Unknown (SSD)) [Manjaro KDE]
116GB SanDisk DA4128 (SD (SSD)) [Preinstalled Windows 10]
232GB SDXC Card (USB ) [Used for VMs]

Optical Drives
No optical disk drives detected

Realtek High Definition Audio

Unlike my previous laptops, my UEFI in this laptop has no option to switch between EFI and Legacy mode.

This is the integrated graphics configuration in my laptop’s CPU:

Name Generic PnP Monitor on Intel UHD Graphics 605
Current Resolution 1280x720 pixels
Work Resolution 1280x680 pixels
State Enabled, Primary
Monitor Width 1920
Monitor Height 1080
Monitor BPP 32 bits per pixel
Monitor Frequency 60 Hz
Device \.\DISPLAY1\Monitor0
Intel UHD Graphics 605
Manufacturer Intel
Model UHD Graphics 605
Device ID 8086-3184
Revision 7
Subvendor ASUStek Computer Inc (1043)
Current Performance Level Level 0
Driver version
Count of performance levels : 1
Level 1 - “Perf Level 0”

The Inland m.2 SSD card and the SDXC card, I installed myself. The SanDisk SSD came with the machine, with Windows 10 preinstalled.

The screen flickering and blinking is an issue I had never encountered with my desktop or my 2 previous laptops. Is there a way to fix this, given the CPU I have?

One other thing: Windows had no trouble detecting Wi-Fi signals upon initial installation and activation. Why did my Manjaro setup fail to detect Wi-Fi, thereby forcing me to use a USB-to-Ethernet adapter? Wi-Fi was instantly recognizable in the Manjaro Live environment (before installation) in my other 2 laptops.

Does the screen flicker in Manjaro Live environment?
Set i915.enable_psr=0 in kernel parameter may help. Ref: Intel graphics - ArchWiki

No. The screen didn’t flicker in the live environment. Once I installed Manjaro to my m.2 drive and restarted in the installed environment, the screen started twitching and flickering.

Hey OP, did you manage to give this a go?

Edit: How to set kernel params from Arch Wiki

1 Like

Set line GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="i915.enable_psr=0" in /etc/default/grub, then run sudo update-grub and reboot.
I once used the above to solve my screen flicker problem.

1 Like

Is that a permanent solution? In the terminal, I tried…

set i915.enable_psr=0

…But for that to work, I had to restart Manjaro thereafter, and it only works when I type it in and restart.

I assume, in /etc/default/grub, there is a text file where I can edit GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="i915.enable_psr=0", yes? I’ll find out when I boot up Manjaro again. My knowledge of Linux is nowhere close to that of Windows or Android.

1 Like

Yes, it’s permanent if it works. Edit the file /etc/default/grub with sudo, then run sudo update-grub in terminal and reboot.

I found the grub text file, made the change to GRUB_CMDLINE_LINUX="", then ran ‘sudo update-grub’ in the terminal. Unfortunately it didn’t work, unless GRUB_CMDLINE_LINUX="" appears more than once in that grub file and they need to be changed.

and you rebooted after making the change?

Post another inxi --admin --verbosity=7 --filter --no-host --width so we can verify, please?


1 Like

Yes. Twice I checked that text file, and at least twice I rebooted. It still flickers. I hope my BIOS upgrade didn’t disturb any chance of it working.

I tried it this way: inxi --admin --verbosity=7 --filter --no-host --width

But the sooner I try to paste the info, I get, “Sorry, you can’t include links in your post.”

There are no links in the info. What is this message board interpreting as links?

Please read this and follow instructions there and you won’t have that problem:


As I said before, I tried to paste the entire system info after running the command in the terminal, and this message board rejected it, interpreting some of the material within as links. Is there a way to work around that problem?

Never mind.
UPDATE: Here it is, in preformatted text:

  Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=5450cc84-0678-4dcc-ac22-dbcad11fb80a rw i915.enable_psr=0 quiet
  apparmor=1 security=apparmor
  resume=UUID=b1b31cb3-8ed9-4b72-8fd9-5614abb6dfbe udev.log_priority=3
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux

  Type: Laptop System: ASUSTeK product: VivoBook_ASUS Laptop E410MA_E410MA
  v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: E410MA v: 1.0 serial: <filter>
  UEFI: American Megatrends v: E410MA.306 date: 05/27/2021

  ID-1: BAT0 charge: 35.0 Wh (100.0%) condition: 35.0/42.1 Wh (83.2%)
  volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
  status: Not charging

  RAM: total: 3.66 GiB used: 921 MiB (24.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.

  Info: Quad Core model: Intel Pentium Silver N5030 bits: 64 type: MCP
  arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 8 microcode: 1A
  cache: L2: 4 MiB bogomips: 8756
  Speed: 796 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 796 2: 796 3: 796
  4: 796
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
  arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
  flexpriority fpu fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida intel_pt
  lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl
  nx pae pat pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts
  rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep ss ssbd
  sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer tsc_known_freq umip vme vmx vnmi vpid x2apic xgetbv1
  xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected

  Device-1: Intel GeminiLake [UHD Graphics 605] vendor: ASUSTeK driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:3184 class-ID: 0300
  Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
  bus-ID: 1-5:3 chip-ID: 13d3:5a11 class-ID: 0e02
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
  screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7")
  diag: 354mm (13.9")
  OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 21.1.6
  direct render: Yes

  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
  vendor: ASUSTeK driver: snd_hda_intel v: kernel
  alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:0e.0 chip-ID: 8086:3198
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.33 running: no

  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  vendor: AzureWave driver: N/A modules: rtw88_8821ce port: e000
  bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig

  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 1-4:2 chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends

  Message: No logical block device data found.

  Message: No RAID data found.

  Local Storage: total: 354.96 GiB used: 8.96 GiB (2.5%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: DA4128
  size: 116.48 GiB block-size: physical: 512 B logical: 512 B type: SSD
  serial: <filter> rev: 0x8 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Inland model: NVMe SSD 256GB
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: T1202A0 temp: 39.9 C scheme: GPT
  Message: No optical or floppy data found.

  ID-1: / raw-size: 230.1 GiB size: 225.43 GiB (97.97%) used: 8.95 GiB (4.0%)
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
  uuid: 5450cc84-0678-4dcc-ac22-dbcad11fb80a
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 8.3 MiB (2.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  label: NO_LABEL uuid: 2840-78F6

  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.07 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
  uuid: b1b31cb3-8ed9-4b72-8fd9-5614abb6dfbe

  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 260 MiB fs: vfat label: SYSTEM
  uuid: B00F-0DF5
  ID-2: /dev/mmcblk0p2 maj-min: 179:2 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-3: /dev/mmcblk0p3 maj-min: 179:3 size: 115.18 GiB fs: ntfs label: OS
  uuid: C8CC127BCC1263CA
  ID-4: /dev/mmcblk0p4 maj-min: 179:4 size: 1.03 GiB fs: ntfs label: RECOVERY
  uuid: 40740CC9740CC41E

  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: IMC Networks Bluetooth Radio type: Bluetooth
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
  chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
  Device-2: 1-5:3 info: IMC Networks USB2.0 VGA UVC WebCam type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 13d3:5a11 class-ID: 0e02
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 7 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900

  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0

  Processes: 179 Uptime: 3m wakeups: 1 Init: systemd v: 248 tool: systemctl
  Compilers: gcc: N/A Packages: pacman: 1191 lib: 327 flatpak: 0 Shell: Bash
  v: 5.1.8 running-in: yakuake inxi: 3.3.06

Well i see nothing that jumps out as why this is happening… is the screen flicker bad enough you cant try changing your resolution or refresh rate?


From a system perspective it looks good, so:

  1. Does this also happen if you create a new user user and log in there? (E.G. cookymonzta2)
  2. Have you tried a newer stable (5.13) or experimental (5.1 RC6) yet as you do have a quite new machine…


No effect. The new user is tied to the same glitches as the old. KDE 5.22.4 did no good, either.

Sorry: I meant Kernel:

  • If you get lost, please remember Ctrl+Alt+F1 is your friend!

  • Print this page so you have it as a reference while in TTY2

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux513
    sudo mhwd-kernel --install linux514
    • to ensure grub is showing, execute:

      sudo nano --backup /etc/default/grub
    • Change (or add?) the following 3 lines:


      (3 or higher is fine, add the # before the lines above if those lines are present)

    • Ctrl+X Y Enter to save if there is anything to save

    • If you did save, execute:

      sudo update-grub
    • Reboot

  • Go to grub’s Advanced options

  • Choose these kernels one by one and try them out one by one and see if that helps.

  • If not, remove them again…


Too many errors, could not resolve host, failed to synchronize all databases, invalid url for server.

Just a sample of the errors I got with this failed update. Neither kernel installed.

I must remind you that I have 2 operating systems on my laptop, on separate SSDs (Manjaro on Drive 0 and Windows 10, pre-installed, on drive 1). I wonder if the flickers are caused by the name I chose for my laptop in Manjaro. I have the same name for Windows 10. My Windows XP VM (in VMware Workstation) was flagged with “A duplicate name exists on the network”; same computer name as my main Win10 OS. I changed the name in my VM and the error disappeared.

And how do I get my Manjaro setup to detect my Wi-Fi signal? My Windows setup had no problem detecting multiple nearby Wi-Fi networks upon system installation. I had to use a USB-to-RJ45 Ethernet interface to get an Internet connection in Manjaro and install the OS.

  • Hook up a network cable
  • Try again
  • Please provide full output