Manjaro KDE + pipewire - How to make things work again?

Thank you for that info. I have just checked for pulseaudio related packages - not the window manager - and frankly - I didn’t expect a window manager to be depending on a specific type of sound library :man_facepalming:

I am not a KDE user so the dependencies of KDE is not familiar to me - but I can confirm this from a quick view on kwin dependencies.

When kwin has a hard dependency on pipewire then this is not a decision taken by Manjaro but a choice made by upstream KDE.

Changes made by upstream KDE is their choice and not a Manjaro choice - Manjaro just takes the fall.

1 Like

And Firefox has as a dependency pulseaudio. I have no understanding of sound system at all, but to me it looks like both solutions: pulseaudio and pipewire should not contradict or conflict with each other.

1 Like

I have explicitly - purposely - replaced pulseaudio with pipewire for testing purpose and I have no issues with Firefox.

I am planning to make a test install of KDE to see if I can replicate anything …

1 Like

Found this on the Arch BBS

And from that the following is fun to read

1 Like

I didn’t expect a window manager to be depending on a specific type of sound library

KWin depends on Pipewire not for the sound part but for the screen casting part. Pipewire (+ xdg-desktop-portal) is the standard way to go about screen casting on Wayland and pretty much all the compositors depend on Pipewire because of that.


ahh - so this is wayland related?

I have seen topic on screen recording working badly on KDE - is this related?

If it is wayland related - there is a lot more sense to these issues.

1 Like

As far as I understand kwin has become dependent on pipewire in order to ensure there will be screencasting working in Wayland session because without pipewire it’s impossible.

I guess there’s some code in kwin now which relies on a fact that pipewire is up and running.

1 Like

For what it’s worth, gnome-shell also depends on pipewire.

1 Like

I don’t think so, the pain point with Wayland screen recording is lacking application support.

All the wayland compositors do (that can do screencasting, anyways).

The dependency of compositors on Pipewire isn’t the problem, it’s been a hard dependency of KWin for a while IIRC. Pipewire on its own also doesn’t replace other audio servers - with pipewire-pulse and pipewire-jack you can replace pulseaudio and jack with implementations going through pipewire.

The problem is caused by the latest version of pulseeffects having a dependency on pipewire-pulse specifically, and updating appears to have removed a bunch of packages depending on pipewire. I don’t know why exactly that is, installing pulseeffects on my system right now wouldn’t remove any of them; maybe the update messed it up somehow.

What affected people need to do is re-install those packages themselves, which for example plasma-pa (Volume control of Plasma) is part of.
Optionally they can also revert to manjaro-pulseaudio and use pulseeffects-legacy, if Pipewire doesn’t completely work for them.

1 Like

Yes sorry, this was what I was going for. My point was that it’s not just kde or just wayland, it’s more that that. Even apps like chrome/chromium is adding support for screen sharing though pipewire, so it’s looking like it’ll become something of a standard going forwards (kinda). It was mostly aimed towards @linux-aarhus who didn’t seem familiar with what it was. :slight_smile:

1 Like

Hi friends! :blush:

Regarding what kind of decision the Manjaro Team may have made, it is crystal clear to me that the replacement of “pulseaudio” by “pipewire” occurs if the “pulseeffects” package is installed. So, for me, it is not a Manjaro Team decision.

Just for clarify, in other posts of mine I made it clear that…

It would also be nice to hear them (Manjaro Team)

… and that…

As I said, “pipewire” SEEMS to be the standard for Manjaro now.

I ask you to observe this information…

… and this information…

… and finally, I make the following considerations…

I use Manjaro KDE and according to some informations KDE have dependencies in relation to “pipewire” and we also have applications that depends on “pulseaudio”. There is still information that pulseaudio and the pipewire should not contradict or conflict with each other.

QUESTION: What do you recommend for Manjaro KDE users? Install “pipewire”? Install “pulseaudio”? Install “pipewire” and “pulseaudio”?

NOTE: In my particular case, I really don’t mind using any of them (“pipewire” or “pulseaudio”) … But, I would appreciate very much know what you recommend/guide to we have the best possible experience with Manjaro KDE. :smiling_face_with_three_hearts:

Thanks friends! :blush:

There is several pacakges will let you configure settings for sound - also on KDE.

Although the name of the applications in question are labelled as PulseAudio the work fine - at the moment - with pipewire as well also on KDE.

  • pavucontrol
  • pasystray
1 Like

The 2 core packages do not cause any problems. Pipewire package has been installed on many Manjaro systems for a while, but has not been active
My pacman.log shows it was first installed June 2019

But to get Pipewire working may require installing dependency packages
The dependency package pipewire-pulse requires removal of conflicting Pulseaudio packages

1 Like

I think Manjaro won’t recommend one or another. Also there is not a contradiction with pipewire and pulseaudio, but pipewire-pulse can replace it. So you need to remove pulseaudio package to use pipewire-pulse, they are conflicting. manjaro-pipewire and manjaro-pulse are the metapackages for switching to one another easily.

Kwin needs pipewire but not pipewire-pulse, that is, you do not need to replace pulseaudio with pipewire-pulse.
Pulseeffects needs pipewire-pulse, that is, you must replace pulseaudio with pipewire-pulse to use pulseeffects.
However, pulseeffects-legacy does not need pipewire-pulse, you can use it with pulseaudio.
If you want to use pulseeffects (not legacy version) or another program that requires pipewire-pulse you can install manjaro-pipewire from repositories, it makes easy to replace pulseaudio with pipewire(-pulse).

I switched to pipewire(-pulse) to use pulseeffects with its update. It worked well but then I switched back to pulseaudio and pulseeffects-legacy because I had some issues with audio widget of plasma. Now, I have some other issues with that widget and pulseeffects-legacy. I just replaced the widget with win7 widget as a “solution”.

1 Like

So, yesterday I couldn’t update my system. I tried a few things, but nothing worked.

After a restart, no sound was present.

If I want to clean things up and go the “default” way for the Manjaro Dist with KDE, what’s the best things to do?

I guess other people could use this recommendation, too. There’s many posts, but I can’t find a single one with a step-by-step “How to clean things up, and install pipewire, after the last (a bit problematic) update” :grinning_face_with_smiling_eyes:


I have been in the same situation. I have been adding and removing and reinstalling packages per the older discussions I find online.

In the end, I came to the conclusion that: having Pipewire is not a problem; I want Pulseaudio; I don’t think I need pulseeffects.

I removed (pacman -R ...) a bunch pulseaudio packages and a bunch of pipewire packages (but not pipewire, the one required by kwin).

Then I re-installed the pulseaudio and related packages that I believed I needed.

I checked my user-land systemctl stuff (systemctl status --user) and saw that within session.slice, there was the pipewire-pulse.service and pipewire.service. But no pulseaudio.service was listed.

So I ran systemctl status --user pulseaudio and saw that pulseaudio was stopped. So I started and enabled it (systemctl start --user pulseaudio and systemctl enable --user pulseaudio).

And saw no devices in pavucontrol.

Then… a few seconds later, I reopened pavucontrol, and my devices were back. And all is OK for me right now.



Could you help me out, with what’s needed in the cleanup? As you can see, I’ve a few pulseaudio-related packages.

> sudo pacman -R pulseaudio                                                                                                  
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio' required by manjaro-pulse
:: removing pulseaudio breaks dependency 'pulseaudio' required by pulseaudio-alsa
:: removing pulseaudio breaks dependency 'pulseaudio' required by pulseaudio-arctis-pro-wireless
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-bluetooth
:: removing pulseaudio breaks dependency 'pulseaudio' required by pulseaudio-ctl
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-rtp
:: removing pulseaudio breaks dependency 'pulseaudio=14.2-3' required by pulseaudio-zeroconf
:: removing pulseaudio breaks dependency 'pulseaudio' required by pulseeffects-legacy
:: removing pulseaudio breaks dependency 'pulseaudio' required by scream-pulse

If you really want rid of pulseaudio
sudo pacman -Rdd pulseaudio

Don’t go and remove random packages, it could lead to even more breakage.
If you want to have your sound handled by pipewire, do

pamac install manjaro-pipewire

If you want to go back to pulseaudio or install all the things for it that you may have removed in the past, do

pamac install manjaro-pulse

No manual restarting of systemd services or dependency handling is necessary. Just reboot after that and you should have working sound with pipewire or pulseaudio, whichever you installed

1 Like


By running pamac install manjaro-pulse, it’s reports that there’s “Nothing to do.”, so everything is installed. But, I sadly have no audio control og sound on my machine. It has been restarted a few times, but it’s not working.

So I’ve now tried to install manjaro-pipewire which gave the following output:

To install (6):
  electron11                          11.4.3-1                                                      community  49,6 MB
  pipewire-alsa                       1:0.3.25-1                (Required By: manjaro-pipewire)     extra      4,0 kB
  pipewire-pulse                      1:0.3.25-1                (Required By: manjaro-pipewire)     extra      4,1 kB
  pipewire-jack                       1:0.3.25-1                (Required By: manjaro-pipewire)     extra      89,3 kB
  wireplumber                         0.3.0-1                   (Required By: manjaro-pipewire)     community  
  manjaro-pipewire                    20210322-1                                                    community  
To remove (8):
  pulseaudio-zeroconf                 14.2-3                    (Depends On: pulseaudio)            extra
  pulseaudio-lirc                     14.2-3                    (Depends On: pulseaudio)            extra
  pulseaudio-equalizer                14.2-3                    (Depends On: pulseaudio)            extra
  pulseaudio-rtp                      14.2-3                    (Depends On: pulseaudio)            extra
  pulseaudio-jack                     14.2-3                    (Depends On: pulseaudio)            extra
  manjaro-pulse                       20210109-1                (Conflicts With: manjaro-pipewire)  extra
  pulseaudio-bluetooth                14.2-3                    (Conflicts With: pipewire-pulse)    extra
  pulseaudio                          14.2-3                    (Conflicts With: pipewire-pulse)    extra

I accepted that, and installed the applications needed. Hereafter I rebooted the machine. But… Still no sound, or controls at all.

Are there a guide for “cleaning out broken stuff”, and start over, if we’re talking about the sound-integration? It’s sad that it broke during the update…