Manjaro KDE - After the last update replaces pulseaudio with pipewire, no more audio volume controls

After the last update replaces pulseaudio with pipewire we no longer have audio volume controls.

The sound is working, but we don’t have the audio volume controls.

What we can do to get the audio volume controls back to work in KDE?

Thanks! =D

1 Like

The last update would only replace PulseAudio with Pipewire if you had pulseeffects
installed

If you install pavucontrol-qt or pamixer they should be able to control audio in Pipewire

Or you could install pulseeffects-legacy and manjaro-pulse to use pulseeffects with PulseAudio

4 Likes

On Manjaro XFCE the same problem - sound is working but control volume keys don’t.

2 Likes

The panel control for audio may not work in Xfce with Pipewire, but Pipewire can allegedly use pavucontrol for setting audio levels

So, the KDE audio volume controls don’t work with pipewire, correct?

I do not use KDE, pulseffects or pipewire
So I can only advise what others have said should work for pipewire

If you want KDE audio controls to function as before

pamac install pulseeffects-legacy manjaro-pulseaudio
1 Like

As you requested I reinstalled the pulseeffects components. But, he still didn’t have the audio controls…

pacman -S pulseeffects-legacy
pacman -S manjaro-pulse

What should I do? :worried:

I suggest you reboot system

and check systemd services for pipewire and pulseaudio

systemctl --user -l --no-pager status pipewire* 

systemctl --user -l --no-pager status pulseaudio*

You may need some of these commands to disable pipewire.service and mask pipewire.socket

systemctl --user disable pipewire.socket --now
systemctl --user disable pipewire.service --now
systemctl --user mask pipewire.socket
1 Like

I tried to use “pulseaudio” and its components again and I had several problems. I even had problems on the KDE panel and I couldn’t get the standard volume control (KDE) back. The solution was to remove everything that was related to “pulse” (“pulseaudio”) and install these components related to “pipewire” …

yay -S gst-plugin-pipewire
yay -S libpipewire02
yay -S manjaro-pipewire
yay -S pipewire
yay -S pipewire-alsa
yay -S pipewire-dummy
yay -S pipewire-jack
yay -S pipewire-jack-dropin
yay -S pipewire-pulse
yay -S pulseeffects
yay -S wireplumber

ATTENTION: Be careful when removing “pulse” components as you can cause problems in your OS even at boot.

IMPORTANT: We are waiting for a solution for Manjaro KDE, because apparently “pipewire” is the new standard for audio control in Manjaro.

TIP!

If you switch to a bluetooth device such as a headset, then you will need to restart pipewire…

systemctl --user stop pipewire.service
systemctl --user start pipewire.service

If necessary, you will need to restart the application that will be used with the headset as well.

NOTES:
I - The keyboard shortcuts to control audio volume also stopped working;
II - This change from pulseaudio to pipewire seemed to me to be very hasty … =| There is still a lot to improve and correct … In reality, this change brought me difficulties with the linux audio that I never had.

I will try these steps. I also have had audio problems with my BT headset that I have never had before.

1 Like

Please confirm that it worked for you! Thanks! =D

The Manjaro team and its community are very competent. I contribute to the project financially - even if only a little - and with the forums, because I believe in the quality of it. More people should do the same.

I really don’t know why “pipewire” was adopted without Manjaro (KDE) being ready to receive it. I’m having a lot of problems with the audio.

The Manjaro Team and the community as a whole (including friends like @oberon @philm @Manjaro-Team ) are very participative and helpful.

I don’t know what reasons they had for making that decision. It would also be nice to hear them.

I have used Manjaro KDE for many years and I think it is too precipitous to abandon the project after so many years of success and due to the qualities and potential of it. It is important to note that Manjaro is a rolling release and by definition we are subject to things like that. It is a choice for those who use it. However, it should be noted that we are not dealing with a bleeding edge distro.

As I said, “pipewire” seems to be the standard for Manjaro now. I don’t bother to use it like I’m already doing, I just want to know how things work on my Manjaro KDE the way we all like it.

Thanks! =D

NOTE: Decisions like adopting “BTRFS” and automatic snapshots out of the box (like Garuda Linux https://garudalinux.org/ ) would be pretty cool stuff to Manjaro that is a rolling release. But, this is another conversation, for another time and for the right people.

1 Like

These commands seem to make no difference to my BT headset issue.

What does work is:
Turn on my BT headset & allow it to connect to my PC (I have a USB BT dongle)
My headset says “Connected” (as per prior behavior before the update)
I hear a very muted ‘click-type’ sound in my headset that makes me think there was a connection to the audio system of my PC
BT icon in toolbar shows that the headset is connected
However, there is no sound in my headset.
Fix:
In the BT taskbar icon settings I click “Disconnect”
In the BT taskbar icon settings I click “Connect”
Sound now works in my headset

I stumbled above this workaround while trying to diagnose the issue.

I am willing to put up with this very minor issue for now.

Do you have pipewire-media-session installed?
Also check

systemctl --user status pipewire-media-session.service

And enable and start if not active (running).

I discovered that it is needed to install and activate pulse-pa.

But this is in case you already switched to pipewire. I did and everything is fine for me now.

This topic may be useful.

Hello, I have the same problem (KDE doesn’t see any audio output or input), I have tried quite every solution I have found around.
Your suggestion made me find the first error message, so maybe this is the way to find the right solution. What should I do now?

$ systemctl --user status pipewire-media-session.service
● pipewire-media-session.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/pipewire-media-session.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2021-03-22 13:22:32 CET; 809ms ago
    Process: 16325 ExecStart=/usr/bin/pipewire-media-session (code=exited, status=161)
   Main PID: 16325 (code=exited, status=161)

mar 22 13:22:32 manjaro-su systemd[1327]: pipewire-media-session.service: Scheduled restart job, restart counter is at 5.
mar 22 13:22:32 manjaro-su systemd[1327]: Stopped Multimedia Service Session Manager.
mar 22 13:22:32 manjaro-su systemd[1327]: pipewire-media-session.service: Start request repeated too quickly.
mar 22 13:22:32 manjaro-su systemd[1327]: pipewire-media-session.service: Failed with result 'exit-code'.
mar 22 13:22:32 manjaro-su systemd[1327]: Failed to start Multimedia Service Session Manager.

More info:

$ pactl info
Server String: /run/user/1001/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 30
Tile Size: 65472
User Name: system
Host Name: manjaro-su
Server Name: PulseAudio (on PipeWire 0.3.23)
Server Version: 14.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: @DEFAULT_SINK@
Default Source: @DEFAULT_SOURCE@
Cookie: 1320:66c4

$ systemctl --user status pipewire.service
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-03-22 13:05:05 CET; 1min 21s ago
TriggeredBy: ● pipewire.socket
   Main PID: 9498 (pipewire)
     CGroup: /user.slice/user-1001.slice/user@1001.service/session.slice/pipewire.service
             └─9498 /usr/bin/pipewire


$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Sorry I am not an expert but I found this
https://bbs.archlinux.org/viewtopic.php?id=264463

so you should google for these errors.

I would remove these configuration files they talk about and reinstall pipewire-media-session

Also check if you have all services installed: reference

Also there are some files in
/home/user/.config/pipewire/media-session.d/

check if you have something with Off in those files.
Follow this:
https://wiki.archlinux.org/index.php/PipeWire

Moving the *.conf.pacnew files to *.conf solved the problem. Thanks!

1 Like

The procedure informed by @ciacnorris worked for me!

Step by step…

As root…

rm -f /etc/pipewire/media-session.d/media-session.conf
mv /etc/pipewire/media-session.d/media-session.conf.pacnew /etc/pipewire/media-session.d/media-session.conf

As your user…

systemctl --user start pipewire-media-session.service

Thanks! =D