Manjaro is unable to update (GPGME & keyring errors)

I’m sorry if this’s the wrong place to post this issue but it’s supposedly related with the AUR packages in pacman. I cannot update my device and here’s the inxi --admin --verbosity=7 --filter --width command:

System:
  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=2acd979d-0c15-4b5e-9c03-b03b59fb8c93 rw quiet apparmor=1
  security=apparmor resume=UUID=cf2d2dcd-ce25-4873-b38b-6b2edc6ccf64
  udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Hewlett-Packard product: HP ProDesk 600 G1 TWR v: N/A
  serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Hewlett-Packard model: 18E7 serial: <superuser required>
  BIOS: Hewlett-Packard v: L01 v02.75 date: 05/04/2018
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse Dell WM116
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes
  status: Discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard Dell WK636
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes
  status: Discharging
Memory:
  RAM: total: 5.69 GiB used: 2.26 GiB (39.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L1: 256 KiB
  L2: 1024 KiB L3: 6 MiB bogomips: 25554
  Speed: 2922 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2922 2: 1926
  3: 3498 4: 1232
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good
  sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave
  xsaveopt xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0
  chip-ID: 8086:0412 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.5x10.9")
  s-diag: 523mm (20.6")
  Monitor-1: VGA-1 res: 1680x1050 hz: 60 dpi: 90 size: 474x296mm (18.7x11.7")
  diag: 559mm (22")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:03.0
  chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  chip-ID: 8086:8c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Intel Ethernet I217-LM vendor: Hewlett-Packard driver: e1000e
  v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
  v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 1.36 TiB used: 94.61 GiB (6.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000AVCS-612DY1
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
  type: N/A serial: <filter> rev: 0A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-75WN4A0
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: 1A02 scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 456.96 GiB size: 448.72 GiB (98.20%)
  used: 14.26 GiB (3.2%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: 2acd979d-0c15-4b5e-9c03-b03b59fb8c93
  ID-2: /home raw-size: 931.51 GiB size: 915.81 GiB (98.31%)
  used: 80.35 GiB (8.8%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: Eris
  uuid: c7581184-8813-4804-a5f3-d5e0cddd97dd
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda2 maj-min: 8:2 label: swap
  uuid: cf2d2dcd-ce25-4873-b38b-6b2edc6ccf64
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
  speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 207 Uptime: 2h 51m wakeups: 20 Init: systemd v: 249
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1271 lib: 349
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole
  inxi: 3.3.09

And the sudo pacman -Syu output as well:

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
 core                                                                                   168.9 KiB   192 KiB/s 00:01 [#####################################################################] 100%
 extra                                                                                 1918.1 KiB   902 KiB/s 00:02 [#####################################################################] 100%
 community                                                                                6.8 MiB   907 KiB/s 00:08 [#####################################################################] 100%
 multilib                                                                               176.5 KiB   569 KiB/s 00:00 [#####################################################################] 100%
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

I tried updating the mirror list. I even tried to update my kernel but the GUI does not display the other kernels at the moment. What should I do now?

Please take a look in this post:

https://forum.manjaro.org/t/root-tip-mitigate-and-prevent-gpgme-error-when-syncing-your-system/84700/2

I must thank you sir, this the first thing that made any progress; however, I got another set of errors.
After I walked through the commands, I ran sudo pacman -Syyu and it gave me this:

:: Synchronizing package databases...
 core                                                                                   168.9 KiB   109 KiB/s 00:02 [#####################################################################] 100%
 extra                                                                                 1918.1 KiB   814 KiB/s 00:02 [#####################################################################] 100%
 community                                                                                6.8 MiB   903 KiB/s 00:08 [#####################################################################] 100%
 multilib                                                                               176.5 KiB   346 KiB/s 00:01 [#####################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (78) alsa-lib-1.2.6.1-1  alsa-plugins-1:1.2.6-1  alsa-ucm-conf-1.2.6.3-0  alsa-utils-1.2.6-1  archlinux-appstream-data-20211210-1  ark-21.12.0-1  baloo-widgets-21.12.0-1
              breeze-icons-5.88.0-3  cantarell-fonts-1:0.303.1-1  dhcpcd-9.4.1-1  dolphin-21.12.0-1  dolphin-plugins-21.12.0-1  elisa-21.12.0-1  ffmpegthumbs-21.12.0-1  filelight-21.12.0-1
              filesystem-2021.12.07-3  firefox-95.0.1-0.1  ghostscript-9.55.0-3  gwenview-21.12.0-1  harfbuzz-3.2.0-1  harfbuzz-icu-3.2.0-1  imlib2-1.7.5-1  inxi-3.3.11.1-1  k3b-1:21.12.0-1
              kaccounts-integration-21.12.0-1  kaccounts-providers-21.12.0-1  kamera-21.12.0-1  kate-21.12.0-1  kcalc-21.12.0-1  kdeconnect-21.12.0-1  kdegraphics-thumbnailers-21.12.0-1
              kdenetwork-filesharing-21.12.0-1  kdenlive-21.12.0-1  keditbookmarks-21.12.0-1  kfind-21.12.0-1  kget-21.12.0-1  khelpcenter-21.12.0-1  kio-extras-21.12.0-1  konsole-21.12.0-1
              ksystemlog-21.12.0-1  kwalletmanager-21.12.0-1  lib32-alsa-lib-1.2.6.1-1  lib32-alsa-plugins-1.2.6-1  lib32-vulkan-icd-loader-1.2.202-1  libical-3.0.12-1  libkcddb-21.12.0-1
              libkdcraw-21.12.0-1  libkexiv2-21.12.0-1  libkipi-21.12.0-1  libksane-21.12.0-1  libktorrent-21.12.0-1  liblouis-3.20.0-1  libsidplayfp-2.3.1-1  libx11-1.7.3.1-1
              manjaro-hello-0.6.6-10  manjaro-release-21.2.0-1  mhwd-db-0.6.5-21  okular-21.12.0-1  pacman-mirrors-4.23.2-1.1  pango-1:1.50.1-1  partitionmanager-21.12.0-1
              print-manager-21.12.0-1  pulseaudio-alsa-1:1.2.6-1  qt5-base-5.15.2+kde+r263-1  qt5-wayland-5.15.2+kde+r37-1  samba-4.15.3-1  signon-kwallet-extension-21.12.0-1
              skanlite-21.12.0-1  smbclient-4.15.3-1  spectacle-21.12.0-1  steam-manjaro-1.0.0.74-1  tbb-2021.4.0-1  thunderbird-91.4.1-0.1  vulkan-icd-loader-1.2.202-1  xfsprogs-5.14.2-1
              xorg-server-21.1.2-2  xorg-server-common-21.1.2-2  yakuake-21.12.0-1

Total Installed Size:  1023.14 MiB
Net Upgrade Size:       -10.26 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
 firefox-95.0.1-0.1-x86_64 is up to date
 thunderbird-91.4.1-0.1-x86_64 is up to date
 qt5-base-5.15.2+kde+r263-1-x86_64 is up to date
 archlinux-appstream-data-20211210-1-any is up to date
 ghostscript-9.55.0-3-x86_64 is up to date
 kdenlive-21.12.0-1-x86_64 is up to date
 breeze-icons-5.88.0-3-any is up to date
 k3b-1:21.12.0-1-x86_64 is up to date
 kate-21.12.0-1-x86_64 is up to date
 samba-4.15.3-1-x86_64 is up to date
 smbclient-4.15.3-1-x86_64 is up to date
 gwenview-21.12.0-1-x86_64 is up to date
 okular-21.12.0-1-x86_64 is up to date
 kget-21.12.0-1-x86_64 is up to date
 khelpcenter-21.12.0-1-x86_64 is up to date
 dolphin-21.12.0-1-x86_64 is up to date
 steam-manjaro-1.0.0.74-1-x86_64 is up to date
 skanlite-21.12.0-1-x86_64 is up to date
 liblouis-3.20.0-1-x86_64 is up to date
 partitionmanager-21.12.0-1-x86_64 is up to date
 ksystemlog-21.12.0-1-x86_64 is up to date
 libx11-1.7.3.1-1-x86_64 is up to date
 elisa-21.12.0-1-x86_64 is up to date
 xorg-server-21.1.2-2-x86_64 is up to date
 konsole-21.12.0-1-x86_64 is up to date
 ark-21.12.0-1-x86_64 is up to date
 spectacle-21.12.0-1-x86_64 is up to date
 alsa-utils-1.2.6-1-x86_64 is up to date
 kio-extras-21.12.0-1-x86_64 is up to date
 qt5-wayland-5.15.2+kde+r37-1-x86_64 is up to date
 xfsprogs-5.14.2-1-x86_64 is up to date
 kdeconnect-21.12.0-1-x86_64 is up to date
 kwalletmanager-21.12.0-1-x86_64 is up to date
 harfbuzz-3.2.0-1-x86_64 is up to date
 filelight-21.12.0-1-x86_64 is up to date
 libktorrent-21.12.0-1-x86_64 is up to date
 libical-3.0.12-1-x86_64 is up to date
 kcalc-21.12.0-1-x86_64 is up to date
 imlib2-1.7.5-1-x86_64 is up to date
 alsa-lib-1.2.6.1-1-x86_64 is up to date
 print-manager-21.12.0-1-x86_64 is up to date
 kfind-21.12.0-1-x86_64 is up to date
 yakuake-21.12.0-1-x86_64 is up to date
 dolphin-plugins-21.12.0-1-x86_64 is up to date
 pango-1:1.50.1-1-x86_64 is up to date
 lib32-alsa-lib-1.2.6.1-1-x86_64 is up to date
 tbb-2021.4.0-1-x86_64 is up to date
 inxi-3.3.11.1-1-any is up to date
 keditbookmarks-21.12.0-1-x86_64 is up to date
 libkcddb-21.12.0-1-x86_64 is up to date
 dhcpcd-9.4.1-1-x86_64 is up to date
 libksane-21.12.0-1-x86_64 is up to date
 pacman-mirrors-4.23.2-1.1-any is up to date
 kamera-21.12.0-1-x86_64 is up to date
 libkexiv2-21.12.0-1-x86_64 is up to date
 libsidplayfp-2.3.1-1-x86_64 is up to date
 lib32-vulkan-icd-loader-1.2.202-1-x86_64 is up to date
 kaccounts-integration-21.12.0-1-x86_64 is up to date
 manjaro-hello-0.6.6-10-any is up to date
 baloo-widgets-21.12.0-1-x86_64 is up to date
 vulkan-icd-loader-1.2.202-1-x86_64 is up to date
 cantarell-fonts-1:0.303.1-1-any is up to date
 libkipi-21.12.0-1-x86_64 is up to date
 kdenetwork-filesharing-21.12.0-1-x86_64 is up to date
 alsa-plugins-1:1.2.6-1-x86_64 is up to date
 kaccounts-providers-21.12.0-1-x86_64 is up to date
 lib32-alsa-plugins-1.2.6-1-x86_64 is up to date
 alsa-ucm-conf-1.2.6.3-0-any is up to date
 libkdcraw-21.12.0-1-x86_64 is up to date
 kdegraphics-thumbnailers-21.12.0-1-x86_64 is up to date
 xorg-server-common-21.1.2-2-x86_64 is up to date
 ffmpegthumbs-21.12.0-1-x86_64 is up to date
 filesystem-2021.12.07-3-x86_64 is up to date
 mhwd-db-0.6.5-21-x86_64 is up to date
 manjaro-release-21.2.0-1-any is up to date
 signon-kwallet-extension-21.12.0-1-x86_64 is up to date
 harfbuzz-icu-3.2.0-1-x86_64 is up to date
 pulseaudio-alsa-1:1.2.6-1-x86_64 is up to date
(78/78) checking keys in keyring                                                                                    [#####################################################################] 100%
downloading required keys...
:: Import PGP key CAA6A59611C7F07E, "Philip Mueller <philm@manjaro.org>"? [Y/n] Y
:: Import PGP key 150C200743ED46D8, "Mark Wagie <mark@manjaro.org>"? [Y/n] Y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] Y
:: Import PGP key B02854ED753E0F1F, "Anatol Pomozov <anatol.pomozov@gmail.com>"? [Y/n] Y
:: Import PGP key 7A4E76095D8A52E4, "Antonio Rojas <arojas@archlinux.org>"? [Y/n] Y
:: Import PGP key 3B94A80E50A477C7, "Jan Alexander Steffens (heftig) <heftig@archlinux.org>"? [Y/n] Y
:: Import PGP key 06096A6AD1CEDDAC, "Laurent Carlier <lordheavym@gmail.com>"? [Y/n] Y
:: Import PGP key 94657AB20F2A092B, "Andreas Radke <andyrtr@archlinux.org>"? [Y/n] Y
:: Import PGP key 771DF6627EDF681F, "Tobias Powalowski <tpowa@archlinux.org>"? [Y/n] Y
:: Import PGP key F22FB1D78A77AEAB, "Giancarlo Razzolini <grazzolini@archlinux.org>"? [Y/n] Y
:: Import PGP key 786C63F330D7CB92, "Felix Yan <felixonmars@archlinux.org>"? [Y/n] Y
(78/78) checking package integrity                                                                                  [#####################################################################] 100%
error: alsa-ucm-conf: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-ucm-conf-1.2.6.3-0-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: filesystem: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/filesystem-2021.12.07-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: alsa-lib: signature from "David Runge <dvzrv@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-lib-1.2.6.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: alsa-plugins: signature from "Anatol Pomozov (Arch Linux developer account) <anatolik@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-plugins-1:1.2.6-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: alsa-utils: signature from "David Runge <dvzrv@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/alsa-utils-1.2.6-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: archlinux-appstream-data: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux-appstream-data-20211210-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: harfbuzz: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/harfbuzz-3.2.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: vulkan-icd-loader: signature from "Laurent Carlier <lordheavym@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/vulkan-icd-loader-1.2.202-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libx11: signature from "Andreas Radke <andyrtr@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libx11-1.7.3.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: qt5-base: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/qt5-base-5.15.2+kde+r263-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: pango: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/pango-1:1.50.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: qt5-wayland: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/qt5-wayland-5.15.2+kde+r37-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: xfsprogs: signature from "Tobias Powalowski <tpowa@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/xfsprogs-5.14.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: ark: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/ark-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: baloo-widgets: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/baloo-widgets-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: breeze-icons: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/breeze-icons-5.88.0-3-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: cantarell-fonts: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/cantarell-fonts-1:0.303.1-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: dhcpcd: signature from "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/dhcpcd-9.4.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: smbclient: signature from "Tobias Powalowski <tpowa@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/smbclient-4.15.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kio-extras: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kio-extras-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: dolphin: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/dolphin-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: dolphin-plugins: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/dolphin-plugins-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: elisa: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/elisa-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: ffmpegthumbs: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/ffmpegthumbs-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: filelight: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/filelight-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: firefox: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/firefox-95.0.1-0.1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: ghostscript: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/ghostscript-9.55.0-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libkipi: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libkipi-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libkdcraw: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libkdcraw-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: signon-kwallet-extension: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/signon-kwallet-extension-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kaccounts-integration: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kaccounts-integration-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: gwenview: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/gwenview-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: harfbuzz-icu: signature from "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/harfbuzz-icu-3.2.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: imlib2: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/imlib2-1.7.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: inxi: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/inxi-3.3.11.1-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libkcddb: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libkcddb-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: k3b: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/k3b-1:21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kaccounts-providers: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kaccounts-providers-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kamera: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kamera-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kate: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kate-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kcalc: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kcalc-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kdeconnect: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kdeconnect-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libkexiv2: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libkexiv2-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kdegraphics-thumbnailers: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kdegraphics-thumbnailers-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: samba: signature from "Tobias Powalowski <tpowa@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/samba-4.15.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kdenetwork-filesharing: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kdenetwork-filesharing-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kdenlive: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kdenlive-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: keditbookmarks: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/keditbookmarks-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kfind: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kfind-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kget: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kget-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: khelpcenter: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/khelpcenter-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: konsole: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/konsole-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: ksystemlog: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/ksystemlog-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: kwalletmanager: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/kwalletmanager-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: lib32-alsa-lib: signature from "David Runge <dvzrv@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-alsa-lib-1.2.6.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: lib32-alsa-plugins: signature from "David Runge <dvzrv@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-alsa-plugins-1.2.6-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: lib32-vulkan-icd-loader: signature from "Laurent Carlier <lordheavym@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-vulkan-icd-loader-1.2.202-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libical: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libical-3.0.12-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libksane: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libksane-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libktorrent: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libktorrent-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: liblouis: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/liblouis-3.20.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: libsidplayfp: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/libsidplayfp-2.3.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: pacman-mirrors: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/pacman-mirrors-4.23.2-1.1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: manjaro-hello: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-hello-0.6.6-10-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: manjaro-release: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-release-21.2.0-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: mhwd-db: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/mhwd-db-0.6.5-21-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: okular: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/okular-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: partitionmanager: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/partitionmanager-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: print-manager: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/print-manager-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: pulseaudio-alsa: signature from "Anatol Pomozov (Arch Linux developer account) <anatolik@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/pulseaudio-alsa-1:1.2.6-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: skanlite: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/skanlite-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: spectacle: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/spectacle-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y   
error: steam-manjaro: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/steam-manjaro-1.0.0.74-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: tbb: signature from "Felix Yan <felixonmars@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/tbb-2021.4.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: thunderbird: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/thunderbird-91.4.1-0.1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: xorg-server-common: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/xorg-server-common-21.1.2-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: xorg-server: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/xorg-server-21.1.2-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: yakuake: signature from "Antonio Rojas <arojas@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/yakuake-21.12.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Should it be this way? and what were all those PGP keys that I had to remove later on?

Ok, there are still some pgp-key wrong.

Please run:

sudo pacman-key --refresh-keys

… and than run your update again. :grinning:

Edit1: sorry … forgot the ‘sudo’ before pacman-key

OK, I ran it and currently updating, it’s still retrieving packages, checking dependencies, etc. It may take a while (and my PC keeps freezing right now), I’ll get back to you and let you know when it’s finished. And I gathered the “sudo” part, thank you anyway! I’ll share its output for the sake of completeness:

gpg: error retrieving 'philm@manjaro.org' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key CAA6A59611C7F07E: 4 signatures not checked due to missing keys
gpg: key CAA6A59611C7F07E: "Philip Müller (Called Little) <philm@manjaro.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: error retrieving 'mark@manjaro.org' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key 150C200743ED46D8: "Mark Wagie <mark@manjaro.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: key 7258734B41C31549: "David Runge <dvzrv@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   ed25519 2019-10-01 [SC] [expires: 2023-09-30]
      C7E7849466FE2358343588377258734B41C31549
uid           [ unknown] David Runge <dvzrv@archlinux.org>
sub   cv25519 2019-10-01 [E] [expires: 2023-09-30]

gpg: key B02854ED753E0F1F: "Anatol Pomozov (Arch Linux developer account) <anatolik@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa4096 2014-02-04 [SC] [expires: 2026-10-25]
      8E1992167465DB5FB045557CB02854ED753E0F1F
uid           [ unknown] Anatol Pomozov (Arch Linux developer account) <anatolik@archlinux.org>
uid           [ unknown] Anatol Pomozov <anatol.pomozov@gmail.com>
sub   rsa4096 2014-02-04 [E] [expires: 2026-10-25]

gpg: key 4AC5588F941C2A25: "Antonio Rojas <arojas@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa4096 2014-10-21 [SC]
      9D74DF6F91B7BDABD5815CA84AC5588F941C2A25
uid           [ unknown] Antonio Rojas <arojas@archlinux.org>
sub   rsa2048 2014-11-07 [S]
sub   rsa2048 2014-11-07 [E]

gpg: key 19802F8B0D70FC30: "Jan Alexander Steffens (heftig) <heftig@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   ed25519 2020-05-11 [SC]
      A2FF3A36AAA56654109064AB19802F8B0D70FC30
uid           [ unknown] Jan Alexander Steffens (heftig) <heftig@archlinux.org>
sub   cv25519 2020-05-11 [E]
sub   ed25519 2020-05-11 [S]
sub   ed25519 2020-05-11 [A]

gpg: error retrieving 'lordheavym@gmail.com' via WKD: No data
gpg: error reading key: No data
gpg: key 06096A6AD1CEDDAC: "Laurent Carlier <lordheavym@gmail.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa2048 2011-10-30 [SC]
      535F8C0339450F054A4D282706096A6AD1CEDDAC
uid           [ unknown] Laurent Carlier <lordheavym@gmail.com>
uid           [ unknown] Laurent Carlier <lordheavym@archlinux.org>
sub   rsa2048 2011-10-30 [E]

gpg: key 94657AB20F2A092B: "Andreas Radke <andyrtr@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa2048 2011-05-14 [SC]
      ADC8A1FCC15E01D45310419E94657AB20F2A092B
uid           [ unknown] Andreas Radke <andyrtr@archlinux.org>
sub   rsa2048 2011-05-14 [E]

gpg: key 771DF6627EDF681F: "Tobias Powalowski <tpowa@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa2048 2011-07-18 [SC]
      5B7E3FB71B7F10329A1C03AB771DF6627EDF681F
uid           [ unknown] Tobias Powalowski <tpowa@archlinux.org>
sub   rsa2048 2011-07-18 [E]

gpg: key F22FB1D78A77AEAB: "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa4096 2016-11-11 [SC]
      ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB
uid           [ unknown] Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>
sub   rsa4096 2016-11-11 [E]

gpg: key 786C63F330D7CB92: "Felix Yan <felixonmars@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa4096 2012-01-20 [SC]
      B5971F2C5C10A9A08C60030F786C63F330D7CB92
uid           [ unknown] Felix Yan <felixonmars@archlinux.org>
sub   rsa4096 2012-01-20 [E]

GUI pacman gave me the invalid or corrupted package (PGP signature): message and apparently, I cannot update the kernel as well. It now shows the other kernels but fails to install any one (the one I’m currently running is unsupported).

Coud you identify the package with the invalid pgp signature?

And yes a kernel switch is recommend. :grinning:

I’m running the update via terminal now so that I can do so.

The pacman-logfile should record such things. :grinning:

Its located at:

/var/log/pacman.log

1 Like
error: failed retrieving file 'filelight-21.12.0-1-x86_64.pkg.tar.zst.sig' from manjaro.mirror.liquidtelecom.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

And the kernel error as well:

The following packages will be installed:
linux515

Starting
resolving dependencies...
looking for conflicting packages...
Packages (1) linux515-5.15.7-1
Total Download Size:    99.61 MiB
Total Installed Size:  104.14 MiB
:: Proceed with installation? [Y/n] 
:: Retrieving packages...
linux515-5.15.7-1-x86_64 downloading...
checking keyring...
checking package integrity...
:: File /var/cache/pacman/pkg/linux515-5.15.7-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
Errors occurred, no packages were upgraded.
error: linux515: signature from "Manjaro Build Server <build@manjaro.org>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))

Ok, ‘filelight’ seems not to be important for the system to work. You could try to deselect it from update OR remove it and install it again after your update is over.

OK, doing that as we speak; what about the kernel issue? Or should we put a pin on that for now (maybe split it to a new topic)?

At first please dont run an update and a kernel install at the same time. Both use pacman to get the packages.

First try to run all the updates. If this is done you can try to install another kernel. There is no need to split the topic at the moment I think. :grinning:

It just keeps giving me errors with some applications. It’s tedious to keep picking them up. Should I continue this way or deal with the problem? I’ll do nothing tell you reply.

Hm, sounds like there still problems with the pgp signatures.

There is a topic in the Wiki for this. Please take a look inside.

But I have to tell you that I never had these issues. So I could not tell if its the right solution for your problem. :slightly_smiling_face:

OK, I’m running the commands related to the keys problems in the Wiki topic you sent and got the following outputs:

    ~  sudo rm -r /etc/pacman.d/gnupg                                                                                                                                        ✔  7m 58s 
rm: cannot remove '/etc/pacman.d/gnupg/S.gpg-agent.extra': No such file or directory
    ~  sudo pacman-key --init                                                                                                                                                  1 ✘  7s  
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
==> Generating pacman master key. This may take some time.
gpg: Generating pacman keyring master key...
gpg: key D2C57C100084394D marked as ultimately trusted
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/AF9DA55E65FFA7F7C2874E88D2C57C100084394D.rev'
gpg: Done
==> Updating trust database...
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
    ~  mkdir -pv $HOME/.cache/pkg/ && sudo pacman -Syw archlinux-keyring manjaro-keyring --cachedir $HOME/.cache/pkg/                                                                   ✔ 
mkdir: created directory '/home/old-man-jaro/.cache/pkg/'
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...

Packages (2) archlinux-keyring-20211028-1  manjaro-keyring-20210910-2

Total Download Size:  0.00 MiB

:: Proceed with download? [Y/n] Y
:: Retrieving packages...
 archlinux-keyring-20211028-1-any                                                       979.1 KiB   344 KiB/s 00:03 [#####################################################################] 100%
 manjaro-keyring-20210910-2-any                                                         141.6 KiB   345 KiB/s 00:00 [#####################################################################] 100%
(2/2) checking keys in keyring                                                                                      [#####################################################################] 100%
downloading required keys...
:: Import PGP key 6D42BDD116E0068F, "Christian Hesse <arch@eworm.de>"? [Y/n] Y
:: Import PGP key DAD3B211663CA268, "Bernhard Landauer <oberon@manjaro.org>"? [Y/n] Y
(2/2) checking package integrity                                                                                    [#####################################################################] 100%
error: archlinux-keyring: signature from "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" is unknown trust
:: File /home/old-man-jaro/.cache/pkg/archlinux-keyring-20211028-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: manjaro-keyring: signature from "Bernhard Landauer <bernhard@manjaro.org>" is unknown trust
:: File /home/old-man-jaro/.cache/pkg/manjaro-keyring-20210910-2-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] Y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
    ~  rm -f $HOME/.cache/pkg/*.sig                                                                                                                                           1 ✘  35s  
zsh: no matches found: /home/old-man-jaro/.cache/pkg/*.sig
    ~  sudo pacman -U $HOME/.cache/pkg/*.tar.zst                                                                                                                                      1 ✘ 
zsh: no matches found: /home/old-man-jaro/.cache/pkg/*.tar.zst

As you can see, the one before the last two (which both gave “no matches”) gave an error regarding two keys again. How to go forward from this?

Hm, bad for you. Its above my knowledge. Perhaps someone else has more experience.
… its also slowly time for bed for me (its 5am) :laughing:

Still one thing, is date and systemtime showing the right values?

Ah, I kept you for so long. Sorry. They are showing the right values, I guess. I’ll wait for more helpful people like you and if no one added anything soon, I’ll mark one of your replies as a solution (you did solve something) and start a new topic. Happy holidays!

can you try running:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro 
sudo pacman-key --refresh-keys 
3 Likes