Manjaro install stuck at 95% Misc postinstall configuration

Installing Manjaro over linux mint but it stucks at 95%
I restarted and found it has installed successfully, but I have a problem with installing anything with pacman I don’t know if it’s related. it keeps spamming “Please answer [e]xit or [c]ontinue”

2 Likes

Hi,

could you provide the full output of pacman?

Thanks.

Otherwise could be a problem with the mirror. Try this on your local install (not on the live environment):

sudo pacman-mirrors -c all && sudo pacman-mirrors -f 10 && sudo pacman -Syyu
2 Likes

And also, could you tell us what over means in your context? You did not format the / or something else?

I’m having a similar problem. Installer got stuck at 95% and then i restarted and it booted to Manjaro, so it did install. Tried to update packages, it got stuck after some time(same errors as OP), so i tried to install it again, but it got stuck on 94% (Misc posstinstall configurations). Could it be that I’m trying to install it by replacing another partition with Manjaro or something?

I also have this problem attempting to install on xps 15 9500 on a 2TB drive. Presumably there should be no partition issues since manjaro installer should handle this and the process makes it to the end at post-install scripts. During the hang I don’t see any clear errors or issues in journalctl. I tried a second time installing and same issue, for me stuck with infinite hang at 95% at “misc postinstall configurations”. I suspect a bug but not sure how to troubleshoot further without looking at manjaro install script code…

If you would like to debug it. Please run the graphical installer calamares in debug mode:

sudo calamares --debug &> ~/calamares_debug.log

The log will be saved in the home folder of the live environment.

Just upload it to pastebin.com for example and paste the link here. If you can’t post links paste it like this:

`pastebin.com`

1 Like

The debug ended with the following:
Running "chroot" ("/tmp/calamares-root-72i3rc21", "pacman", "-S", "libreoffice-still", "--noconfirm", "--config", "/opt/mhwd/pacman-mhwd.conf")

So I omitted libreoffice installation and made sure my bios/installer time was set right, resulting in the installer not hanging. Might want to check the installer libreoffice code…

Thanks for the debugging tip.

2 Likes

Just installed it in a VM and i have no problems at all. What could cause the problem is:

  1. Internet Speed is slow
  2. Mirror is slow

Because it it downloads some dependencies.

    Running "chroot" ("/tmp/calamares-root-eykrkfya", "pacman", "-S", "libreoffice-still", "--noconfirm", "--config", "/opt/mhwd/pacman-mhwd.conf") 
23:56:16 [6]: static CalamaresUtils::ProcessResult CalamaresUtils::System::runCommand(CalamaresUtils::System::RunLocation, const QStringList&, const QString&, const QString&, std::chrono::seconds)
    Finished. Exit code: 0 
23:56:16 [6]: static CalamaresUtils::ProcessResult CalamaresUtils::System::runCommand(CalamaresUtils::System::RunLocation, const QStringList&, const QString&, const QString&, std::chrono::seconds)
    Target cmd: ("pacman", "-S", "libreoffice-still", "--noconfirm", "--config", "/opt/mhwd/pacman-mhwd.conf") output:
 resolving dependencies...
looking for conflicting packages...

Packages (31) clucene-2.3.3.4-11  libabw-0.1.3-2  libatomic_ops-7.6.10-2  libcdr-0.1.6-2  libcmis-0.5.2-4  libe-book-0.1.3-7  libepubgen-0.1.1-2  libetonyek-0.1.9-2  libexttextcat-3.4.5-2  libfreehand-0.1.2-3  libixion-0.15.0-1  liblangtag-0.6.3-2  libmspub-0.1.4-7  libmwaw-0.3.16-1  libnumbertext-1.0.5-2  libodfgen-0.1.7-2  liborcus-0.15.4-1  libpagemaker-0.0.4-2  libqxp-0.0.2-4  librevenge-0.0.4-3  libstaroffice-0.0.7-1  libtommath-1.2.0-3  libvisio-0.1.7-3  libwpd-0.10.3-2  libwpg-0.3.3-2  libwps-0.4.11-1  libzmf-0.0.2-8  lpsolve-5.5.2.5-4  rasqal-1:0.9.33-3  redland-1:1.0.17-8  libreoffice-still-6.3.6-1

Total Download Size:   155.63 MiB
Total Installed Size:  656.62 MiB

Manjaro XFCE 20.0.3

Might be good to display that pacman is downloading something.

I just had this issue, I got around it by running the installer without LibreOffice. However, the “Please answer [e]xit or [c]ontinue” persists after reinstalling and booting into the local system. I’m hoping updating to the most recent kernel will make this issue go away

1 Like

Updating to one of the most recent Linux kernels, linux57, made this issue vanish.

I had this on the first pacman update…since I could read what I was continuing/existing I just ctl-C’d it and on rerun that didn’t happen…

I have 1gbps net (actual clock at ~600) so I doubt it’s that. I didn’t see any pfsense/suricata blocks which can sometimes mess with such connections. Re mirror slowness: I left my second install trial up indefinitely and I found an “out of memory” error in the journalctl (I’m running 64GB RAM on gen10 intel chip), so presumably less likely mirror slowness based on that (or code exception handling when can’t connect to a mirror?)?

pacman -Syu fixed the issue for me

I deleted the os partition with “fdisk” and replaced the free space with manjaro

I have the same problem. I have 2 SSD’s, one with Windows and the other one with Solus. I had an encrypted LVM volume (Solus) that I deleted with gparted in the Manjaro live-usb. I tried installing on the empty space and it’s stuck at 95%. Any ideas?

Edit: Will provide a link of the debug shortly
Edit2: pastebin. pl/view/a202405d
It really seems to be some issue with LibreOffice. Here’s the full debug though.

I just installed manjaro-kde-20.03-200606-linux56.iso and I had the stall-at-95% problem. I was not installing with Libre Office, but the “Free Office”, and it hung up too. The “fix” was to not try to install it with either.

im having the same issue , installing with libre office, maybe the problem is in the bios clock ? in my bios it’s time weren’t setted to my region.

I chose FreeOffice not LibreOffice but after installation -restart after 95%- I only have 3 FreeOffice programs PlanMaker, Presentations and TextMaker. There should be more right ?

Hi! im having the same issue. I have manjaro installed on a partitioned disk, but now im installing on a full disk. The disk is ssd. I have tried tree times whitout success.

If you read the thread there is an issue, so do not select office suites, install Manjaro properly, boot on the freshly installed system, then update the system and install the office suite of your liking. This way nothing to fix.

1 Like