Manjaro Install Live CD Stuck at "Reached target Graphical Interface"

I am trying to install Manjaro KDE Plasma and I can’t even boot into the live CD that I have installed on a USB stick. I always get stuck at “Reached target Graphical Interface” and then nothing happens at all. I’m assuming this has something to do with nvidia drivers.

I tried doing this a few days ago and gave up after trying a few things I saw in posts about similar issues, but nothing worked. I can’t remember everything I tried, and I’m willing to try any suggestions anyone has.

I’ve tried with both Manjaro KDE and Manjaro xfce, but get stopped at the same point in both . I’ve tried with and without the proprietary drivers.

This is a picture of where it get’s stuck:

My PC Specs:
CPU: AMD Ryzen 7 5800x
GPU: MSI Ventus Nvidia RTX 2080 8GB
RAM: Team Group T-FORCE VULCAN Z 32GB (2 x 16GB)

Have you tried disabling secure boot in your bios?

So I just got into my BIOS to double check. I already had secure boot disabled so having secure boot disabled doesn’t fix it. I also just tried it again with secure boot enabled, but no dice.

But I realized I never tried switching from UEFI to CSM. I tried that and when I did I no longer got any video at all to my monitor. To fix that I had to do a cmos reset on my motherboard. So I guess I can’t try with CSM instead of UEFI, though thinking about it, I think that might fix it. I’m going to look into a way to get around the video issue I’m having with CSM and see if that gets me anywhere.

Edit: I was not able to get csm mode to work. It always has has no display signal and I have to do a cmos reset to fix it no matter what I try (bios update, changing bios settings related to secure boot/csm options)

I think it would be better using uefi rather than legacy. But perhaps you created the usb in legacy mode and it won’t boot on your uefi computer.

Perhaps you could post more info on how you installed the live usb.

I’ve actually tried 2 different ways. I tried using balenaetcher and Rufus (I currently only have windows installed on my computer) and got the same results both times. I also tried on 2 different USB sticks, a USB 2.0 16gb stick and a USB 3.0 16gb stick.

I do not have a DVD drive on my pc, so can’t try that at the moment. I could probably snag a DVD drive and a couple disks from work tomorrow and give that a try if we are thinking the USB method might be the problem.

Edit: just tried installing the live USB using the Image Writer Program as I see is suggested on the manjaro first steps page, but got the same results as when I did it with rufus and balenaetcher.

Yeah that is correct. I would try the following:

  1. Boot the manjaro install disk and edit the bootloader entry there with e and add there to the kernel parameter: Now it will stop at the login screen, but not the graphical one. Login there.
  2. Look at the xorg log: cat /var/log/Xorg.0.log | less Is there an issue?
  3. If internet is available you can upload it: cat /var/log/Xorg.0.log | curl -F'file=-' and a link will be displayed.

However, i think the nvidia driver on that ISO seems not to support the GTX2080, but the log could say more.

1 Like

Here’s a picture of that log. I tried to do the command to upload it, but was getting an error that said “segmentation fault”

I’m not really experienced enough to make use of this log. Do you see any helpful info in it?

Also here’s what happens if I try to run the X command from this terminal, in case that is also helpful.

Here’s the full log without doing ‘less’ if you want to look through it:

1 Like

Yes, it does not load the nvidia module for any reason… even driver=nonfree is set in the kernel parameter.

It should look like this:

[  8378.658] (II) LoadModule: "nvidia"
[  8378.658] (II) Loading /usr/lib/xorg/modules/drivers/
[  8378.664] (II) Module nvidia: vendor="NVIDIA Corporation"
[  8378.664] 	compiled for, module version = 1.0.0
[  8378.664] 	Module class: X.Org Video Driver
[  8378.664] (II) NVIDIA dlloader X Driver  460.56  Tue Feb 23 23:25:58 UTC 2021
[  8378.664] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

Which ISO did you use? Please the full filename :slight_smile:

Ah when you are on the commandline, then run:

sudo systemctl start display-manager

Then check the xorg log again.

That is strange… i guess it is a typo or no internet is active. Check it with nmtui.


It is also possible that the chip id of RTX2080 is not in the database and therefore mhwd did not load the nvidia driver.

lspci -nnkkvt

It have to be like this:

           +-02.0-[01]--+-00.0  NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82]
           |            \-00.1  NVIDIA Corporation GP107GL High Definition Audio Controller [10de:0fb9]

10de:1c82 is the chip id. Could you tell which id is yours?

Doing this just gives me a black screen with a blinking cursor that doesn’t let me type anything.

Here’s what I get when I do that:

Yeah, probably just a typo I was trying to type what I was seeing on my phone screen but the formatting was probably a little off on my phone.

Here’s all the .iso files I have tried to use over the last few days, I tried a few different versions just to see if it would make any difference, but it never does.
manjaro-kde-21.0.1-210410-linux510.iso ← This one is the one that all screenshots are from

Strange, when i check the ID I get a match:

grep -o "1e82" /var/lib/mhwd/ids/pci/nvidia.ids

Could it be possible that you have integrated AMD GPU?

I will try these ISOs soon. But maybe try to boot the previous iso builds? Also kernel 5.10 and above tend to problems with nvidia sometimes. So maybe try kernel 5.4:

I have a AMD Ryzen 7 5800x. It does not have an integrated GPU. I am pretty sure none of the 5000 series have integrated graphics.

Ah, I didn’t know that. I’ll definitely give it a try!

I gave the ISO you linked a try, and I’m still getting stuck at the same point. I also tried the KDE 20.2.1 version a try just now and tried both with and without proprietary drivers. Still no luck, always stuck at Reached target Graphical Interface. :frowning:

Ok new path forward! now with new issues.

So I happen to have a radeon rx 580 4gb laying around that my buddy gave me after I helped him upgrade his pc last year. I popped out the 2080 and hooked up the rx 580 and was able to install manjaro like a breeze onto the ssd! Great!

I still want to use my 2080 though (I plan to switch between windows and Linux on separate drives regularly, at least for now) so I put the 2080 back in and when I try to boot, I see grub and everything just fine. But as soon as I Got past the grub menu my monitor just completely loses signal.

I feel like this is still a better place to be in than I was before because I’m assuming there is more I can do to fix this issue now that I actually have manjaro installed?

If needed I’m happy to pop the rx580 back in to do whatever might need to be done to sort this out, but ultimately I want to use the 2080.

OK i just tested it and the nvidia driver gets installed without problems with mhwd. However… You can install the nvidia driver also manually:

  1. Boot the iso like above into the commandline.
  2. Run this to install the driver:
sudo mhwd --install pci video-nvidia --pmconfig /opt/mhwd/pacman-mhwd.conf
  1. since you cant reboot here you have to remove nouveau driver manually:
sudo modprobe -r nouveau
sudo modprobe -r ttm
sudo modprobe -r drm_kms_helper
sudo modprobe -r drm
  1. and load nvidia driver:
sudo modprobe nvidia
sudo modprobe nvidia-drm
  1. now start the display-manager:
sudo systemctl start display-manager

Hope it works :slight_smile:


Man, thank you for putting so much effort into trying to help me with this!

Ok so when I put in

It said command not found, but I figured you probably meant modprobe because I saw it in the log when doing the install, so I tried that and it seemed to work I did the next command but when get to sudo modprobe -r drm_kms_helper it says sudo: stop: drm_kms_helper is in use.

Oh also, when I did the install command I got a bunch of warnings,is that normal?

yeah correct.

Sorry, was a typo :see_no_evil:

You forgot: --pmconfig /opt/mhwd/pacman-mhwd.conf which points the packages of the iso.

Oh! I had no idea that was part of the command! I have to read this all on my phone to put it in and the code goes off the screen and I had no idea it scrolled to the right! Lol

Ok so when I do the full command I still get loads of warnings.

And its still saying that the module is in use.

I’m in! Thank you so much for your help!

So I went back to my installation that I did using the amd gpu and put nomodeset in the grub menu and after doing that I was able to do alt-f2 to get to the terminal and then ran the command you gave for installing the nvidia driver,

mhwd --install pci video-nvidia

then I rebooted and now I’m in!

Sorry to any future people looking at this thread for answers if you don’t have a different gpu to use temporarily.

1 Like

Have you tried not using the Nvidia drivers and just using the open source drivers?

I had the same problem trying to install manjaro KDE.

Running the first command to install the nvidia drivers (on the tty) just solved my problem. After point 2 my manjaro live desktop pops up allowing me to install manjaro successfully.

Thank you so much.