Manjaro hangs starting in virtualbox

My host is Manjaro, and I wanted to install another Manjaro, which worked ok. I installed the new manjaro on a standalone SSD as a raw metal install. It boots in vbox just fine until I installed VBoxLinuxAdditions then the new Manjaro hangs when attempting to load as a guest. I then fell back (Re insalled VBoxLinuxASdditions) to 6.1.50 of GuestAdditions and the new Manjaro loads just fine. (I’m using VMDK to access the raw installation of the new Manjaro.)
As another test I applied VBoxLinuxAdditions at 7.0.0 but that guest of the new Manjaro failed to load as a guest.
Reapplied VBoxLinuxAdditions at 6.1.50 and the new Manjaro guest loads just fine.

Now You ask, how did I get the new Manjaro to load as a guest to re-apply VBoxLinuxAdditions ??
I discovered that if I tap the UPARROW key multiple times as the new Manjaro attempts to load as a guest, it does load.

Any thoughts on how to get VBoxLinuxAdditions 7.0.14 to load and the guest to start ?
I will post this to thevbox forum as I really feel that this is a vbox issue, thou it only effects Manjaro guests. (I have several other distros that don’t have this issue with VBoxLinuxAdditions 7.0.14)

For viirtual box vm - the most obvious is to remove plymouth - it is also a known issue … I first heard about it early last year - I think - my memory is flash memory :grin: the one that is gone in a flash

I suggest using a libvirt client instead. There are often issues with VirtualBox.

I have a number of other distros that load fine with 7.0.14 including EndvourOS (Arch based) that loads fine with the 7.0.14 Guest additions, so Im a little reluctant to address Plymouth as a cause. I’m also not familiar at all, regarding how to remove it. I couldn’t even figure out how to check if it’s installed in the latest Manjaro. (By the way I have another guest, zorin, that hangs the same as Manjaro and applying 6.1.50 to zorin fixed it’s hanging at startup as well. )

I am frequently running latest Manjaro in VirtualBox - no issues of any kind

But I do know that a some point - removing Plymouth could fix the issue

“Wa La” and the problem is resolved, maybe a work around but it works for me.


I played around with the grub edit screen and /etc/default/grub and I think that I discovered that it is only the “splash” parm that needs to be removed. It may be a recent development that whatever the other 2 parms “fixed” has now been corrected and thus only the “splash” parm removal is all that is needed to work.
linux-aarhus Any thoughts ?

Removing splash is what disables Plymouth, the other two (quiet and udev.log_priority=3) are just turning off any boot messages (because when using Plymouth you don’t want boot messages printed over your eye-candy splash screen). Leave them or remove them as you wish.

Thanks so much MrL, I appriciate the pointer to wikiarch as another source of information. I did leave both “quiet” and “udev.log_priority=3” in place but still get console messages scrolling, not a real problem as my real pupose is to boot a client and scrolling is short lived.