Manjaro hangs on boot and black screen since recent update

I updated my system (sudo pacman -Syu) earlier tonight and since then Manjaro fails to boot. It reaches GRUB normally, but shortly after it hits a grey (not completely black) screen and hangs. I have tried:

  1. Switching to an alternative login session. Ctrl Alt F3 had no effect, presumably its hanging before this point.
  2. Booting without X as per another thread on the forums (I apparently do not have perms to include the link). No change.
  3. Installing an alternative kernel. I had been running 5.8, but installed 5.4 with LTS to see if this was the cause. This did not cause any changes. However, funnily enough, I still had 5.7 installed so I tried this as well. Booting into that kernel displays an error message:
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to mount /boot/efi.
[DEPEND] Depdency failed for Local File Systems.
[FAILED] Failed to mount unit for core18, revision 1880.
[FAILED] Failed to mount unit for core18, revision 1885.
[FAILED] Failed to mount unit for discord, revision 112.
[FAILED] Failed to mount unit for discord, revision 115.
[FAILED] Failed to mount unit for gnome-3-28-1804, revision 128.
[FAILED] Failed to mount unit for gtk-common-themes, revision 1506.
[FAILED] Failed to mount unit for snapd, revision 8542.
[FAILED] Failed to mount unit for snapd, revision 8790.
[FAILED] Failed to mount unit for spotify, revision 41.
You are in emergency mode. After loggin in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.
Give root password for maintenance
(or press Control-D to continue):

I tried to do as suggested but I failed to get any response to any keyboard input.

  1. Updating system from chroot. I was able to manjaro-chroot in fine from a Live USB and attempted to update my system from there; no updates were needed.

  2. I checked some log files. The one thing that popped out at me was /var/log/Xorg.0.log.old:

[     7.694] (--) Log file renamed from "/var/log/" to "/var/log/Xorg.0.log"
[     7.695] 
X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
[     7.695] Build Operating System: Linux Manjaro Linux
[     7.695] Current Operating System: Linux jakepc 5.8.6-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:19:36 UTC 2020 x86_64
[     7.695] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=9a6318f2-d2ff-40d3-96bf-4e992d98a3ad rw quiet udev.log_priority=3
[     7.695] Build Date: 01 August 2020  07:25:56AM
[     7.695]  
[     7.695] Current version of pixman: 0.40.0
[     7.695]    Before reporting problems, check
        to make sure that you have the latest version.
[     7.695] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     7.695] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 14 02:17:24 2020
[     7.695] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     7.695] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     7.696] (==) ServerLayout "layout"
[     7.696] (**) |-->Screen "Screen0" (0)
[     7.696] (**) |   |-->Monitor "Monitor0"
[     7.696] (**) |   |-->Device "Device0"
[     7.696] (==) Automatically adding devices
[     7.696] (==) Automatically enabling devices
[     7.696] (==) Automatically adding GPU devices
[     7.696] (==) Automatically binding GPU devices
[     7.696] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     7.696] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[     7.696]    Entry deleted from font path.
[     7.696]    (Run 'mkfontdir' on "/usr/share/fonts/misc").
[     7.696] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[     7.696]    Entry deleted from font path.
[     7.696]    (Run 'mkfontdir' on "/usr/share/fonts/TTF").
[     7.696] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     7.696]    Entry deleted from font path.
[     7.696] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     7.696]    Entry deleted from font path.
[     7.696] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     7.696]    Entry deleted from font path.
[     7.696] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     7.696]    Entry deleted from font path.
[     7.696] (==) FontPath set to:

[     7.696] (==) ModulePath set to "/usr/lib/xorg/modules"
[     7.696] (**) Extension "COMPOSITE" is enabled
[     7.696] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[     7.696] (II) Module ABI versions:
[     7.696]    X.Org ANSI C Emulation: 0.4
[     7.696]    X.Org Video Driver: 24.1
[     7.696]    X.Org XInput driver : 24.1
[     7.696]    X.Org Server Extension : 10.0
[     7.698] (++) using VT number 1

[     7.698] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     7.699] (II) xfree86: Adding drm device (/dev/dri/card0)
[     7.703] (--) PCI: (0@0:2:0) 8086:1912:1028:072a rev 6, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64
[     7.703] (--) PCI:*(1@0:0:0) 10de:1c82:196e:11c3 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[     7.703] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     7.703] (II) LoadModule: "glx"
[     7.703] (II) Loading /usr/lib/xorg/modules/extensions/
[     7.706] (II) Module glx: vendor="X.Org Foundation"
[     7.706]    compiled for 1.20.8, module version = 1.0.0
[     7.706]    ABI class: X.Org Server Extension, version 10.0
[     7.706] (II) LoadModule: "nvidia"
[     7.706] (II) Loading /usr/lib/xorg/modules/drivers/
[     7.706] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.706]    compiled for, module version = 1.0.0
[     7.706]    Module class: X.Org Video Driver
[     7.706] (II) NVIDIA dlloader X Driver  440.100  Fri May 29 08:21:27 UTC 2020
[     7.706] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.706] (II) Loading sub module "fb"
[     7.706] (II) LoadModule: "fb"
[     7.707] (II) Loading /usr/lib/xorg/modules/
[     7.707] (II) Module fb: vendor="X.Org Foundation"
[     7.707]    compiled for 1.20.8, module version = 1.0.0
[     7.707]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.707] (II) Loading sub module "wfb"
[     7.707] (II) LoadModule: "wfb"
[     7.707] (II) Loading /usr/lib/xorg/modules/
[     7.707] (II) Module wfb: vendor="X.Org Foundation"
[     7.707]    compiled for 1.20.8, module version = 1.0.0
[     7.707]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.707] (II) Loading sub module "ramdac"
[     7.707] (II) LoadModule: "ramdac"
[     7.707] (II) Module "ramdac" already built-in
[     7.712] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[     7.712] (EE) NVIDIA:     system's kernel log for additional error messages and
[     7.712] (EE) NVIDIA:     consult the NVIDIA README for details.
[     7.712] (EE) No devices detected.
[     7.712] (EE) 
Fatal server error:
[     7.712] (EE) no screens found(EE) 
[     7.712] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[     7.712] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     7.712] (EE) 
[     7.712] (EE) Server terminated with error (1). Closing log file.

and in particular, the errors at the end; presumably this is related, but even if it is I have absolutely no idea how to address it.

System Information

$ inxi -Fazy from within a chroot on the Live USB:

  12Kernel 5.6.15-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 10.1.0 
  12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MANJARO_KDE_2003 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  12Console N/A 12wm kwin_x11 12Distro Manjaro Linux 
  12Type Desktop 12System Dell 12product XPS 8910 12v 1.0.9 12serial <filter> 12Chassis 
  12type 3 12serial <filter> 
  12Mobo Dell 12model 0WPMFG 12v A00 12serial <filter> 12UEFI Dell 12v 1.0.9 
  12date 09/01/2016 
  12Topology Quad Core 12model Intel Core i7-6700 12socket U3E1 12bits 64 12type MT MCP 
  12arch Skylake-S 12family 6 12model-id 5E (94) 12stepping 3 12microcode D6 
  12L1 cache 256 KiB 12L2 cache 8192 KiB 12L3 cache 8192 KiB 
  12flags avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 12bogomips 54417 
  12Speed 900 MHz 12min/max 800/3400 MHz 12base/boost 3400/8300 12volts 1.1 V 
  12ext-clock 100 MHz 12Core speeds (MHz) 121 900 122 900 123 900 124 901 125 900 126 901 
  127 900 128 900 
  12Vulnerabilities 12Type itlb_multihit 12status KVM: Vulnerable 
  12Type l1tf 12mitigation PTE Inversion 
  12Type mds 12mitigation Clear CPU buffers; SMT vulnerable 
  12Type meltdown 12mitigation PTI 
  12Type spec_store_bypass 
  12mitigation Speculative Store Bypass disabled via prctl and seccomp 
  12Type spectre_v1 
  12mitigation usercopy/swapgs barriers and __user pointer sanitization 
  12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  12Type tsx_async_abort 12mitigation Clear CPU buffers; SMT vulnerable 
  12Device-1 Intel HD Graphics 530 12vendor Dell 12driver i915 12v kernel 
  12bus ID 00:02.0 12chip ID 8086:1912 
  12Device-2 NVIDIA GP107 [GeForce GTX 1050 Ti] 12vendor PNY 12driver nouveau 
  12v kernel 12bus ID 01:00.0 12chip ID 10de:1c82 
  12Display 12server 1.20.8 12compositor kwin_x11 12driver nouveau 
  12note display driver n/a 12FAILED nvidia 
  12Message Advanced graphics data unavailable for root. 
  12Device-1 Intel 100 Series/C230 Series Family HD Audio 12vendor Dell 
  12driver snd_hda_intel 12v kernel 12bus ID 00:1f.3 12chip ID 8086:a170 
  12Device-2 NVIDIA GP107GL High Definition Audio 12vendor PNY 
  12driver snd_hda_intel 12v kernel 12bus ID 01:00.1 12chip ID 10de:0fb9 
  12Device-3 ARC Camera 12type USB 12driver snd-usb-audio,uvcvideo 12bus ID 1-6:4 
  12chip ID 05a3:9331 12serial <filter> 
  12Device-4 C-Media Audio Adapter (Unitek Y-247A) 12type USB 
  12driver hid-generic,snd-usb-audio,usbhid 12bus ID 3-1:2 12chip ID 0d8c:0014 
  12Sound Server ALSA 12v k5.6.15-1-MANJARO 
  12Device-1 Intel Wireless 3165 12driver iwlwifi 12v kernel 12port e000 
  12bus ID 03:00.0 12chip ID 8086:3165 
  12IF wlp3s0 12state up 12mac <filter> 
  12Device-2 Qualcomm Atheros QCA8171 Gigabit Ethernet 12vendor Dell 12driver alx 
  12v kernel 12port d000 12bus ID 04:00.0 12chip ID 1969:10a1 
  12IF enp4s0 12state down 12mac <filter> 
  12Local Storage 12total 1.38 TiB 12used 35.20 GiB (2.5%) 
  12ID-1 /dev/sda 12vendor Seagate 12model ST1000DM003-1SB102 
  12family Barracuda 7200.14 (AF) 12size 931.51 GiB 12block size 12physical 4096 B 
  12logical 512 B 12sata 3.0 12speed 6.0 Gb/s 12rotation 7200 rpm 12serial <filter> 
  12rev CC43 12temp 34 C 
  12SMART yes 12state enabled 12health PASSED 12on 1y 296d 23h 12cycles 2251 
  12read 17.80 TiB 12written 18.48 TiB 12Pre-Fail 12attribute Spin_Retry_Count 
  12value 100 12worst 100 12threshold 97 
  12ID-2 /dev/sdb 12vendor Silicon Power 12model SPCC Solid State Disk 
  12family Driven OEM SSDs 12size 476.94 GiB 12block size 12physical 512 B 
  12logical 512 B 12sata 3.2 12speed 6.0 Gb/s 12serial <filter> 12rev 61.3 12temp 33 C 
  12SMART yes 12state enabled 12health PASSED 12on 53d 6h 12cycles 246 12written 776 GiB 
  12ID-3 /dev/sdd 12type USB 12vendor Generic 12model Flash Disk 12size 7.81 GiB 
  12block size 12physical 512 B 12logical 512 B 12serial <filter> 12rev 8.07 
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure? 
  12Hardware-1 Intel SATA Controller [RAID mode] 12driver ahci 12v 3.0 12port f060 
  12bus ID 00:17.0 12chip ID 8086.2822 12rev 31 
  12ID-1 / 12raw size 476.44 GiB 12size 467.96 GiB (98.22%) 12used 35.03 GiB (7.5%) 
  12fs ext4 12block size 4096 B 12dev /dev/sdb2 
  12Alert No Swap data was found. 
  12System Temperatures 12cpu 44.0 C 12mobo 29.8 C 12gpu nouveau 12temp 35 C 
  12Fan Speeds (RPM) N/A 
  12Processes 244 12Uptime 22m 12Memory 15.54 GiB 12used 1.48 GiB (9.5%) 12Init systemd 
  12v 246 12Compilers 12gcc 10.2.0 12Packages 12pacman 1179 12lib 307 12flatpak 0 
  12Client Unknown Client: systemd 12inxi 3.1.05

(I’m not sure what’s up with all the 12s, but am copy pasting here without changes.)

1 Like

But your inxi output shows kernel 5.6.15. Why is that?

What exactly happens when you boot with a live CD and chroot into your installation? I am wondering if all drives are available or if your /etc/fstab is correct. The errors your are showing here seem all have to do with mount failures. Even the Xorg.log is complaining about a “missing directory”

Presumably the output shows 5.6 because that’s the kernel on the live USB; the advanced options for Manjaro in GRUB do confirm 5.4, 5.7, and 5.8 as the installed kernels though.

Besides that, the boot from the Live USB seems to proceed normally; I can provide more specific information if I knew what to look for.

I’ve checked my /etc/fstab and it seems correct:

$ cat /etc/fstab
# /dev/sdb2
UUID=9a6318f2-d2ff-40d3-96bf-4e992d98a3ad       /               ext4            rw,noatime      0 0

# /dev/sdb1
UUID=F39E-E666          /boot/efi       vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro       0 0

/swapfile               none            swap            defaults,pri=-2 0 0
$ blkid /dev/sdb1
/dev/sdb1: UUID="F39E-E666" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="ESP" PARTUUID="da98171d-88f2-426e-8b24-c24a681063ae"
$ blkid /dev/sdb2
/dev/sdb2: UUID="9a6318f2-d2ff-40d3-96bf-4e992d98a3ad" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="primary" PARTUUID="67d80857-8c32-47d1-a8a4-48acdb42c1a5"

I’m not sure what else to look for here.

That looks really strange. Have considered to search for pacsave files?

locate --existing --regex "\.pac(new|save)$"

If it is an old installation wrong configurations could break the system after time.
Solve it with:

pacdiff -l

I have seen that “Failed to mount /boot/efi” error recently. Reinstall kernel from live USB or some kernel that works. If necessary reinstall grub

you have to update your bios
see on site Dell bios EFI XPS 8910

check smart status / access under live is USB
for your disks

I cannot seem to find the locate command, as my PATH seems to have been somewhat mangled in the chroot. Could you share the default install location?

The 5.4 LTS kernel that I just installed was from the live usb and it did not resolve the issue. If I am misunderstanding please let me know

Sorry, I misread your message. You only have that error I mention with kernel 5.7. In this case, probably only that kernel needs reinstall. But I think it’s a different problem than your main problem.

Anyway, do you see anything relevant in system logs?

journalctl -b -1

(When chroot)

I’ve just updated my BIOS as per Dell’s website. No change.

One thing that pops out at me is

Sep 14 04:22:06 jakepc systemd-modules-load[264]: Failed to find module 'nvidia'

which seems to be a similar error to the one shown in the Xorg logs. Maybe this is a graphics problem?

Also relevant is probably

Sep 14 04:22:08 jakepc sddm[797]: Failed to read display number from pipe
Sep 14 04:22:08 jakepc sddm[797]: Display server failed to start. Exiting
Sep 14 04:22:09 jakepc systemd-coredump[947]: Process 797 (sddm) of user 0 dumped core.
                                              Stack trace of thread 797:
                                              #0  0x00007ff17b4da615 raise ( + 0x3d615)
                                              #1  0x00007ff17b4c3862 abort ( + 0x26862)
                                              #2  0x00007ff17b8ee9ac _ZNK14QMessageLogger5fatalEPKcz ( + 0x8f9ac)
                                              #3  0x000055b175a850c8 n/a (sddm + 0x290c8)
                                              #4  0x000055b175ac74b1 _ZN4SDDM4SeatC2ERK7QStringP7QObject (sddm + 0x6b4b1)
                                              #5  0x000055b175ac9081 _ZN4SDDM11SeatManager10createSeatERK7QString (sddm + 0x6d081)
                                              #6  0x000055b175ac9ec3 n/a (sddm + 0x6dec3)
                                              #7  0x00007ff17bb47a06 n/a ( + 0x2e8a06)
                                              #8  0x000055b175ac8080 _ZN4SDDM10LogindSeat19canGraphicalChangedEb (sddm + 0x6c080)
                                              #9  0x00007ff17bb47a06 n/a ( + 0x2e8a06)
                                              #10 0x00007ff17c4a58e0 _ZN23QDBusPendingCallWatcher8finishedEPS_ ( + 0x648e0)
                                              #11 0x00007ff17bb3d1b2 _ZN7QObject5eventEP6QEvent ( + 0x2de1b2)
                                              #12 0x00007ff17bb10770 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent ( + 0x2b1770)
                                              #13 0x00007ff17bb13283 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData ( + 0x2b4283)
                                              #14 0x00007ff17bb69cd4 n/a ( + 0x30acd4)
                                              #15 0x00007ff17a65043c g_main_context_dispatch ( + 0x5243c)
                                              #16 0x00007ff17a69e1d9 n/a ( + 0xa01d9)
                                              #17 0x00007ff17a64f221 g_main_context_iteration ( + 0x51221)
                                              #18 0x00007ff17bb69311 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE ( + 0x30a311)
                                              #19 0x00007ff17bb0f11c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE ( + 0x2b011c)
                                              #20 0x00007ff17bb175a4 _ZN16QCoreApplication4execEv ( + 0x2b85a4)
                                              #21 0x000055b175a87f31 main (sddm + 0x2bf31)
                                              #22 0x00007ff17b4c5152 __libc_start_main ( + 0x28152)
                                              #23 0x000055b175a8823e _start (sddm + 0x2c23e)
                                              Stack trace of thread 807:
                                              #0  0x00007ff17b59246f __poll ( + 0xf546f)
                                              #1  0x00007ff17a69e168 n/a ( + 0xa0168)
                                              #2  0x00007ff17a64f221 g_main_context_iteration ( + 0x51221)
                                              #3  0x00007ff17bb69311 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE ( + 0x30a311)
                                              #4  0x00007ff17bb0f11c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE ( + 0x2b011c)
                                              #5  0x00007ff17b92ac32 _ZN7QThread4execEv ( + 0xcbc32)
                                              #6  0x00007ff17c458098 n/a ( + 0x17098)
                                              #7  0x00007ff17b92be0f n/a ( + 0xcce0f)
                                              #8  0x00007ff17b4843e9 start_thread ( + 0x93e9)
                                              #9  0x00007ff17b59d293 __clone ( + 0x100293)
Sep 14 04:22:12 jakepc systemd[1]: sddm.service: Start request repeated too quickly.
Sep 14 04:22:12 jakepc systemd[1]: sddm.service: Failed with result 'core-dump'.
Sep 14 04:22:12 jakepc systemd[1]: Failed to start Simple Desktop Display Manager.

This is likely to be the issue then. Any idea what the cause is or how to fix?

I got a chance to get locate working:

$ locate --existing --regex "\.pac(new|save)$"

I resolved those issues, but they do not seem to relate in any way to the errors I found in the system logs above, so I find it unlikely that this is the cause.

I would say make a clean reinstall the nvidia driver:

sudo mhwd -r pci video-nvidia-450xx
sudo mhwd -i pci video-nvidia-450xx
1 Like

I was able to fix the problem after doing some reading on threads with similar problems. pacman -S linux58-nvidia-440xx did the trick and allows me to boot into the 5.8 kernel without issues. For whatever reason this was not installed; probably I had installed the drivers in a weird way in the past, causing issues once things got updated.

Thanks to everybody who offered their help!

1 Like

Glad you found the issue. For others that run across this I have found that sometimes old builds of drivers are removed, especially from AUR, which is why it looks like you don’t have a driver installed. You can fix this either how you did via the command line, or if you can get it to boot (I had an issue only when my secondary monitor was plugged in), you can use the ‘Manjaro Settings Manager’.

You can have this issue with other drivers like printers, as well. Although that would not keep you from booting…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.