Manjaro GNOME won't boot on Raspberry Pi 4 model B 8GB

Hello everyone. I’m trying to boot the official Manjaro GNOME for ARM 21.06 image on a Raspberry Pi 4 Model B 8GB, made by Raspberry Pi Imager, but after the first Manjaro logo screen, all hardware / monitor activity suddenly ceases with only a command prompt cursor blinking. I tried 3 different SD cards and 3 different USB-C AC power adaptors to eliminate some common issues with Raspberry Pi’s before coming here, as well as waited 30 minutes for the initial boot to start, just in case.

I don’t know whether I’m supposed to post a journal output, but there’s literally nothing I can do or type after the boot hangs. I’m really new to Linux / Raspberry Pi, so any suggestions would be graciously appreciated. Thank you!

Did you run the initial setup procedure on first boot already? There should be a CLI based wizard asking for user, language and country settings…

I can’t even make it to the initial setup screen. Right after the very first Manjaro logo screen with the loading circle under it, the screen goes black and hangs on a blinking cursor…

Sounds a bit like this to me…

Can you try to change the TTY and log in to the console?

I tried the alt+ctrl+F2 keystroke mentioned in the Reddit post, and during my second boot, I got this screen:

There’s also that blinking cursor on the bottom.

Seems there have been some issues with earlier builds of the 21.06 for RPi4… MANJARO Arm , No First Boot - #4 by Darksky. could you please check if you use the latest version of the image (uploaded some days ago)

I downloaded it just yesterday!

Have you ever boot another OS with this device ? (rpiOS for instance) To be sure that it boots correctly and its firmware is up to date ?

I haven’t tried any other OS yet, I’ll give it a shot if I see there’s no other way to solve this… Even though that makes me think, my Raspberry Pi 4 came bundled with an SD card w/ NOOBS in it, so this could be an older RP model?

Depending on what pi bundle you order the Noobs and sdcard come with some bundles. Most likely if you just received the pi4 the eeprom should boot with usb boot. The other firmware in the boot partition is the latest in the stable branch so should be good.

I downloaded the Gnome image and it appears to be have issues with loading GDM on the first boot. @Strit / @appelgriebsch I was able to get to the terminal and login as root and looked at journalctl:

looks like it tries to read a boolean value from the config file, but got some unexpected input instead… will have to verify the autostart configuration that got introduced for the new calamares OEM installer

EDIT: looks like it tries to read a value that isn’t there… common/gdm-settings-direct.c · master · GNOME / gdm · GitLab

Thank you and Darksky for taking a look at this… if I understand correctly, is this a bug on the existing image? Is this something I have to fix manually or do we have to wait for a new revision of the image to be compiled and published? Thanks again fellas, I really appreciate all your help.

EDIT: (also, I have no idea how to disable TTY mode now!)

We have a new RPi4 Gnome image build ready. Please try 21.07. in our tests it performed well.


I’m not sure if this should warrant a separate forum post or not, so I apologise if it does.

I’m having an identical problem to the one described in this thread while using the most recent Manjaro ARM Sway image.

If anyone has any solutions or ideas on how to fix this, I would be very appreciative.


Is this the 21.07 image as it is the latest.

Yes it is, I downloaded it from: Manjaro - Downloads

It will not boot here either after downloading and installing the image.

if you have a working manjaro install you can use the manjaro-arm-installer to create a sway install.

i downloaded xfce & used that to make a sway install on sd.

Looks like we had a bug in the script that starts the calamares-oem setup. You can temporarily fix this by

  1. Mounting the microSD
  2. Go to the /var/run/media/…/ROOT_MNJRO/etc/greetd folder
  3. Open the config.toml in an editor e.g. sudo nvim config.toml
  4. Go to the line with the oem-setup and add the missing
  5. Save the file e.g. :w
  6. reboot with the microSD


Thank you Andreas! I installed 21.04 a week ago, so I’m currently all set, but this is great news!

1 Like