Manjaro Gnome switcheroo-control option not showing

Prime-run from terminal is working fine. So i decided to install the this switcheroo-control.
I did right click from the application launcher but no option there like switch the gpus.

I’m just guessing that you have to reboot the system after installing it. Did you?

yeah i did still not showing

Have you tried to contact the developer Bastien Nocera / switcheroo-control · GitLab

File an issue. They clearly state they tested it on MacBook Pro (8,2) and Thinkpad T430s. What is your hardware. Make sure you share inxi -Fazy and mhwd -li

Also you can open Issues · Bastien Nocera / switcheroo-control · GitLab and ask for more assistance.

inxi -Fazy

  Kernel: 5.13.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.13-x86_64 
  root=UUID=891f8736-3b80-49a6-b6bb-1b93bfe8afd2 rw rootflags=subvol=@ quiet 
  root=/dev/mapper/luks-38b217b0-d4c3-4c74-a64c-a5abeda1acb4 splash apparmor=1 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X512FL_X512FL 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X512FL v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X512FL.303 date: 08/26/2019 
  ID-1: BAT0 charge: 29.3 Wh (100.0%) condition: 29.3/37.1 Wh (78.9%) 
  volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A 
  status: Not charging cycles: 299 
  Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: EA cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 700 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 700 2: 700 3: 732 
  4: 655 5: 600 6: 688 7: 600 8: 654 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: ASUSTeK 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300 
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: ASUSTeK driver: nvidia 
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 
  chip-ID: 10de:1d13 class-ID: 0302 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 1-6:3 chip-ID: 13d3:56d3 class-ID: 0e02 serial: <filter> 
  Display: x11 server: 1.20.13 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.6 
  direct render: Yes 
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl 
  bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.11-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel 
  port: 5000 bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Local Storage: total: 462.05 GiB used: 45.12 GiB (9.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: RBUSNS8154P3256GJ3 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 type: SSD serial: <filter> rev: E8FK11.T temp: 47.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 052 scheme: GPT 
  ID-1: / raw-size: 225.47 GiB size: 225.47 GiB (100.00%) 
  used: 45.12 GiB (20.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-38b217b0-d4c3-4c74-a64c-a5abeda1acb4 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 712 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 225.47 GiB size: 225.47 GiB (100.00%) 
  used: 45.12 GiB (20.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-38b217b0-d4c3-4c74-a64c-a5abeda1acb4 
  ID-4: /var/log raw-size: 225.47 GiB size: 225.47 GiB (100.00%) 
  used: 45.12 GiB (20.0%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-38b217b0-d4c3-4c74-a64c-a5abeda1acb4 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 12.7 GiB used: 768 KiB (0.0%) 
  priority: -2 dev: /dev/dm-1 maj-min: 254:1 
  mapped: luks-bbe98d8d-4ae8-4702-a451-68636aec59a8 
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3000 
  Processes: 302 Uptime: 1h 31m wakeups: 1 Memory: 11.55 GiB 
  used: 2.14 GiB (18.5%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: pacman: 1294 lib: 408 flatpak: 0 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.06 

mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.07.28               false            PCI

Warning: No installed USB configs!

Checking the list of iGPU ID, makes me think that yours in not there data/30-pci-intel-gpu.hwdb · master · Bastien Nocera / switcheroo-control

So, you can contact the developer and ask for assistance in that regard.

yeah my igpu is there, Intel UHD 620.(check at line number 758)

well thanks for your time, i fixed it by these two commands.

systemctl start switcheroo-control.service```
systemctl enable switcheroo-control.service

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.