Manjaro Gnome Freezes randomly

Hello,
I installed Manjaro gnome on a laptop with low configs. I just did a fresh install with all default options (let the installer decide whatever is better).

I experience random system freeze where nothing works. Not even switching to tty and Sysrq. I have to hard reset by holding down power button. There is no defined pattern for this freeze. After reading many such similar posts, I tried to look into the swap space. However, I did not find one (I assume the partition type for swap will be “swap”)

here is my system config:

inxi
ystem:
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=973b9d6e-27e8-4db7-8311-9145072a59d2 ro quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Acer product: Aspire R3-131T v: V1.15 serial: <filter> 
  Mobo: Acer model: Aspire R3-131T v: V1.15 serial: <filter> UEFI: Insyde 
  v: 1.15 date: 07/04/2016 
Battery:
  ID-1: BAT0 charge: 19.4 Wh (58.3%) condition: 33.3/48.9 Wh (68.0%) 
  volts: 14.9 min: 15.2 model: PANASONIC AC14B3K type: Li-ion serial: <filter> 
  status: Discharging 
Memory:
  RAM: total: 3.67 GiB used: 2.57 GiB (69.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: Intel Pentium N3710 bits: 64 type: MCP arch: Airmont 
  family: 6 model-id: 4C (76) stepping: 4 microcode: 411 cache: L2: 1024 KiB 
  bogomips: 12805 
  Speed: 480 MHz min/max: 480/2560 MHz Core speeds (MHz): 1: 480 2: 480 3: 658 
  4: 772 
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_perfmon bts clflush 
  cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept erms 
  est flexpriority fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs 
  pge pni popcnt pse pse36 pti rdrand rdtscp rep_good sep smep ss sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi vpid xtopology 
  xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0 
  chip-ID: 8086:22b1 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-3:2 
  chip-ID: 04f2:b520 class-ID: 0e02 
  Display: wayland server: X.org 1.20.11 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 21.1.5 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus-ID: 00:1b.0 chip-ID: 8086:2284 class-ID: 0403 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 1000 
  bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: 1000 
  bus-ID: 02:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:4 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 465.76 GiB used: 280.38 GiB (60.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD5000LPCX-21VHAT0 size: 465.76 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> 
  rev: 1A01 scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 463.26 GiB size: 454.99 GiB (98.21%) 
  used: 280.37 GiB (61.6%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 973b9d6e-27e8-4db7-8311-9145072a59d2 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 6.9 MiB (1.4%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: A582-C75D 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/sda2 maj-min: 8:2 size: 2 GiB fs: swap label: N/A 
  uuid: 98546811-19a6-4a13-a56f-b53a99000024 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 7 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: Chicony HD WebCam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b520 
  class-ID: 0e02 
  Device-2: 1-4:3 info: Raydium Raydium Touch System type: HID 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 96mA chip-ID: 2386:0401 class-ID: 0300 
  Device-3: 1-5:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 208 Uptime: 1h 25m wakeups: 1 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1324 lib: 391 
  flatpak: 0 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06 

Here are my partitions

fdisk -l
Device       Start       End   Sectors   Size Type
/dev/sda1     2048   1050623   1048576   512M EFI System
/dev/sda2  1050624   5244927   4194304     2G Linux filesystem
/dev/sda3  5244928 976773134 971528207 463.3G Linux filesystem

Is there a swap configured for my system? what is the 2GB of space taken by sda2?
Is there anything else I should look for?

Thanks.

This is not the full output, see this: [HowTo] Provide System Information

This kernel has been EOL for quite a while. Either upgrade to the latest LTS kernel which is 5.10, or the latest stable kernel which is 5.13. I would test 5.10 first to see if your issue remains there.

Hello,
Thanks for your reply. Yes I removed some part of the command (I didn’t know about the three back ticks) as it complained about posting links - now I have edited the original post.

Also, I just update my system using “sudo pacman -Syy” and “sudo pacman -Syu”
Do I need to manually install the latest Kernel?

Also, what about the swap space? I don’t seem to have one?

Thanks.

Likely, kinda wish this was more automatic so it doesn’t leave people on EOL kernels. Simply go to setting and go to the kernel settings menu. From there click install on the 510 kernel, wait for it to finish then restart. You can confirm you are running off the 5.10 kernel by running the command uname -r

Not created automatically, but with that little ram you have (especially since you have an iGPU), I would certainly create one. Please follow this: Swap - Manjaro

1 Like

Thank you very much for your responses.
I will do both suggested upgrades - Updating Kernel and adding swap and post after that.

Thanks again.

Hello,

I tried to upgrade to kernel 5.10 LTS and it was successful.

About the Swap feature, I see there is a 2Gb partition in the fdisk discovery which says that its a “linux filesystem”. But when I try to mount the sda2 partition, it complains thus,

mount: /mnt/usb: unknown filesystem type 'swap'.

So, my guess(wild) is swap partition is created but not formatted properly? And is 2GB enough for a system with 4GB of memory?

Thanks.

No idea what it is, but it must be a filesystem like ext4 and not a swap…

Sure you can reformat it:

sudo mkswap /dev/sda2

and add it to fstab.

:warning: But make sure there is nothing on there which is needed by mounting it:

sudo mount /dev/sda2 /mnt
ls /mnt
sudo umount /mnt

Hello megavolt,

Thanks for your response. As I replied in my previous post, I am not able to mount that partition. (At first I was afraid that it was my home partition or something). But when I try to mount sda2, I get the message as,

mount: /mnt/usb: unknown filesystem type 'swap'.

Then I am not sure why fdisk says it as “linux filesystem”

ok… I totally misread that sorry :smiley:

Try to mount the swap:

sudo swapon /dev/sda2

and check:

sudo swapon -s

But this is only temporary. You will need to add the swap to fstab for permanent mount.

https://wiki.archlinux.org/title/Swap#Swap_partition

Thanks for the suggestions megavolt and Evernow,

I did what is suggested here - install new kernel and make the 2GB as linux swap. After that I worked for few hours without freezing (using firefox with many tabs). That seems good. No freezing so far. Will come back if the problem persists.

Thanks again very much guys for your responses.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.