Manjaro gnome edition 20.2 final release candidate

I’m interesting to translate your application in French? Where can I put a pull request ?

Here you go. You’ll need to request developer access so you can make a new branch for your changes. If you do the groundwork for translations, it will be much easier for everyone else to contribute their languages too.

You can also make it integrate with the language selection of manjaro-hello, because it is used as a plugin there.

I just logged into a Wayland session on GNOME and it doesn’t appear Mutter supports the extension:

❯ wl-gammactl
compositor doesn't support wlr-gamma-control-unstable-v1

No, and it probably never will be.

This is basically just a GUI slapped on the example code from here.

…and proper dependencies:

Well, it’s for wl-roots, and mutter is not based on that. It working with gnome would be a pure coincidence :man_shrugging:

Right, but yet here we are in a topic about GNOME. :wink:

@Chrysostomus and @Yochanan: Well, I wanted to test wl-gammactl under gnome, but as Yochanan did, it is no longer necessary.

Is there any other alternative to configure the gamma on Wayland as I don’t like Night Color (KDE) and Night Light (Gnome) app ? It is not as good as kgamma and xgamma app.

Thanks.

Have you tried redshift-wayland-git in the AUR?

No, but I’ll give it a try. Thanks for the information. :wink:

@Chrysostomus:

Hi,

First of all, I have a few remarks about Manjaro Gnome 20.2-rc3.

First, I want to tell you that I appreciate the new features in this version. :wink:
Second, the way to create the first user of the system is nice. It feels like Windows. :grin:
Third, you did a good job. Well done Manjaro team. :wave:

I tested this Manjaro Gnome 20.2-rc3, and here is my review:

Regarding Live usb

  1. At the first boot screen, I noticed 2 entries for the “Edit boot options” option. When I use this option nothing happens for one, and for the other it appends “Edit boot options” information multiple times. Is this a bug ? What is this option for ?

  2. The backlight adjustment problem is still present with the new 5.9.10 kernel. So, we must add in the kernel command line at Grub level, the option: i915.enable_dpcd_backlight = 0
    Otherwise, it doesn’t work.

    Note: This option should be present by default at the liveusb and Grub level, if this problem is not
    resolved when the final version is released.

  3. Window Tiling (pop-shell) is only in English (so in my case it is not translated into French). Which is a bit of a shame. Otherwise, the entire desktop is generally well translated.

  4. At the level of Calamares and the installation of the system. I noticed some untranslated translations in French at the level of:

  • “Cancel” button on the screen where you modify the partition you choose.
  • Elements in English during installation: unpacking …, modify partition, configure the hardware, configure … display manager, Misc postinstall configurations

After the installation

When the system appears, the “keyboard choice (input)” screen displays an untranslated header. As well as a “Close” button noticed on several windows.

At the Manjaro Hello level, some elements are not translated:

  • Applications -> Common application selection
  • Gnome layouts manager -> Manjaro gnome config tools

Regarding the ‘bug’ stated by openminded, it is not present when we run gnome-layout-switcher via Manjaro Hello. On the other hand, it appears when you run gnome-layout-switcher directly.

Where is “Manjaro-application-utility” ? I don’t see it in the apps. Must I have an internet connexion to use it ? Can you tell me more about it ? Thanks.

One last thing. If I configure all the live usb as I want, all the configurations made at the liveusb level will be present after the installation of the system on the media (SDD, HDD, …) ? How to offer a ready-to-use system for another user with Manjaro Gnome 20.2 (for example: friend) ?

That’s it for now. I will continue to test this Gnome 20.2-rc3 over the next few days. If I have any news, I will get back to you.

Regards.

@Ste74, your update broke the menu. We need to roll that back. This is the same bug why we couldn’t adjust the other entry names either.

It should be in bottom left of Manjaro-hello

No, changes are discarded, except maybe wifi.

You need to build a new iso or use manjaro-architect for that.

@Chrysostomus: What about translations ? Has a team taken care of this ? The Manjaro-application-utility application is not also translated.
I suggest that Gnome-layouts-switcher, Manjaro-application-utility and pop-shell be translated for the future.

I found “Manjaro-application-utility” and it works well. :slightly_smiling_face:

Translations are going to take some time, as no translation support has been coded into gnome-layout-switcher.

Ok. If you need help you can ask me. :wink:

If you have time to add the support, pull requests are welcome. You can use the request access button in gitlab and make a new branch for the feature.

@Chrysostomus: I’m not developer or programmer, so I can’t help you to code. I can help you to translate the application but don’t ask me to modify the code.
Furthermore, I don’t know how to create a .pot file. I let you modify the code to support multi-languages for gnome-layout-switcher and Manjaro-application-utility.

Note: Loginized application works on Manjaro with Gnome 3.38.1 (The application that allows you to change the wallpaper of GDM). I installed it from the AUR repository here.

Regards.

Yesterday I installed manjaro 20.2-rc3 and there are three issue.
First of all, pamac can’t be add to dash to dock.
Secondly, The latest boot animation is not displayed when booting. My pc is xiaomi notebook pro
Last, the cheese camera does not work.

!!! Warning !!! Yesterday, I received only one update, it was for Gnome shell material shell (extension) from Manjaro repositories. I made that update.

Today, I launched my system and I can’t login into my user session (wayland). I tried xorg session in gdm and I can’t no login too. So be careful before make that update. If necessary make a backup or a snapshot of your system.

Regards.

You can disable your extensions from tty and try again

This is a known issue and fixed in the upcoming pamac version.

Was this uefi or legacy boot? We have had some reports of it not working on legacy boot.

This is an on/off bug with cheese.
I seem to have the same issue … but was able to make it work defining the device path:

cheese -d /dev/video1

(your path may be different)