Manjaro Gnome crashing on shutdown

I’m running Manjaro and Windows 10 dual boot from an SSD and also have a HDD for storage. Its on an HP laptop with integrated graphics. I’m getting this error on shutdown, which the computer freezes and i have to shutdown by hard pressing the power button.

This happens around 10% of the times normally but when I don’t wait for 60 seconds to finish while turning off and click on power off again, it happens almost every time.

I’m not able to upload picture here, but the code says

  • Failed to unmount /oldroot

  • Failed to unmount /oldroot/dev/pts

  • Failed to unmount /oldroot/dev

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=791aff02-67f3-45ce-97c6-9b71024bcb30 rw apparmor=1 
  security=apparmor resume=UUID=dcc97cbf-9f1e-42f4-87fe-80f5c831181c 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC 
  v: 0976100000405F10000610180 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 218F v: 39.15 serial: <filter> UEFI: Insyde 
  v: F.0C date: 01/08/2013 
  ID-1: BAT0 charge: 14.9 Wh condition: 20.7/20.7 Wh (100%) volts: 17.1/14.8 
  model: HP type: Li-ion serial: N/A status: Charging 
  Info: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19166 
  Speed: 2395 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 2395 2: 2395 
  3: 2395 4: 2395 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: Realtek HP Truevision HD integrated webcam type: USB 
  driver: uvcvideo bus ID: 2-3:2 chip ID: 0bda:5776 serial: <filter> 
  Display: wayland server: 1.20.10 compositor: gnome-shell driver: i915 
  note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard 
  driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 chip ID: 10ec:8136 
  IF: eno1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Hewlett-Packard driver: ath9k v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 168c:0036 
  IF: wlo1 state: up mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 2-4:4 
  chip ID: 0cf3:3121 
  Local Storage: total: 577.55 GiB used: 55.69 GiB (9.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 2C scheme: GPT 
  ID-2: /dev/sdb vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: R013 scheme: GPT 
  ID-1: / raw size: 32.67 GiB size: 31.91 GiB (97.66%) used: 8.24 GiB (25.8%) 
  fs: ext4 dev: /dev/sdb5 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 1.95 GiB used: 1.2 MiB (0.1%) 
  priority: -2 dev: /dev/sdb4 
  System Temperatures: cpu: 66.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 205 Uptime: 1h 41m Memory: 3.74 GiB used: 1.57 GiB (42.0%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1184 lib: 329 
  flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08 


Welcome to the forum! :slight_smile:

I would advise you to try installing the 5.4 LTS kernel and see if you still have the same problem. :thinking:

1 Like

Have you tried this?


This worked for me. I’d experienced this strange behaviour in the last few days. I searched without success on Google, then tried our forum and… bingo. Thanks!

1 Like

Thanks for sharing this bug fix. It helped reduce my shutdown time from 2 minutes to ~2 seconds.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.