Manjaro Gnome 21.3 kernel 515 Live usb successfully booted, but won't start after "[ok]: started gnome display manager."

Hello there, first of all, so sorry if there’s similar problem posted in this forum already (been trying to find the solution specifically to the problem I have, but none works), googling and surfing thru yt and still didn’t find anything to work as my solution.

I’m trying to install Manjaro GNOME in my old laptop (core 2 duo, nvidia geforce g105m, Legacy bios), this laptop have the installed windows 7 already (I intend to have dual-boot). Created the Live USB using rufus (automatically applying DD) in my windows 7 at the same laptop. Bios doesn’t have secure boot, and on legacy mode.

Booted successfully to the screen to select timezone, keyboard, drivers, etc. Chose free, end up showing the list of the loading like a broken display, pressing alt+f(x) gave nothing, held and press power button only to reboot. Chose non-free, showing the list of loading perfectly, until the loading showed “[ ok ]: started gnome display manager.” and the screen started flickering, after 2-3 minutes the screen went blank with a “_” at the upper left corner (and still flickering). Able to enter tty2 by holding the key alt+f2.

I am a super noob at linux btw. I really want to start familiarize myself with manjaro gnome to be able to use it as my daily os in this laptop. So sorry if I sound too noob. Thanks for those whom are responding.

first check this lis:

Firmware checklist for BIOS systems

  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot/ hibernation (if unable to boot from USB)

and use Ventoy to flash the iso, since you are in legacy, boot ventoy in legacy, you will have a option for that when booting

checked these, there’s no EFI and Raid option in my BIOS. AHCI enabled already. Created new bootable live usb using Ventoy, I must say it is way more fast loading the live media using Ventoy, but the problem still there. The loading stopped and flickering after “[ ok ]: started gnome display manager.” and then the whole screen went blank with “_” in the upper left, still able to use tty2 by holding the alt+f2.

any other approach ?

I would like to post a link to a pic or post the pic in here, but it seems I can’t do that in here. The last line of the loading look like this before the flickering and blank:
[ ok ]: finished permit user session.
[ ok ]: Starting GNOME display manager…
[ ok ]: Starting hold until boot process finishies up…
[ ok ]: Started GNOME display manager.
(and then it just hanging in there, screen start flickering, 2-3 minutes screen went blank)

did you booted ventoy in bios/legacy mode? you didnt select the uefi option
disabled hibernation in windows?
try booting with proprietary drivers
if it doesnt work, try downloading manjaro kde and test with it
if it doesnt work try downloading a non arch iso like linux mint and test with it

I booted using legacy mode, didn’t have the uefi option in my BIOS. Disabled the hibernation in windows already.
Booted with proprietary drivers resulted as I describe above.

As for testing it with manjaro KDE and LM, I will do that later in the night. Gonna update you with it asap. Much thanks for responding, mate.

Hi there, mate. so sorry for my late reply, i’ve managed to try installing using kde version, same problem occurred. Not yet try it with LM.

btw, as I stated above, my gpu is geforce g105m, which is an old GPU. Checked at the nvidia driver website, and the last supported driver for my GPU is in 340xx version (2019). Got back to the manjaro gnome installation, fast forward and access tty2, under su and typed pacman -Qs nvidia and then result showed the driver 340xx is not listed. Is that useful in some way to troubleshoot the issue i’m having ?

so it didnt work with kde?
i dont think its related to nvidia, since you cant even boot with open source drivers…
and yes the latest available drivers in manjaro for nvidia cards are the 390xx
the 340 are available in the aur, but first you need to boot into the live usb …
do you have integrated gpu? or nvidia is the only one gpu? if yes then youll have problems installing manjaro because of the mentioned lack of drivers for that card in manjaro

How much memory does the system have?

nvidia is the only one GPU in my laptop.

can I install it manually from scraps through tty after the gdm failed to start and hangs in the blank screen ?
the point is to make the manjaro up and running first at my laptop, and maybe later i’ll try to find a way to build up my desktop using gnome and manually install the 340xx nvidia driver for my geforce g105m

found someone whom have the same problem as mine (outdated gpu), posted the problem in this forum (2021), that person end up cannot find any solution to it and instead changed the outdated gpu with a newer one.

what system ? my laptop ? 4GB of RAM, and 512M in gpu

and how do you want to install manjaro if you cant boot into the live usb session because manjaro doesnt have the drivers for your gpu?
i think its possible to install manjaro using command line, then you could install the 340xx drivers from aur… but i dont know how to install manjaro using the command line…
try installing arch linux instead of manjaro for example

Yup, guess i can’t. Guess the instant installation is just not that instant for those whom have outdated gpu.

Found a step by step manjaro installation using tty/cli by some good fella posted in this forum while back in the 2020, i’m in the middle of doing it rn. Hoping all gonna goes smooth, at the brighter side, i can really use these steps as my first learning method to getting familiar with linux realm/manjaro.
After the manjaro up and running in my laptop, gonna continue with installing the 340xx driver from aur as you said, and choosing gnome DE.

I’m thinking tho, it might be a good tutorials if someone/gurus created a step by step building manjaro environment available for those whom have an outdated gpu as mine, working smoothly in outdated laptop/pc is one of many reason ppl trying to move to linux, manjaro in this case.

so also check what exact packages you need with the 340xx drivers, probably these:

I simply have to use the pacman command for the driver, right ? All the dependencies for the 340xx driver will be updated automatically ?

after you installed manjaro, install these, that should be enough:

pamac build nvidia-340xx-utils nvidia-340xx lib32-nvidia-340xx-utils nvidia-340xx-settings


The reason I asked is Gnome uses a lot of memory and the specs you cgave pointed to an older system. I just wanted to make sure you had more than 2GB. 4GB will be slightly less than baseline for Gnome. Gnome and KDE use the most system memory. Its going to leave you with a little over 3GB for applications. A modern browser with 3 to 5 tabs open will eat that up. If you have a good sized swap file the system will work, but swapping memory between ram and the hard disk will impact performance, the system will be sluggish.
You can install the lighter-gnome package to not start some memory hogs with the system. They will start if needed, but only then. After testing you may find that the system is to slow for you. You might want to look into removing the Gnome install and installing Manjaro with LXQt, Mate, or Xfce. LXQt being the lightest memory footprint.

Still in the middle of installing the manjaro hahaha gonna try it out what you said after it

Wow, I never thought about it before, all I know is the gnome version is the most ram grabbing system of all other edition. But I guess it will never be too big like win10 right ?

I can revert back (uninstall) the gnome if I want to, right ? And maybe after that, gonna try the Xfce if I find the gnome really laggy.

Yes, its likely less, but likely not by much. The problem isnt just the Gnome desktop itself. Its applications also use a lot of memory. I know from experience that older systems have problems running it since I have very old hardware (FX4300, 560ti, 6gb DDR3), and it doesnt run very well.
Xfce should run ok. While I dont normally link to the spins I create, Manjaro doesnt have a LXQt install iso. You may want to give mine a try if you find you need a desktop and applications that sip memory.

Hi dipax. Thanks for this thread, you know why? Because i have an identical laptop and have EXACTLY THE SAME issues trying to run live manjaro system.

Main (maybe the only?) issue is indeed the graphic card.

Long ago, when manjaro officially supported nvidia driver 340xx and manjaro architect was also free of issues (what can’t be said about nowadays architect :frowning: ), i was able to install perfect manjaro system:

  1. Run architect.
  2. Install kernel 4.14 LTS - the latest kernel that works with 340xx driver, kernels after this one didn’t boot for example.
  3. Install nvidia 340xx driver.
  4. Install plasma desktop.

And this worked like a charm. Pity i had to format my disk :confused:

Now, when support for these old drivers has been dropped, making manjaro (and generally almost every new distro) run on such old laptops with nvidia can be really hard.

Maybe it may work with open source driver, but too new kernel is possibly the reason for fail? I know that it should theoretically work, but it just doesn’t.

I am too nooby to deal with it by myself. I will try, but I know it won’t be easy. If someone more advanced might help… I would be grateful. This laptop may be a monster for 2D emulation and many dosbox games, but now i am “forced” to use windows, which works here out of the box.