Manjaro frezzes on shut down

Hey GUYS
I am facing this errror from about a month ago
[18500,511056] reboot : Power down
i get this error when I shut down my laptop
it gets stuck in there/freezes
and does not turn off

Please help

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. That’s typically an UEFI Firmware / BIOS error, so upgrade that first before doing anything else…

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

The output toinxi --admin --verbosity=7 --filter --no-host --width is:

System:
  Kernel: 5.11.1-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=4a5b9ac1-253f-4ba1-aeed-d74f038c4cda rw quiet apparmor=1 
  security=apparmor resume=UUID=18f5c562-ba6a-4455-8b98-9ed1a8d2f1c5 
  udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Portable System: Dell product: Inspiron 3541 v: N/A serial: <filter> 
  Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: Inspiron 3541 v: A07 serial: <filter> BIOS: Dell v: A07 
  date: 11/27/2015 
Battery:
  ID-1: BAT0 charge: 2.2 Wh condition: 2.2/41.4 Wh (5%) volts: 17.2/14.8 
  model: SMP-SAN2.8 DELL FW1MN41 type: Li-ion serial: <filter> 
  status: Charging 
Memory:
  RAM: total: 3.28 GiB used: 2.13 GiB (65.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64 
  type: MCP arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 
  microcode: 7030105 L2 cache: 2 MiB bogomips: 14379 
  Speed: 1522 MHz min/max: 1000/1800 MHz boost: enabled Core speeds (MHz): 
  1: 1522 2: 1552 3: 1476 4: 998 
  Flags: 3dnowprefetch abm acc_power aes aperfmperf apic arat avx bmi1 bpext 
  clflush cmov cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de 
  decodeassists extapic extd_apicid f16c flushbyasid fpu fxsr fxsr_opt ht 
  hw_pstate ibs lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe 
  msr mtrr nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat 
  pausefilter pclmulqdq pdpe1gb perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 ptsc rdtscp rep_good sep skinit ssbd sse sse2 sse4_1 sse4_2 
  sse4a ssse3 svm svm_lock syscall topoext tsc tsc_scale vme vmmcall wdt xsave 
  xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Dell driver: radeon 
  v: kernel alternate: amdgpu bus ID: 00:01.0 chip ID: 1002:9851 
  class ID: 0300 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 2-1.4:5 chip ID: 0c45:670b class ID: 0e02 
  Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.11.1-1-MANJARO LLVM 11.1.0) 
  v: 4.5 Mesa 20.3.4 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9840 class ID: 0403 
  Device-2: AMD FCH Azalia vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d class ID: 0403 
  Sound Server: ALSA v: k5.11.1-1-MANJARO 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8136 
  class ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
  chip ID: 168c:0036 class ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-3: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb 
  bus ID: 2-1.2:6 chip ID: 0cf3:0036 class ID: e001 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 
  bus ID: 2-1.2:6 chip ID: 0cf3:0036 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
RAID:
  Message: No RAID data was found. 
Drives:
  Local Storage: total: 465.76 GiB used: 117.63 GiB (25.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: MBR 
  Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD+-RW SU-208GB rev: H100 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
Partition:
  ID-1: / raw size: 458.55 GiB size: 450.35 GiB (98.21%) 
  used: 117.63 GiB (26.1%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 4a5b9ac1-253f-4ba1-aeed-d74f038c4cda 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.21 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 18f5c562-ba6a-4455-8b98-9ed1a8d2f1c5 
Unmounted:
  Message: No Unmounted partitions found. 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 0438:7900 class ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-4: 2-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 0438:7900 class ID: 0900 
  Device-1: 2-1.1:3 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0129 class ID: ff00 
  serial: <filter> 
  Device-2: 2-1.2:6 info: Qualcomm Atheros AR9462 Bluetooth type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s chip ID: 0cf3:0036 
  class ID: e001 
  Device-3: 2-1.4:5 info: Microdia Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0c45:670b 
  class ID: 0e02 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
Sensors:
  System Temperatures: cpu: 61.0 C mobo: 45.0 C gpu: radeon temp: 60.0 C 
  Fan Speeds (RPM): cpu: 3954 
Info:
  Processes: 216 Uptime: 6m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: 1383 pacman: 1361 lib: 405 flatpak: 14 snap: 8 
  Shell: Bash v: 5.1.0 running in: xfce4-terminal inxi: 3.3.01 
1 Like
  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
    

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.`

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. Did you or did you not check UEFI / BIOS upgrades already? If not, do that first!

  4. You’re on an experimental kernel. Have you tried upgrading to 5.10 LTS or if the symtoms are the same, 5.4 LTS?

:thinking:

how to upgrade bios
and where to check for bios upgrades

no I have not checked for kernel 5.10
I am not changing my kernel again because last time when I done It
it results to black screen issue for which I have to reinstall the distro

You seem to have a Dell:

So please check the manufacturer’s web site.

When using a rolling release, it’s a good practice to have multiple kernels on your system just in case something goes wrong with one of the kernels. I’m not saying you should delete your current kernel, just saying you should add one and check that one out, while keeping your current one.

Here’s the wiki page that tells you how to manage multiple kernels:

:+1:

1 Like

thanks for the link
yes i have dell laptop
and when I tried to download the driver for manjaro
it only have driver for ubuntu and windows
https://www.dell.com/support/home/en-in/product-support/product/inspiron-15-3541-laptop/drivers
what to choose please guide me

That’s a Dell dynamic website and I can’t tell you what to download because it depends on your country.

If you don’t know how to do that, please contact Dell support and then come back.

Sorry!

:sob:

1 Like