Manjaro freezing everything except mouse

This only happens when I copy anything either using the shortcut or the context menu and everything freezes for a few seconds but I can move the mouse. This happens when I copy absolutely anything no matter the file size or if it’s just text.

1 Like

Hi Bonkbonk, Welcome to the forum :wave:

Please read this post how to provide good information:

Did you by any chance find a solution to this? I am facing the same problem.

Hi there.

I am on Gnome too.

cat /etc/lsb-release  INT ✘  3s 

I have not worked out yet what triggers the freezing event, where I can only control my mouse but I am limited with what I can do with it.
It looks like it happened a few times, since I installed Manjaro a few weeks ago, when I move the mouse over Activities, and there is more than one activity running, the animation kicks in.
At that point the activities remain visible in the middle of the screen, I can hover my mouse over them without any problem, but cannot do anything to select them, neither with the mouse nor with the keyboard.
Interestingly enough, I can close the individual activity, selecting the cross at the top of the box, but, even when I am left with one activity, that activity does not become “workable”, until I logout or reboot the machine, which I can luckily do via buttons.

Does anyone know how else I can get out of this state, when it happens?

P.S. Manjaro is great! I love it. I am running it on a Dell Laptop from 2012, with an Intel i5 inside. I removed Windows10 completely as it was driving me crazy.

what’s the graphics card?
are you using wayland or xorg?
have you tried disabling extensions?
have you tried disabling animations in gnome tweak?

Thqnks Kerry for your answer.

  • Graphics card : Intel Integrated (The Intel i5 is a first generation type, as you can imagine from the age of the laptop - 2012)

  • echo $XDG_SESSION_TYPE  :heavy_check_mark:

My next step was to check how to disable animations (I quite like them, though :wink:)
I will also see if things get better by disabling extensions.

first try logging out & switching to the xorg session, see if that gives you issues.

sudo pacman -S gnome-tweaks

animations is on the first page when opened.

Thanks again, Kerry.
I will monitor the behaviour using xorg session.

It looks like having the animation disabled did the trick for me.

I am not getting freeze events any more.

I did not do any logging. I just did not get any freezing events.

Thanks Kerry for your help.

yeah, i had to leave gnome.
i’m on a rpi400, arm chip, things just got unstable/slow.

currently trying to switch to sway, but it’s a bit of a learning curve, all file editing to config.

As you have experience on running Manjaro on ARM.
I have an Android TV box, [Beelink GT-King-Pro], based on an AMlogic S922X (6 Arm cores).
On its own it is pretty good as an Android TV-Box. The best I have had until now (I have also another one in another TV room).
When I bought it I read somewhere that someone had installed Manjaro on it.

As during lockdown we all did Zoom calls, however I struggled to find Webcams which I could use with an Android TV Box, so I wondered, at that point, whether switching to a dual boot system (I have a dedicated EMMC on board, so I could do that, I think) and adding Manjaro could do the trick, so that I could use a webcam attached to the GTKing while running Manjaro, so I could use my main TV directly connected to the box (what I normally do, instead, is connect my Laptop to the webcam, and Cast that to the TV - not pretty)

Question to you, not sure if you have this use case with your pi400, can you actually connect a webcam to Manjaro on your system (I know it is 4-ARM cores, but it seems pretty powerful for graphics interface, right?) and use it with Zoom or Teams or HTML5 video calls (like jitsi or 8x8)?

How difficult is it to install Manjaro on Arm? :stuck_out_tongue_winking_eye:

nope, no web cam, no mic. i use my phone or tablet for that.

dead simple to install, just write the image & power on.