Manjaro Freezes Sometimes, no response


So I have been having an issue which I can find nothing online about. My computer will sometimes completely freeze (mouse, keyboard, sounds, and display) until I hit the reset button on it. What’s strange is if I turn it on in the morning it works pretty much throughout the day but the moment I restart it, it breaks. Other days it just doesn’t work at all.

I do not believe this is a software issue. On Manjaro the whole computer freezes, and on Windows, it often doesn’t boot, or I get a BSOD with different codes (usually MEMORY_MANAGEMENT or IRQL_NOT_LESS_OR_EQUAL)after 1-5 minutes of getting to the log in page. (sometimes it doesn’t even let me log in)

This is the hardware, along with what I have tested.

CPU- AMD 3800X (new), I don’t think this is the issue because the computer can boot into manjaro fine, and on the days the computer works, the CPU never hiccups.

Memory - 16GB HyperX 2666 MHz , this is definetly not the issue because the memory worked perfectly fine in my old computer, and when I swap sticks with another computer I have (with the same memory), that computer works fine, and mine breaks.

Motherboard - MSI B550 Gaming Plus, naturally, I thought this was to blame if it was not the memory, but I RMA’d the board and got a different one back and the problem STILL persists.

Graphics Card - AMD Radeon 560, I’m not sure if this is the culprit. The computer cannot work without a dedicated GPU, and this is the only one I have. It’s a very old card tho, but it worked fine in my old computer.

SSD - ADATA SU635 240GB, I thought this was the issue but this drive only runs Linux (and GRUB), and the problem exists on windows as well.

Hard Drive - 1TB Seagate Barracuda, I also don’t think this is the issue because this drive only runs Windows.

Cooling - There is adequate cooling (3 fans (2 intake one exhaust)) and the CPU temps are usually all fine (sub 40 when idle, sub 70 when being worked up)

Any help or advice would be greatly appreciated. Thank you.

Maybe some CPU pins broken. Check it.

Try the solution on that post, maybe it will help you.

What power supply unit do you have ?

can you report
from terminal

inxi -Fza 

I have checked, all CPU pins are fine. This morning I was able to use the computer for about an hour before it crashed to a white screen saying “something went wrong and the system can’t recover”.

Just tried that solution, no luck. The computer worked for about ~5 minutes before freezing completely.

I have a Corsair CX550M unit. I do not think it is the power supply because my system can only at max use about 300W, while the power supply provides up to 550W.

Can you report, what stephane said ?

Yes, sorry about delay. Here it is:

           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=PARTUUID=f4fdd752-1bd5-ec42-b2ca-5ee37aa569dd ro 
           quiet splash apparmor=1 security=apparmor udev.log_priority=3 amdgpu.noretry=0 
           Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7C56 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: B550-A PRO (MS-7C56) v: 1.0 serial: <filter> UEFI: American Megatrends LLC. 
           v: 1.50 date: 01/14/2021 
Battery:   Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Info: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 71 (113) stepping: 0 microcode: 8701021 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 124862 
           Speed: 4278 MHz min/max: 2200/3900 MHz boost: enabled Core speeds (MHz): 1: 4278 2: 2038 3: 2016 
           4: 2014 5: 2833 6: 2037 7: 1924 8: 1911 9: 2032 10: 2023 11: 3288 12: 1956 13: 2038 14: 2158 15: 4010 
           16: 2016 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 2b:00.0 chip-ID: 1002:67ff class-ID: 0300 
           Display: x11 server: 1.20.11 compositor: gnome-shell driver: loaded: amdgpu,ati 
           unloaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo> 
           OpenGL: renderer: N/A v: N/A direct render: N/A 
Audio:     Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus-ID: 2b:00.1 chip-ID: 1002:aae0 class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403 
           Device-3: C-Media Blue Snowball type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-10.1:6 
           chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter> 
           Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 
           v: kernel port: f000 bus-ID: 2a:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp42s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 118.09 GiB (10.2%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SU635 size: 223.57 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4c12 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 
           scheme: GPT 
Partition: ID-1: / raw-size: 223.27 GiB size: 218.77 GiB (97.98%) used: 118.07 GiB (54.0%) fs: ext4 dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 25.8 MiB (8.6%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 49.0 C mobo: 0 C gpu: amdgpu temp: 40.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1351 
Info:      Processes: 373 Uptime: N/A wakeups: 2 Memory: 15.62 GiB used: 1.66 GiB (10.6%) Init: systemd v: 247 
           tool: systemctl Compilers: gcc: 10.2.0 clang: N/A Packages: 1346 pacman: 1343 lib: 381 flatpak: 0 
           snap: 3 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.04

The system has pretty much completely failed at this point, not even letting me log in for much more than a minute, sometimes not letting me log in at all. So I am not sure if I will be able to report much more logs.

Can you update the kernel at least to v 5.10 ?
Because kernel 5.9 is EOL.

Have you ran any gpu stressing software for testing ?