Manjaro freezes and overheats

I have been using Manjaro xfce on my laptop for a few months now everything has been fine, but recently I have noticed that the laptop becomes very hot in a very short time and sometimes when using browser while installing a program the system freezes. I tried to monitor the cpu usage in task manager but nothing seemed un unusual. Is that a problemin the OS or the hardware itself?

My laptop is powered by AMD cpu

Hello and welcome,

Something has changed and you should more or less know what is that, or asociate it with something, so it can be investigated.

We need a more detailed one, more of a technical description. To know what that means, see this:

  1. Would be nice if you tell what your fan is doing, normally you should hear it if it behaves differently.
  2. Have you changed anything related to TLP?

I can’t recall a specific thing but I think it’s has to do with one of the updates I had installed

thank you for your help here’s what appeared to me

              Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
              parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
              root=UUID=5bec84ef-50c6-442c-8afd-360b048af538 rw quiet apparmor=1 
              security=apparmor udev.log_priority=3 
              Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
              dm: LightDM 1.30.0 Distro: Manjaro Linux 
              Type: Laptop System: HP product: HP 255 G6 Notebook PC 
              v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
              Mobo: HP model: 8330 v: 27.35 serial: <filter> UEFI [Legacy]: Insyde v: F.51 
              date: 05/31/2019 
              ID-1: BAT1 charge: 11.9 Wh condition: 25.8/31.1 Wh (83%) volts: 11.8/10.9 
              model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
              status: Charging 
              Topology: Dual Core model: AMD E2-9000e RADEON R2 4 COMPUTE CORES 2C+2G 
              bits: 64 type: MCP arch: Excavator family: 15 (21) model-id: 70 (112) 
              stepping: N/A microcode: 6006705 L2 cache: 1024 KiB 
              flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
              bogomips: 5990 
              Speed: 1094 MHz min/max: 1100/1500 MHz boost: enabled Core speeds (MHz): 
              1: 1106 2: 1417 
              Vulnerabilities: Type: itlb_multihit status: Not affected 
              Type: l1tf status: Not affected 
              Type: mds status: Not affected 
              Type: meltdown status: Not affected 
              Type: spec_store_bypass 
              mitigation: Speculative Store Bypass disabled via prctl and seccomp 
              Type: spectre_v1 
              mitigation: usercopy/swapgs barriers and __user pointer sanitization 
              Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
              disabled, RSB filling 
              Type: srbds status: Not affected 
              Type: tsx_async_abort status: Not affected 
              Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard 
              driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
              Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati unloaded: modesetting 
              alternate: fbdev,vesa display ID: :0.0 screens: 1 
              Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
              s-diag: 414mm (16.3") 
              Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
              diag: 395mm (15.5") 
              OpenGL: renderer: AMD STONEY (DRM 3.35.0 5.4.67-1-MANJARO LLVM 10.0.1) 
              v: 4.5 Mesa 20.1.8 direct render: Yes 
              Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
              bus ID: 00:01.1 chip ID: 1002:15b3 
              Device-2: AMD Family 15h Audio vendor: Hewlett-Packard driver: snd_hda_intel 
              v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
              Sound Server: ALSA v: k5.4.67-1-MANJARO 
              Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
              v: kernel port: 3100 bus ID: 02:00.0 chip ID: 8086:24fb 
              IF: wlp2s0 state: up mac: <filter> 
              Local Storage: total: 465.76 GiB used: 86.56 GiB (18.6%) 
              SMART Message: Required tool smartctl not installed. Check --recommends 
              ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
              block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
              rotation: 5400 rpm serial: <filter> rev: YAM1 scheme: MBR 
              ID-1: / raw size: 146.49 GiB size: 143.19 GiB (97.75%) 
              used: 86.56 GiB (60.5%) fs: ext4 dev: /dev/sda2 
              Alert: No Swap data was found. 
              System Temperatures: cpu: 54.0 C mobo: 20.0 C gpu: amdgpu temp: 52 C 
              Fan Speeds (RPM): N/A 
              Processes: 215 Uptime: 22m Memory: 3.73 GiB used: 2.63 GiB (70.4%) 
              Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1244 pacman: 1226 
              lib: 328 flatpak: 8 snap: 10 Shell: Bash v: 5.0.18 
              running in: xfce4-terminal inxi: 3.1.05


I am not sure if I even have any fans! I never heard a sound from it since I bought this laptop. there isn’t even a fan related settings in the bios or anywhere else!

I don’t know what is TLP?

The freezeing could be caused by the combination of having only 4 GiB memory and no swap partition or swap file. Even if you do not intend to hibernate you should use a small swap file or partition, I would say of at least 2 GiB. It’s easy to implement it, just look into the wiki.

I check system temperatures by the simple command


I would check if this provides usable output in your case as well. If you really have no air blower (fan) than I would check temperatures from time to time.

1 Like

I am having the same issue here.
My laptop is an intel i5 which used to run perfectly well some games [i used to use elementary os].
After i installed manjaro, it gets 1) very hot (temperature reaching 100c when running a heavy browser game), 2) very slow, and 3)CPU at high capacity.

I have read so much about all kinds of possible solutions dealing with cooling fans on my laptop (supposedly thats the issue? [specially because heat+i cant hear the cooling fan work]), but absolutely nothing works.
I have tried changing kernels (installing it, on boot screen changing the one Im going to use, etc.), didnt work.
I have tried TLP, POWERTOP, LMSENSORS, PWMCPONFIG, everything.

At PWMCONFIG, i reach a point where it says: “/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed”. I have tried a possible solution (" fancontrol-under-ubuntu-14-04-resolving-usrsbinpwmconfig-there-are-no-pwm-capable-sensor-modules-installed "), didnt work to.

MY elementary os (in the another partition) got slow as well after this issue arrived.
I have tried to fix it in elementary os, but got nothing new too.

Is it due to manjaro not ‘‘geting my cooler to work’’?
COuld it be a coincidental hardware issue? (for instance, laptop fan suddenly not working…?) PS: I cant see if it works, I dont know how to open a laptop and I think this is not a likely scenario.

1 Like

This is a very important finding. Only 4 GB of RAM with zero swap is very tight. Especially when considering your use case:

You should consider to create swap on your system.

1 Like

Thank you, I made a 500MB swap partition hopefully this will solve the freezing problem.

When I checked the temperature as you said it was 53°C but I don’t know what caues it to be that high, it didn’t heat up like that when I was using windows 10. The main reason I choosed xfce is that it’s light weight and won’t consume much of the resources and it did at first. Something surely went wrong but I am not sure what is it.

That’s not enough: with only 4GB ram your swap should be at least 8GB.

OP has a hdd!! If more than 2 GiB swap are in use it will feel like the system is totally frozen… IMHO this won’t be very helpful. :upside_down_face: But I agree, 500 MiB is probably not enough.

Ok, if that’s the case I will resize it to 2GB. Is there’s anything else I should do?

This temperature would be no issue at all, my system (with fan) has a similar temperature.

Thank you for your help, I will Consider this the solution. I think this solved the problem for me.

1 Like

Wollie could you help me regarding my similar issue?

thank you

1 Like

I can try - but please open your own thread.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.