Manjaro Freezes after starting Steam

When I open steam runtime or native my pc freezes completely and does not respond to Ctrl + Alt + F*/Backspace.
I have already tried switching between steam beta and stable, switched kernels from 5.15, updated all nvidia drivers, it sometimes stops happening when uninstalling and installing again the steam package.

System Info:

Kernel: 5.19.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: 1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: Manjaro Linux
  Device-1: NVIDIA GA102 [GeForce RTX 3080] vendor: driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 0a:00.0 chip-ID: 10de:2206 class-ID: 0300
$ pacman -Q | grep nvidia
lib32-nvidia-utils 520.56.06-1
libnvidia-container 1.11.0-1
libnvidia-container-tools 1.11.0-1
linux519-nvidia 520.56.06-3
mhwd-nvidia 520.56.06-2
mhwd-nvidia-390xx 390.154-2
mhwd-nvidia-470xx 470.141.03-3
nvidia-container-runtime 3.11.0-1
nvidia-container-toolkit 1.11.0-1
nvidia-utils 520.56.06-2
opencl-nvidia 520.56.06-2
 mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

The issue seems similar to: #82262 and other similar issues I’ve seen in the forum but every solution I tried has failed. I don’t know what else to do, please help!

You can try the nuke option, it should keep your libraries, but reset all of Steam

steam --reset

I haven’t tried that, i’ll try it and notify if it worked!

This didn’t work either, steam launched and was usable for a while but after that the system crashed, just like it happens when I uninstall and install the package, it becomes usable for a while but still crashes.

Investigating the problem a bit more, it seems to be an issue with game downloads, and when steam starts it tries to download updates and crashes the system. I am using an m.2 nvme drive