Manjaro does not boot after update - emergency shell

this looks like mixing UEFI and NO-UEFI, because in a UEFI-System
the Grub-menu does not show the entry: “Memory-Tester…”. Never.
But the line “Adding boot menu entry for UEFI Firmware Settings …” indicates
that Manjaro is installed as UEFI.
If Windows is installed in UEFI-Mode, you probably try to start from the wrong boot-device?1
====> BIOS ===> boot-entry which ist first bootable device.
Maybe there is a possibility to select boot-device by pressing “F8” or" F12" before Grub-menu?

1 Like

I do understand that, and I confess to having had worse problems with Windows that does updates whether you want them or not. I’m definitely prepared to read up on stuff and that’s why I was looking for solutions here. I’m sorry if I came across as a bit miffed as I had just realized I had not backed up a folder of work that I can’t recreate…

All of today has been consumed setting things up again and I still haven’t got my virtual hosts to work on Apache. (Keep getting 403 error. It appears to be a common problem with many possible causes and it must have been fluke I didn’t have problems the first time I did it).

There are little things I’ve been struggling with like I just realized my system time and date has jumped 12 hours ahead with installing. It appeared to be right this morning, but I suspect that applying the time zone (GMT+12) it didn’t realize that was the time the clock actually was already set to. Now it’s not obvious to me where to correct this, so that’s another thing to google…

For consistency sake I prefer to use the same operating system on both my computers even though the backup-pc would not really need any updates: All it does is put a large hard drive on my LAN and nothing much will change with that ever while I just don’t want to risk wiping it.

And you want to drive a car without without taking a driver’s license
because the car is so pretty and you only want to drive to anywhere…?
Golgafrinchan Ark Fleet Ship B - they invented the wheel, but could not find the right color for wheels…

I’m not claiming to be a top racing car driver, but I do know how to do the work I do.
Isn’t it more like driving a car without being a motor mechanic?

yarabrina seems to run NVIDIA card - this seems to be the main problem actually:

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.
    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:
sudo mhwd -a pci nonfree 0300

If proprietary drivers don’t fix everything, please click the ► at the beginning of this line to view more info

If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our [tutorial on compiling old Nvidia drivers]
([Support/How-To] Compile old/legacy Nvidia Proprietary Drivers [2020-12-30 Update Issue]).[[Testing Update] 2021-01-02 - Linux 5.10, Themes, Deepin, Haskell, Python]
([Testing Update] 2021-01-02 - Linux 5.10, Themes, Deepin, Haskell, Python)

After chrooting from live ISO, try regenerating the initramfs images:

mkinitcpio -P

Alternatively reinstall the kernel package. (That will also trigger mkinitcpio as well as update-grub.)

pacman -S linux510


I completely understand. After I posted an hour back, a lot of split/merge had taken place, and the order of the posts got changed and the context is gone. So, please ignore that post of mine. Sorry!

Let me try the solution @moson suggested, and go through @GaVenga’s wiki post. I’ll update if it works.

It is related but im my P.O.V. the most urgent issue at moment is the ability to boot via Grub: GRUB/Restore the GRUB Bootloader - Manjaro
The nVidia problem can be solved after that by going into another VC.

Take note that especially with dual-boot setups involving M$, you should set your BIOS time to be in UTC, and do some registry stuff so that M$ also uses UTC.
Otherwise you will keep that problem because Linux in general is using UTC as hardware clock setting, which M$ is doing wrong…

1 Like

Seems boot problems and NVIDIA problems are linked to each other, first load the nouveau driver
and then fix the rest? (after chrooting: sudo mhwd -a pci free 0300)

Anything that allows to boot into the system and access the console in text mode will do :wink:

You are right…

Hi! Well I gave a shot combining @GaVenga and @moson’s suggestions, and I am able to boot now. I do not know which one is actually responsible for the success, so thanks to both of you.

For anyone else facing this, these are the commands I ran on sequence:

sudo manjaro-chroot -a
sudo pacman -Syyu
pacman -S linux510

After reboot, I was able to login and everything seemed normal.

I should add that there was a lot of warnings and some errors in the screen. I captured those using script command. I uploaded here: Gofile.

If you can help me understanding whether these are serious or not, that’ll be very helpful. I haven’t tried anything for NVIDIA driver issue from command line yet, but I while chose to auto install driver from Manjaro Settings, it returned success. Let me know if that is not enough or not recommended.


This warnings can be ignored.
everything seemed normal ===> VICTORY!
If you are brave - reinstall any other kernels by “manjaro settings”
This is an option - not a “must”

Reinstalling the kernel did the trick.
For some reason it was not properly installed.

Looking at your logfile it complains about files not being present while the kernel is being uninstalled (and reinstalled later).

warning: could not get file information for boot/linux510-x86_64.kver
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/build/vmlinux
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/extramodules
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/aegis128-aesni.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/aesni-intel.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/blake2s-x86_64.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/blowfish-x86_64.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/camellia-aesni-avx-x86_64.ko.xz

If you want to know the reason why it was not installed properly during your initial upgrade, you might be able to find something in /var/log/pacman.log


That is right, too.
sudo update-grub is sufficient.

please add “exit” for end command chroot

1 Like

@stephane, done. I did that, but thought it was not part of the solution, so skipped while posting.

I’ll try to find what caused the failure, but given my knowledge, probably won’t understand. And, will try to reinstall other kernels (I think only one other LTS version is there) after 2-3 days, to be sure everything is working.

I’m marking my post as the solution, as it had what finally worked. But thanks a lot to all of you. :slight_smile:

1 Like

Update installation was not as usual there were a lot of errors linked with nvidia driver. Thats probably the reason why kernel was not installed correctly first time.

This helps me, i just loaded with 5.4 which was installed too - remove everything linux510 and install kernel again.

1 Like

It does seem to be related to NVIDIA only. In the log file, the first error seems to be this:

[2021-01-01T12:05:04+0530] [ALPM-SCRIPTLET] e[1me[31mError: e[mconfig ‘video-hybrid-intel-nvidia-prime’ does not exist!

Some time after this, there are these lines:

[2021-01-01T12:15:42+0530] [ALPM-SCRIPTLET] depmod: ERROR: could not open directory /lib/modules/5.8.18-1-MANJARO: No such file or directory
[2021-01-01T12:15:42+0530] [ALPM-SCRIPTLET] depmod: FATAL: could not search modules: No such file or directory

Afterwards, there are lots of errors of module not found. But at the end, it says:

Kernel has been updated. Modules of the current kernel have been backed up so you can continue to use your computer. However, the new kernel will only work at next boot.

The logs for my update attempt are uploaded here: Gofile

can you return

sudo mhwd-kernel -li
sudo ls /etc/mkinitcpio.d/*.preset

you can only boot on 5.4 , modules are missing in 5.10 ( includinf failsafe )