Manjaro does not boot after update - emergency shell

You are right…

Hi! Well I gave a shot combining @GaVenga and @moson’s suggestions, and I am able to boot now. I do not know which one is actually responsible for the success, so thanks to both of you.

For anyone else facing this, these are the commands I ran on sequence:

sudo manjaro-chroot -a
sudo pacman -Syyu
pacman -S linux510

After reboot, I was able to login and everything seemed normal.

I should add that there was a lot of warnings and some errors in the screen. I captured those using script command. I uploaded here: Gofile.

If you can help me understanding whether these are serious or not, that’ll be very helpful. I haven’t tried anything for NVIDIA driver issue from command line yet, but I while chose to auto install driver from Manjaro Settings, it returned success. Let me know if that is not enough or not recommended.


This warnings can be ignored.
everything seemed normal ===> VICTORY!
If you are brave - reinstall any other kernels by “manjaro settings”
This is an option - not a “must”

Reinstalling the kernel did the trick.
For some reason it was not properly installed.

Looking at your logfile it complains about files not being present while the kernel is being uninstalled (and reinstalled later).

warning: could not get file information for boot/linux510-x86_64.kver
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/build/vmlinux
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/extramodules
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/aegis128-aesni.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/aesni-intel.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/blake2s-x86_64.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/blowfish-x86_64.ko.xz
warning: could not get file information for usr/lib/modules/5.10.2-2-MANJARO/kernel/arch/x86/crypto/camellia-aesni-avx-x86_64.ko.xz

If you want to know the reason why it was not installed properly during your initial upgrade, you might be able to find something in /var/log/pacman.log


That is right, too.
sudo update-grub is sufficient.

please add “exit” for end command chroot

1 Like

@stephane, done. I did that, but thought it was not part of the solution, so skipped while posting.

I’ll try to find what caused the failure, but given my knowledge, probably won’t understand. And, will try to reinstall other kernels (I think only one other LTS version is there) after 2-3 days, to be sure everything is working.

I’m marking my post as the solution, as it had what finally worked. But thanks a lot to all of you. :slight_smile:

1 Like

Update installation was not as usual there were a lot of errors linked with nvidia driver. Thats probably the reason why kernel was not installed correctly first time.

This helps me, i just loaded with 5.4 which was installed too - remove everything linux510 and install kernel again.

1 Like

It does seem to be related to NVIDIA only. In the log file, the first error seems to be this:

[2021-01-01T12:05:04+0530] [ALPM-SCRIPTLET] e[1me[31mError: e[mconfig ‘video-hybrid-intel-nvidia-prime’ does not exist!

Some time after this, there are these lines:

[2021-01-01T12:15:42+0530] [ALPM-SCRIPTLET] depmod: ERROR: could not open directory /lib/modules/5.8.18-1-MANJARO: No such file or directory
[2021-01-01T12:15:42+0530] [ALPM-SCRIPTLET] depmod: FATAL: could not search modules: No such file or directory

Afterwards, there are lots of errors of module not found. But at the end, it says:

Kernel has been updated. Modules of the current kernel have been backed up so you can continue to use your computer. However, the new kernel will only work at next boot.

The logs for my update attempt are uploaded here: Gofile

can you return

sudo mhwd-kernel -li
sudo ls /etc/mkinitcpio.d/*.preset

you can only boot on 5.4 , modules are missing in 5.10 ( includinf failsafe )

Sure, these are the results:

(standard) ~ >>> sudo mhwd-kernel -li                                          
Currently running: 5.10.2-2-MANJARO (linux510)
The following kernels are installed in your system:
   * linux510
   * linux54
(standard) ~ >>> sudo ls /etc/mkinitcpio.d/*.preset                            
/etc/mkinitcpio.d/linux510.preset  /etc/mkinitcpio.d/linux54.preset

By the way, I just copy-paste from your post. I have no idea what does this mean, and how to boot using a kernel of specified choice:


sudo pacman -Syy
sudo mhwd-kernel -r linux510 
sudo mhwd-kernel -i linux510

it was log from one day before in your link gofile ( error on modules on 5.10 )

If I understand correctly, this reinstalls 5.10 kernel. If you don’t mind, can you please explain why are you suggesting so? I just recovered my laptop, so don’t want to take risk. I hope you understand.

But while I ran the solution, hasn’t it done the same thing?

And seeing the post below by @moson, I’m more confused now, as the output does say so.

? @yarnabrina is running on 5.10 already, no? :man_shrugging:

Hello. I seem to have the same problem - get the same message at boot. But the computer didn’t see usb drives. I’ve tried changing BIOS settings, using other USB slots, nothing seemed to help. So I removed the SSD, and then the USB was detected and the live system started. I followed the steps described here and the kernel was updated, the updates checked (nothing needed to be changed), but when I executed sudo update-grub, I got some errors:
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
(I can’t include the screenshot)
After rebooting, I no longer get the message, but I’m greeted with a blank screen - the system won’t load.

A post was split to a new topic: Display has issues

Hey i faced same problem. My system is dell inspiron 15 with Nvidia gtx 1050 graphic card and i have dual booted with windows 10. After latest update my system broke suddenly.
Tried the steps mentioned in the solution posted by OP but when booting live usb I selected non free drivers, so I got some error when following the solution steps pls see the screenshot. I clicked on yes on all options and decided to proceed. Can someone help me understand the reason for this I’m new to Linux and would want to know how it’s working.


As of writing this the system is installing lots of packages, will let you updated if I’m able to boot in after continuing with the solution steps.

EDIT: I was not able to fix the problem, so i decided to boot into live usb again this time with free drivers set instead of non free and I also realized that during my last attempt, I had opened up a new terminal after executing sudo manjaro-chroot -a, thus I think this might be the reason for the solution not working. this time I remained in same terminal and continued with sudo pacman -Syyu and other command. Now I booted into my OS, but I did not recall getting grub menu option to select windows or manjaro and also nvidia drivers are not installed atm, so should I auto install properiatery drivers from system settings?

So my problems are:

  1. Not able to see the grub menu so that I can select windows or manjaro
  2. nvidia module are not installed? please refer the attachment. I use optimus manager and mostly select it to use my GPU, and it had been using my GPU (hybrid mode I guess) before the update but now after the update it is in Intel mode only, when I try to switch, I get this warning.


I had the exact same isssue, but I had some older kernels installed. I was able to resolve the issue by booting an older kernel in the boot menu, which worked in my case. I didn’t need to to any chrooting and running:

pacman -Syyu
pacman -S linux510

Did the trick. I guess it was a good thing I had those kernels still lying around…

Always use MHWD to install / uninstall kernels:

sudo mhwd-kernel -i linux510

Or use the GUI from Manjaro Settings Manager > Kernels

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.