Manjaro does not boot after update - emergency shell


I had Manjaro 20.2 on my Dell Inspiron. Today morning, I logged in and received a big update ( >1 GB). I started the update accepting the default selections, and while installing there was only one warning prompt regarding NVIDIA driver, which I ignored. I did not check the logs in package manager, so cannot say whether there were other problems.

After it completed, I was told to reboot to finish the update. I did that, and received a terminal screen:

I searched for a bit online, and in all related threads people seem to be able to run commands. I failed, but also, I haven’t seen the 2nd error in the threads I’ve come across. After using it for 2-3 months, not sure why it is suddenly giving file system errors.

So, my questions are this:

  1. What is the problem, and how can I avoid this in future?
  2. How can I fix this issue for now? (I really don’t want to format and reinstall)
  3. Is all my data gone? If not, how can I recover those?

I’m pretty new to Linux, so I’ll much appreciate if you answer in a easy to understand way.

Thank you!

1 Like

Boot a live ISO and run in a terminal window

sudo manjaro-chroot -a

Result will be someting like:
Choose your System by Number indicated.

==> Select system to mount [0-0] :

(If Result = 0 then You have to enter 1 at this point.)
Then run: sudo pacman -Syyu.
(as a precaution: sudo update-grub)
and reboot…
(And install a second kernel, most times one of them works)

Thanks for replying :slight_smile:

Unfortunately, I’m a beginner in Linux, so I don’t understand your answer. I’m going to prepare and try the live ISO nevertheless (not sure whether it’ll lead to data loss or not), but I’ll highly appreciate if you please explain what is the actual problem, and how do you solve it.

Mod-edit: Formatting fix for commands. :wink:

Simple for beginners:
your last update has not finished completely.
Start from the live ISO. Select your language and your keyboard-config. Free Drivers is o.K.
Wait until Desktop has finished loading.
Now open a Terminal, thats in icons a black rectangle…
Then enter the command:
sudo manjaro-chroot -a
Asks for Password, that is: manjaro
This means, the software on your ISO knows, that you want to change to your main-System,
which is corrupt at this time being…
In this terminal enter:
sudo pacman -Syyu
That means: continue the broken update of your main-System
sudo update-grub
That means: repair the bootloader (if necessary) of your hopefully EX-broken System.
The reboot is required to finish all actions done.


Mod-edit: Formatting fix for commands. :wink:

NVIDIA is a big problem - i am lucky to run an AMD-Grafikkarte.
If the problem persists: please ask philm by personal message,
he is the best expert you can get…
or try to ask TriMoon
From the ISO after the command:
sudo pacman -Syyu
you can try the following commands, you better copy and past it to a second USB-stick into a file:

  1. sudo mhwd -r pci $(mhwd -li | grep ‘video-’ | awk ‘{print $1}’)
  2. sudo mhwd -a pci free 0300

This is some magic, but is intended to repair broken graphics drivers.
And if command not found “mhwd” try sudo pacman -S mhwd-nvidia
and use the command mhwd-nvidia instead of mhwd.

1 Like

Don’t worry we will be careful not to make that happen :wink:
Try what @GaVenga suggested above, then we will know if it need more/other steps.


Hi guys, thanks for taking time (especially on New Years Day) on explaining. Much appreciated!

Unfortunately, it did not solve the problem. It tried as @GaVenga suggested, once with the extra steps for NVIDIA (which, if I understand correctly, uninstalls and reinstalls a package named video-linux), and once without. But I am still getting the same error.

The only difference after this, compared to what I had before, is the grub menu. Earlier, whenever I turned my laptop on, I’ll be prompted to choose whether I want to log in to Windows or Manjaro. After this (I’m guessing the last command), it tries to log into Manjaro directly and fails. I’m not too bothered for this change right now, as I can get into Windows from boot settings, but may be this is relevant, I don’t know.

Let me know what other information I can provide, and how can I get those, and I’ll share.

Some detailed explanation of what exactly you mean by that would make things a lot easier, because we can not see through your eyes and don’t have access to your machine :wink:

I’ll try to continue tomorrow again because it’s late where i am.

17 posts were split to a new topic: Boot issues after update

2 posts were merged into an existing topic: Boot issues after update

A post was merged into an existing topic: Boot issues after update

Please wait, until Tri Moon rises! He really knows what to to…

Hi @GaVenga, in case I didn’t make it clear, the screenshot with Memory Tester is just to demonstrate to @TriMoon what screen I used to see for login. That picture is from a guide to set up dual boot, it’s not from my system.

Both my OS, Manjaro and Windows are UEFI. I know this for a fact as I had to reinstall windows in October before installing Manjaro.

Without at least knowing what you do you should not defuse a bomb - or driving a car which is a weapon too.


btrfs as root-system needs a special bootloader afaik - some years ago I struggled with open SUSE
and the final solution was not so easy.
Expert required…

Thanks but you are actually not demonstrating it for me personally, it is helping others to help you better :wink:

Sure, no problem. Context is I have a dual boot system. It had Windows originally, and I added Manjaro in October.

What used to happen

If I turn on my laptop, I’d see a screen with 4 options. Two options to choose either of the OS, one for Manjaro custom settings and one for UEFI options. I belive this is called the Manjaro bootloader screen (based on this page), but I may be wrong. It looked something like this (from the previous link), but I used to UEFI as the last option instead of Memory Tester:

Then if I select any of the two OS using cursor keys and press enter, I’d have reached the page to provide user credentials and that’s it.

While problem started yesterday morning, I was still reaching the above page. If I had selected Windows, no problem and everything was working as it should.

If I had selected Manjaro, then it was showing me the error that I shared in the main question.

What is happening

I applied what @GaVenga suggested in the evening. While I ran sudo update-grub, I received this:

I interpreted this as they removed the old entry for existing installation and inserted a new entry on top. I may have understood completely wrong, so sorry about that. Anyway, if I turn my laptop on after that, it is immediately going to the following page:

Let me know if this info is what you wanted.

So, I am not getting a chance to log in to Windows easily. While turning on the laptop, I have to press F12 to go to boot settings and from that Windows option is coming. This is just an inconvenience, which I am happy to ignore for now.

I totally agree we need something that will prevent this ever happening again.
The reality is that unlike the experts we just want to use our computers to do our work.
While it’s working to our satisfaction we don’t want to fix it.

On rare occasion that we do want to update something then we can make sure our backups are up to date first before giving it explicit command.

Thus at the moment I’m looking for a way to kill the automatic update checking and all the nagging about new packages. My backup system I disconnected the moment it too came up with umpteen package updates and haven’t dared connect it to my router again. I can’t afford to lose that too.

So my question is how do I kill the updates and make them on explicit request only?

There are no automatic updates. You are in charge. You are only being notified that there are updates available. If you want to be on the safer side, don‘t update immediately but read the announcement for that update here on the forum. It will give you an idea of how the situation is.

There is no use in not updating to avoid trouble. Updates are there for a reason. Apart from bringing new features there are security updates.

By choosing Manjaro as your Linux distribution you also choose to be close to the constantly rolling (means updating) Arch Linux, which is where the majority of packages come from. That‘s why you get „nagged“ with updates regularly. Not performing updates for an extended period of time will likely get you into more trouble as Manjaro is not meant to be run like this.

Most of the problems can be solved in some way and the probability to run into such problems varies greatly with your specific hardware combination.

In general running a linux system sometimes requires a little bit of reading, learning, trying and such. If you are not willing to do that from time to time it is probably not the best choice for you.

Also please keep in mind that there is a small team behind the scenes and not a huge company with unlimited resources…