Manjaro boots and I get a black screen - EOL kernel version

Its been a while since this has happened. I did a system update using pacman (It had been about 15 days since my last system update) the update failed somehow. Then I did the system upgrade using the manjaro “Add/Remove Software” which in the end asked me to restart my device, so I did. After that, when I opened my device all it showed is that some services have started then it shows a black screen.
[Ok] blah blah service
then in the end it just shows me a black screen. I cannot even enter the tty mode. It’s as if i booted into a void with nothing. I went through several posts in this forum but none of them worked. I am booted from a live usb rn. I checked what was wrong with my zero to none linux skills. one thing weird i noticed was with g-parted:

the /dev/nvme01p1 shows that something is wrong with it, when i click on that partition i see the following:

Thats all i could find. Please help

from USB live manjaro ,open a terminal and add

sudo pacman -S dosfstools  mtools 

relaunch gparted after

can you report ( open also a browser )

inxi -Fza 

if you want to check logs on your disk

sudo manjaro-chroot -a 
journalctl -b0 -p4
exit ( end-chroot , always quit by exit )

Hi @Lemonade,

From within the Live ISO, open a terminal and enter a chroot environment:

manjaro-chroot -a

Be careful now, as you are now working on your system as root, so any changes can and will have a lasting impact.

From the chroot environment, give us some more information.

Also, please provide the output for

sudo lsblk


sudo fdisk -l

When I enter chroot environment it shows me the following:

[manjaro@manjaro ~]$ manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
==> Mounting (ManjaroLinux) [/dev/nvme0n1p2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]#  

When I do sudo lsblk I get this:

[manjaro /]# sudo lsblk
loop0         7:0    0 130.5M  1 loop 
loop1         7:1    0 581.8M  1 loop 
loop2         7:2    0   1.5G  1 loop 
loop3         7:3    0 695.2M  1 loop 
sda           8:0    1   7.5G  0 disk 
|-sda1        8:1    1   2.9G  0 part 
`-sda2        8:2    1     4M  0 part 
nvme0n1     259:0    0 476.9G  0 disk 
|-nvme0n1p1 259:1    0   300M  0 part /boot/efi
`-nvme0n1p2 259:2    0 476.6G  0 part /
[manjaro /]# 

When i do sudo fdisk -l I get this:

[manjaro /]# sudo fdisk -l 
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SKHynix_HFM512GDHTNI-87A0B              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: FC9406CF-76E4-264A-BD0E-77E0958CD7BC

Device          Start        End   Sectors   Size Type
/dev/nvme0n1p1   4096     618495    614400   300M EFI System
/dev/nvme0n1p2 618496 1000214527 999596032 476.6G Linux filesystem

Disk /dev/loop0: 130.47 MiB, 136810496 bytes, 267208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 581.83 MiB, 610095104 bytes, 1191592 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 1.47 GiB, 1581879296 bytes, 3089608 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 695.22 MiB, 728993792 bytes, 1423816 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 7.5 GiB, 8053063680 bytes, 15728640 sectors
Disk model: Flash Disk      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sda1  *         64 6124243 6124180  2.9G  0 Empty
/dev/sda2       6124244 6132435    8192    4M ef EFI (FAT-12/16/32)
[manjaro /]# 

I take it you’ve got something like a 512GB nVME SSD?


Do i have to do the installation while chrooted?

Yes that is what I have.

For inxi -Fza I get the following output:

System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro 
           misolabel=MANJARO_XFCE_2114 quiet systemd.show_status=1 apparmor=1 security=apparmor driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 82EY v: IdeaPad Gaming 3 15ARH05 serial: <filter> Chassis: type: 10 
           v: IdeaPad Gaming 3 15ARH05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter> UEFI: LENOVO v: FCCN16WW date: 01/05/2021 
Battery:   ID-1: BAT0 charge: 19.4 Wh (50.1%) condition: 38.7/45.0 Wh (86.0%) volts: 10.9 min: 11.4 model: SMP L19M3PF7 
           type: Li-poly serial: <filter> status: Discharging cycles: 454 
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600104 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71899 
           Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1386 3: 1998 4: 1776 5: 1621 
           6: 1904 7: 1384 8: 1394 9: 1389 10: 1384 11: 1392 12: 1388 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 05:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Device-3: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3 chip-ID: 174f:244c class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.19-2-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A 
           alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.37 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8822ce v: N/A 
           modules: rtw88_8822ce port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:c822 class-ID: 0280 
           IF: wlp4s0 state: up mac: <filter> 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-3:2 chip-ID: 0bda:c123 class-ID: e001 
           serial: <filter> 
           Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 484.44 GiB used: 65.58 GiB (13.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GDHTNI-87A0B size: 476.94 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 11010C00 temp: 38.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Generic model: Flash Disk size: 7.5 GiB block-size: physical: 512 B 
           logical: 512 B type: SSD serial: <filter> rev: 8.07 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 39.4 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 38.0 C device: nouveau temp: N/A 
Info:      Processes: 323 Uptime: 1h 3m wakeups: 1 Memory: 7.14 GiB used: 4.25 GiB (59.4%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: N/A Packages: pacman: 1124 lib: 306 flatpak: 0 Shell: Bash v: 5.1.8 
           running-in: xfce4-terminal inxi: 3.3.06 

Scratch this

OK, let’s check it for errors. In the chroot environment, please run:

sudo fsck /dev/nvme0n1

If asked for a password, then the password is your password. But I highly doubt this’ll happen.

This kernel has been EOL (End Of Life) for quite some time, and might even be the cause of you problems. We should fix that first.

In the chroot environment, check which kernels are installed:

mhwd-kernel --listinstalled

Report back with the output.

[manjaro@manjaro ~]$ sudo fsck /dev/nvme0n1
fsck from util-linux 2.37.2
e2fsck 1.46.4 (18-Aug-2021)
/dev/nvme0n1 is in use.
e2fsck: Cannot continue, aborting.

also @stephane
Doing the installation helped, gparted doesn’t show that error anymore. I remember doing the installation while chrooted once, it threw me some errors back then. Now when I did it directly from the live usb terminal it worked.

See my edit above :point_up:

[manjaro /]# mhwd-kernel --listinstalled
Currently running: 5.13.19-2-MANJARO (linux513)
The following kernels are installed in your system:
   * linux414
   * linux510
   * linux513
   * linux514
   * linux54
[manjaro /]# 

That’s the output I got

under chroot remove
and add 5.15

sudo manjaro-chroot -a
mhwd-kernel -r linux414
mhwd-kernel -r linux513
mhwd-kernel -r linux514
mhwd-kernel -i linux515
mkinitcpio -P

Any particular reason you’ve got so many kernels installed?

Remove most of 'em:

mhwd-kernel --remove linux414
mhwd-kernel --remove linux513
mhwd-kernel --remove linux514

Followed by syncing, exiting, and rebooting.


I was trying different kernels back then when I had a backlight problem to see if changing to an older kernel fixes it (some forum posts had mentioned it), probably forgot about them afterwards.

Looks that way. Let this be a lesson then.

be careful to not go in lower version ,
you architecture cpu is not supported
it should work with 510 & 515 versions

while trying to remove linux513 i get “You cannot remove your current kernel” which seems reasonable. and while installing, the linux515, you see I haven’t had system updates since these things started, most of my packages are outdated. can I do something to update all these packages while on a live usb?

The following packages are out of date, please update your system first: alacarte alsa-card-profiles alsa-oss alsa-ucm-conf android-tools apparmor argon2 attica audit avahi blender blosc blueman boost-libs botan breeze-icons brotli btrfs-progs ca-certificates-mozilla catfish ceph-libs chromaprint clang cmake compiler-rt cpupower cryptsetup dbus-python dhclient double-conversion elfutils enchant expat extra-cmake-modules firefox firefox-i18n-en-us fontconfig fzf gcc gcc-libs gegl gimp glib2 glib2-docs gnome-themes-extra gobject-introspection-runtime gpgme graphviz grub grub-btrfs gst-plugins-bad gst-plugins-bad-libs gtk3 gtkhash gtkhash-thunar gufw hwinfo hwloc iana-etc ibus imagemagick imath iniparser iproute2 iputils jdk8-openjdk jemalloc jre8-openjdk jre8-openjdk-headless jsoncpp karchive kauth kbookmarks kcmutils kcodecs kcompletion kconfig kconfigwidgets kcoreaddons kcrash kdbusaddons kdeclarative kded kfilemetadata kglobalaccel kguiaddons ki18n kiconthemes kio kirigami2 kitemmodels kitemviews kjobwidgets knewstuff knotifications knotifyconfig kpackage kservice ktextwidgets kwallet kwidgetsaddons kwindowsystem kxmlgui ldb ldns lensfun lib32-expat lib32-gcc-libs lib32-libelf lib32-libglvnd lib32-libva-mesa-driver lib32-libx11 lib32-libxcrypt lib32-mesa lib32-mesa-vdpau lib32-nspr lib32-nss lib32-openssl lib32-sqlite lib32-vulkan-intel lib32-vulkan-radeon lib32-wayland libaccounts-glib libarchive libblockdev libbytesize libcap libcap-ng libelf libftdi libgexiv2 libglvnd libgsf libibus libieee1284 libimobiledevice libinput libixion liblouis libluv libmfx libmicrohttpd libnewt libnm libopenmpt liborcus libplacebo libplist libproxy libraqm libreoffice-fresh librsvg libseccomp libsynctex libteam libthai libtorrent-rasterbar libunwind libva-mesa-driver libxcrypt libxml2 lightdm-gtk-greeter-settings lilv linux414 linux414-nvidia linux414-virtualbox-host-modules linux510 linux510-nvidia linux510-virtualbox-host-modules linux54 linux54-nvidia lirc llvm llvm-libs manjaro-application-utility manjaro-hello manjaro-release mbedtls menulibre mesa mesa-vdpau meson mhwd-nvidia-390xx mhwd-nvidia-470xx minizip mlt mpg123 mpv mugshot mujs nano ncmpcpp ndctl net-snmp netpbm networkmanager node-gyp nodejs npm nspr nss obs-studio opencolorio openimageio openshadinglanguage openssl openvdb openvpn openxr pacman-mirrors pambase pango perl perl-alien-build perl-http-message perl-libwww perl-lwp-mediatypes php pipewire polkit polybar popt protobuf protobuf-c ptex purpose pybind11 python python-anytree python-appdirs python-attrs python-cairo python-certifi python-chardet python-distro python-distutils-extra python-dnspython python-docopt python-gobject python-idna python-importlib-metadata python-keyutils python-lxml python-markdown python-more-itertools python-npyscreen python-numpy python-ordered-set python-packaging python-pexpect python-pillow python-psutil python-ptyprocess python-pygments python-pyparsing python-pyqt5 python-pyqt5-sip python-pysmbc python-pyxdg python-reportlab python-requests python-setuptools python-six python-urllib3 python-xlib python-yaml python-zipp qbittorrent qpdf qt5-base qt5-translations qt5-wayland qt5-webchannel ranger redshift s-nail samba sdl sdl2 shaderc smbclient snapd sof-firmware solid sonnet syndication systemd systemd-libs systemd-sysvcompat talloc tbb tcl tdb tevent udiskie ueberzug ufw util-linux util-linux-libs vala vim vim-runtime virtualbox virtualbox-guest-utils vlc volume_key vulkan-intel vulkan-radeon wayland webkit2gtk webkit2gtk-4.1 xapp xcb-proto xdg-desktop-portal xdg-desktop-portal-gtk xfce4-whiskermenu-plugin xorg-server xorg-server-common xorg-server-devel yajl yay youtube-dl zbar zlib zstd 
Do you want to continue anyway? [y/N] n

The reason it’s giving that error is because you don’t seem to be running the command(s) from within the chroot environment, like it should be.

wrong, I have been chrooted this whole time trying to remove and install the kernels. Right now I am doing a system upgrade while chrooted