Manjaro arm on Amlogic Tv box?

blender-2.7 is working well even when you set the renderer to Cycles.

Blender 2.8+ demands OpenGl 3.3 which is currently not supported by Panfrost. Some days ago I tried to overwrite GL_VERSION to 3.3 and start Blender 2.9 that way but it only showed a grey empty window.

I also think to remember that Mali G31 only supports OpenGl ES up to version 3.2. So the rest of the implementation would have to be software anyway. Don’t know what priority Blender 2.9 has on the Panfrost dev teams’ list. I guess they will focus their efforts on new Mali chips first to get them up and running before implementing features beyond OpenGl ES 3.1 (need to look up - I thought mesa 21 devel has support for 3.1 now and not 3.2).

Would be great to have a hybrid OpenGL driver that uses Panfrost as much as possible and falls back to LLVM for features not supported by Panfrost, yet.

Yes I also tried blender 2.7, I think it is ready for production using x96 Max+. Even on LLVM Pipe the performance is very smooth.

I also tried to install Blender 2.7 on Armbian Focal, but failed. Don’t know how to compile Blender 2.7 on Focal, whereas on AUR it’s quite easy on Manjaro side.

On Armbian Bionic it is easy to install Blender 2.7.

This can be a solution if it is possible in the future, I think LLVM Pipe is quite mature in terms of features compared to panfrost

Did you notice this thread about the problems to compile Blender 2.7 (even when using Manjaro) and possible solutions?

Edit: I meant blender-2.7-es which I am using. See posts at the end of the thread I linked to.

I just noticed this post just now. But in my case, Blender 2.7-es was broken I think since around 3-4 months ago, but the last update fix this issue on AUR (around 2-3 weeks ago).

I think I have an idea to compile Blender 2.7 easily on Ambian Focal / Manjaro by using chroot debian buster. The same way as the box86 procedure. Will let you know the update

Yes I can confirm using chroot method can easily run Blender 2.79b on Armbian Focal / Manjaro

  • sudo schroot -c debian-armhf
  • apt install blender
  • exit

to run blender, simply use this command:

  • schroot -c debian-armhf blender

Now Blender 2.79b should run perfectly on Armbian Focal / Manjaro

Many Thanks to you, finally I solve this issue because of our discussion on Box86.
I added the Bonus in the tutorial to install Blender 2.79b using schroot debian buster

Is there a server-only version without a desktop that I can download to install on my Tanis TX3 TV box?

Where do I download it from?

Yes I can confirm, using manjaro unstable Kernel 5.10+ and mesa-git, Panfrost is very stable on Mali G31.

With compositor active, I got
glmark2 score : 53
glmark2-es2 score : 83

After switching off compositor, I got
glmark2 score : 54
glmark2-es2 score : 188

Have you tried using Armbian Kernel 5.10+? do you know how to upgrade to this kernel using our box image?

Are you all also having lots of visual glitches the latest Version 87.0.4280.141 with the latest mesa-git? The visual glitches when using Firefox 84 is a lot less intrusive.

Manjaro-ARM-VIM3-XFCE-linux-vim-5.10-5-1 with mesa-git.

No, I have completely switched to Manjaro ARM after balbes150 announced that there would be no more support for amlogic devices. Also: I did not feel welcome anymore over at the Armbian forum as owner of a box with S905X3. This is completely different here at the Manjaro forum. :grinning:

Edit: Technically, linux-vim kernel is based on balbes150’s kernel source if I am not mistaking.

Edit:: It seems that currently there is no compiled version of panda3d available for arm64 and that is the reason that my attempt to install it failed.

I just tried to install ursina game engine but it fails because it cannot install panda3d. Then I tryed to install panda3d by-hand but it also fails:

pip install panda3d==1.10.8
Defaulting to user installation because normal site-packages is not writeable
ERROR: Could not find a version that satisfies the requirement panda3d==1.10.8
ERROR: No matching distribution found for panda3d==1.10.8

Same error when using pip install panda3d.

Read somewhere that this might be related to wheel so I also installed wheel by-hand:

pip install wheel
Defaulting to user installation because normal site-packages is not writeable
Collecting wheel
  Using cached wheel-0.36.2-py2.py3-none-any.whl (35 kB)
Installing collected packages: wheel
Successfully installed wheel-0.36.2

And then I added .local/bin to my PATH. But I still cannot install panda3d and ursina.

Help is needed here.

Which preference did you choose to build this image? Khadas Vim 3? I used Khadas Vim 3 image from manjaro download, then use your dtb, then upgrade to Unstable brach, but the sound is not appearing. When I used the old method to turn on sound from HDMI from Alsamixer, then press M and button Up, when I restarted, it always comeback as Muted. And I have to re-enabled that every restart.

When you say the sound is working. Is it the sound from the audio jack or the HDMI or both?

I have used this command: sudo buildarmimg -d vim3 -e xfce -b unstable

HDMI. I never tested the audio jack.

Start using the system LED.

On many Linux distros/releases for TVboxes the indicator LED is not used (i.e. it is set to some constant value). To remedy this I have written a program, tvbox-led, that can indicate system status/activity with blinks of the LED; indicate which network interfaces are up and network load (by varying blink lengths and frequency). It can also be set to merely produce a smooth cozy pulsating light. It was developed, tried and tested on Ugoos AM6 plus but it can be adapted to other boxes (e.g. s922x , s905x3) as well. (It is a matter of identifying GPIO pins, see the docs.)

Currently, only source is provided. (It is easy to cross compile e.g. on Ubuntu x86, see the docs.)

#Ugoos #LED #tvbox-led


I have just upgraded vim-kernel to version 5.10.8-1-MANJARO-ARM.

Boots without problems. As expected the upgrade broke my internal wifi but reinstalling the rtl8822cs driver was easy:

  • cd RTL8822CS
  • make clean
  • make
  • sudo make install
  • reboot

and wifi is working again.

I did the same and it works

I was thinking of using a external usb3 ssd as a root partition and use boot from a sd card (I don’t know if this is possible)
The trouble with this ssd driver is that it is needed to apply quirks, quirks=152d:0562:u so the driver can work.
I know that in raspberry pi 4 this is possible by adding usb-storage.quirks=152d:0562:u to /boot/cmdline.txt.
I tried a similar approach by adding extraargs=usb-storage.quirks=152d:0562:u to extlinux.conf, but this doesn’t work. Does anyone know a possible solution?

Yes that’s correct, i respect his work and I still use and pkg his kernel.
Will not be this option in near future as he won’t be updating support for amlogic devices.

We can use our mainline pkg and all the things still work on it.

Currently no. I don’t think anyone from the team or community have the device so it’s not tested at all.
Minimal images are available for vim3 and you can use that image and edit the dtb name in extlinux.conf.

Most arm devices don’t really have audio jack support in dts so I don’t think it is possible.

This is why dkms is the recommended solution :slight_smile:
It recompiled on every kernel update.

It is possible but idk how fast that will be over usb.

No need for this, just make sure the root=LABEL={Ssd-rootfs-name} matches the ssd root partition label and it should work.
Oh wait there is a bug in uboot that stops booting is usb drive it’s detected. Will have to fix it first. Ill check with Neil tomorrow.
Good luck.

1 Like

Has anyone tried to run manjaro directly from the emmc, that is, to install it initially on a sd card or USB memory and then transfer it to the emmc and make it run well without using a sd card?

I tried it about 2 or 3 months ago with the process that I explained (sudo /boot/ but I failed and killed my tv box … is this possible today? Has anyone tried it successfully? I want to make time for it this weekend to see if it’s possible. The idea is to set up a server to run home assistant in manjaro but from emmc memory. I appreciate your advice.

I still used the images that balbes150 released from armbian … with these I installed 3 ubuntu servers on 3 tv boxes to run home assistant for my father, my sister and another for my house … but since balbes150 I stopped supporting it. looking for an alternative and so I get to manjaro … As I said in another post I am going to spend time trying to have a server with manjaro running Home assistant … one last question is it possible to run these programs in manjaro:

Thanks for the reminder, u have to update the install script to work with the new boot scripts.

I will try to get it to work today or tomorrow evening.

If it runs on dockers then it will work fine on manjaro. Just make use it have aarch64 version.

You are right - therefore I have successfully built a working dkms package this morning (based on dkms-rtl8723cs package). :grinning:

Should I send you the source files by email (to your known email-address) so that you can add the package to the repository?

1 Like