Manjaro arm on Amlogic Tv box?

Thank you very much for your efforts.
Can confirm that it worked. :smiley:

Had problems with Ethernet as well, had to manually change speed to 100 Mb/s to make it work.

Modified the DTB file. Ethernet now works at 100Mb /s speed.

Under mdio @ 0 {
Changed max-speed = <0x3e8>;
to max-speed = <0x64>;

New DTB: meson-sm1-x96maxplus-vim100m.dtb

So glad to hear that it is reproducible :grinning:

Oh yes, I read about it long time ago on the Armbian forum. I never had problems with the higher speed settings but I guess that is due to my slow ethernet connection (only 15 Mbit/s max.)

Thanks for doing the job! Please fix the error in the rtl8822cs-dkms package next :wink:

Thanks @TheMojoMan for this valuable tutorial.

What about bluetooth, can we activate the bluetooth using the same method for X96Max+?

There is someone who did a backport for rtl8723de using dkms. See here: Ubuntu – How to activate bluetooth device for RTL8723DE – iTecTec

So I think that in principle it should also be possible for rtl8822cs.

But I saw that there is code for rtl8822c in btrtl.c in kernel version 5.10.10 so it seems we only have to wait a bit more and bluetooth support will come to our box as well!

Screenshot from 2021-01-26 15-51-06

You can already find rtl8822cs_fw.bin and rtl8822cs_config.bin in /lib/firmware/rtl_bt when you install linux-firmware package. However kernel 5.10.5 does not seem to support rtl8822cs, yet:

[themojoman@X96MaxPlus ~]$ modinfo btrtl
filename:       /lib/modules/5.10.5-1-MANJARO-ARM/kernel/drivers/bluetooth/btrtl.ko.gz
firmware:       rtl_bt/rtl8822b_config.bin
firmware:       rtl_bt/rtl8822b_fw.bin
firmware:       rtl_bt/rtl8821a_config.bin
firmware:       rtl_bt/rtl8821a_fw.bin
firmware:       rtl_bt/rtl8761a_config.bin
firmware:       rtl_bt/rtl8761a_fw.bin
firmware:       rtl_bt/rtl8723ds_config.bin
firmware:       rtl_bt/rtl8723ds_fw.bin
firmware:       rtl_bt/rtl8723bs_config.bin
firmware:       rtl_bt/rtl8723bs_fw.bin
firmware:       rtl_bt/rtl8723b_config.bin
firmware:       rtl_bt/rtl8723b_fw.bin
firmware:       rtl_bt/rtl8723a_fw.bin
license:        GPL
version:        0.1
description:    Bluetooth support for Realtek devices ver 0.1
author:         Daniel Drake <>
srcversion:     02896D42941196C4ADC8841
depends:        bluetooth
intree:         Y
name:           btrtl
vermagic:       5.10.5-1-MANJARO-ARM SMP preempt mod_unload aarch64

This is a great news. Thanks for the info :slight_smile:

Now what is left is the panfrost stability. Once it is stable, x96 max+ would be a perfect mini computer that works OOTB. I am also very happy that now I can run wine apps by using box86 in this box.

Actually, I am curious how did you find out that our box uses the “rtl8822c”? is there any command that you have to type to identify your wifi and bluetooth hardware? I am asking this, because my other box which is H96 Max RK3399 cannot detects the wifi and bluetooth. And I don’t know which hardware that is used?

On manjaro? Is it 64bit version or 32bit ?

How well does it work?

There is a full thread about it on armbian. No command just teardown the device and see the chip model is the easiest.

This must be rtl8723cs which ive pkged for station P1 but it’s just a guess.

I quick online search shows me wifi chip model
This link

Wifi = AP6255
You need its firmware to be present with the dtb model name as the suffix.

Update 2
Khadas vim 1 used same chip, you just need that wifi pkg and add the model name as suffix

Update 3
Install kvim1-firmware

sudo cp /usr/lib/firmware/brcm/brcmfmac43430-sdio.khadas,vim.txt /usr/lib/firmware/brcm/brcmfmac43430-sdio.{manufacturer},{model}.txt

Replace manufacturer and model as per the dtb/dts compatible model names.

It should work.

Yes, that is how I did it.


I finally found a more straight forward method to install rtl8822cs wifi driver.

Howto: Compile and activate RTL8822CS wifi driver - easier version

Open a terminal and do the following:

  • sudo pacman -S base-devel git bc dkms linux-vim-headers
  • git clone
  • cd RTL8822CS/
  • sed -i 's/$(MAKE) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C $(KSRC) M=$(shell pwd)/$(MAKE) -j4 -C $(KSRC) M=$(shell pwd)/g' Makefile
  • sed -i 's/$(CROSS_COMPILE)strip $(MODULE_NAME).ko --strip-unneeded/strip $(MODULE_NAME).ko --strip-unneeded/g' Makefile
  • make
  • … (wait about 5 min.) …
  • sudo make install
  • sudo modprobe 88x2cs

This is easier to package.

Great work and good that you gave sometime to this topic and finally got it to work and also simplified it for other users.

Much Appreciated.

1 Like

Yes, on Manjaro 64bit. I think I have posted the tutorial in this forum and Armbian:

the performance is quite good for LLVM Pipe driver. I managed to install sketchup 8 and make some 3D models quite easily.

I see, so that’s the trick

OK, thanks for your guide, will try this on “Armbian Reforge”. Since that is my only hope to run linux on this board. At the moment I cannot boot into Manjaro or Armbian or TwisterOS. It just a black screen.

You are awesome, Many Thanks… :slight_smile:

I’ve lost sound from last update. Downgrading to linux-vim-5.10.1 does not work and running either. How can I recover sound? Maybe I need detailed instructions because I just do anything wrong.

Maybe does not detect your soundcard correctly. You can then try the following:
(I am writing this from memory because I currently do not have access to my box)

  • Open terminal and then type: aplay -l
  • Copy name of your device to clipboard.
  • Now type: sudo nano /usr/bin/
  • In the top of the script under the section where script tries to automatically detect card1 (ca. line 6-8) add: card1=“NAME_OF_YOUR_SOUNDCARD” (Ctrl+Shift+v to paste)
  • Ctrl + S to save and then Ctrl + x to exit nano editor
  • Now run /usr/bin/ again
  • Type: sudo systemctl enable sound --now
  • Reboot and pray!

@spikerguy thank you so much for the nice feedback!

Finally, it is only the typical “clone, make, sudo make install” which did not work in my first attempt because the makefile is written for cross compiling. I learned all of this with the help of your rtl8723du package. Thanks for that!

@rna in fact you are awesome! Thanks for telling us about box86 and the great step by step tutorial how to install it. I missed it before.
So I followed it and everything went well … except at the very end after starting Sketchup 7.1 and choosing the default view it stops with an error “Cannot find OpenGL” driver. What am I missing?

Glad that you make it! Welcome to Box86 World on Arm64…!!!

In case of sketchup, actually it’s super easy. The bug is in the sketchup itself, even if you installed sketchup 7.1 / 8 in Windows 7 above, you’ll get the same error.

You have to edit the wine regedit and change the display setting

  1. Open Sketchup then close
  2. Open terminal then run regedit by typing:
    schroot -c debian-armhf ~/box86/build/box86 ~/wine/bin/wine regedit
  3. Then find:
  4. Then change the “HW_OK” from “0” to “1”
  5. Then close your regedit
  6. Then open Sketchup 7/8, you should be ok.

This fix also works for windows 7 above

Anyway, I have updated the topic in Armbian Forum including the Box86 compatibility list link. Feel free to re-read my update.

Hope that helps,
Many Thanks

Followed your instructions and now Sketchup works. :grin:
Really impressive that such a low-power ARM box is capable of running such a program so smoothly! I never would have thought it to be possible …

Must have taken you many, many hours to figure out how to run box86 on ARM 64. Thanks you so much for your effort!!!

Yes, I also impressed with this low powered box to run sketchup so smoothly on LLVM pipe drivers. Have you tried to use Panfrost? I disable panfrost since it causes my box to hang everytime.

At the moment I’m struggling with making winetricks to work. I am able to use winetricks and install sketchup 2014 on Armbian Reforge. But I failed to use winetricks by using this chroot method. Still trying to figure it out. Help would be appreciated.

I already posted that in the armbian forum. Maybe somebody else could help to solve this issue, then we are almost very good to run almost every win32 apps on Arm64.

Actually the trials took me from june 2020 starting with Binfmt_misc & Qemu-user-static, which is not usable, here’s my story: How To Install Box86 on Manjaro Arm64

But luckily I found box86 which is way faster than Qemu. There you have it now

Yes, I used Panfrost. When you install mesa-git package you get mesa 21 develop version which is a lot lot better than mesa 20.3.
Supertuxkart and OpenArena are running smoothly. Also: turn off compositor in XFCE.

Is it stable now? or still sometime crashes?

What Manjaro Image do you use? which kernel?
What is the DTB that you use?

I am using linux-vim 5.10.5 kernel, unstable branch, XFCE

BTW @spikerguy I was building this image with the manjaro-arm tools yesterday and sound is working out of the box now. Great job!

It was unstable and crashing with vim kernel <= 5.9 but with 5.10 everything is rock solid!

My custom .dtb derived from meson-sm1-sei610.dtb.
@gausus just posted a version of this .dtb where ethernet speed is reduced to 100M (because he had problems with speed set to 1G). See post#640.

Hats off for being so persistent! :tophat:

1 Like

Thanks for this information. I’ll try to switch to Kernel 5.10 then.

Have you tried to open Blender 2.8+ using Panfrost? last time I tried with panfrost it failed to open, but using LLVM Pipe it opens but too laggy. It seems there’s something wrong with the OpenGL 3.2 in Panfrost Driver?