Blender does not start after installation

Hello friends, I use Manjaro Linux 20.08 on my Raspberry Pi 4. Today I installed the program “Blender” via the package manager. During the installation, I was asked if I would like to install programs that “Blender” depends on, and I answered yes. After installation, the Blender Starticon is in the menu under Graphics. Unfortunately nothing happens when I try to start “Blender”.

Can someone tell me why and give instructions on how to install “Blender”?

Cheers
Sid1968

Hello @Sid1968!

What happens when you start it in a terminal with blender ?

Are you sure the pi has the hardware to run blender? It’s very graphic intensive isn’t it

It says:


“Error! Unsupported graphics card or driver. A grahics card and driver with support for OpenGL 3.3 or higher is required. The program will now close.”

“Error: Not freed memory blocks: 14522, total unfreed memory 5.364872 MB”


Hmmm…

Yes, search on youtube for “raspberry pi 4 blender”. It runs under Raspbian Linux.

2 Likes

You could use this to overwrite the version:

MESA_GL_VERSION_OVERRIDE=3.3 blender

Disclaimer: Not my fault if something goes wrong :see_no_evil:

Thanks for that advice. How do i overwrite the version?

This way.

I entered that in the Linux Terminal and made a reboot, but the errormessage is still there.

It works only temporary. Whats says:

MESA_GL_VERSION_OVERRIDE=3.3 glxinfo | grep "version string"

:question:

It says:
-bash: glxinfo: Command not found.

You need the package mesa-demos to run glxinfo :wink:

OK. Now it says:

server glx version string: 1.4
client glx version string: 1.4
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.1.7
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.3 (Compatibility Profile) Mesa 20.1.7
OpenGL shading language version string: 3.30
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.1.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

After starting blender:

Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.
Error: Not freed memory blocks: 14522, total unfreed memory 5.364872 MB

Well then it is not possible with that version of blender. Maybe pervious versions were able to do it.

But hey, why on earth do want to run blender on a raspi? :smiley:

There is blender-2.7-es2 in the repo, but it breaks often because of package updates.

Blender as a software, is not made to run on low powered devices…

The Raspberry Pi 4 has four cores. As i mentioned above… it runs fine on Raspbian Buster. But i thank you for your help. Maybe one of you still has an idea how to get Blender to work under Manjaro Linux.

Cheers
Sid 1968 :sob:

P.S .: No, I’m not a crybaby … the tears only come from the wind in my eyes.

1 Like

Rasbian use closed source drivers, which probably has OpenGL 3.3 support, while the Open Source ones Manjaro uses, does not yet.

Same problem here. But I checked the output from the console:
blender-2.7: error while loading shared libraries: libOpenImageIO.so.2.1: cannot open shared object file: No such file or directory

The list of libraries that are missing.
  • libOpenImageIO.so.2.1
  • liboslexec.so.1.10
  • liboslcomp.so.1.10

It breaks because the libraries are newer than they should be.
The good idea from devs (if it couldn’t be fixed by just updating the package) would be uploading seperate set of libraries for this package – eg. libOpenImageIO-2.1 package, as newest version is newer than expected (>=2.2). The packages by themselfes would offer nothing but the content that would be installed in the /usr/lib directory and without of some links/symbolic links (to make them non-conflicting with existing/newer packages).

Why not use newest blender?

Somehow with that setting blender (not blender2.7-es) runs succesfully – but it works damn slow and the lighting is broken, which is because RPi doesn’t support OpenGL 3.3+ and does not understand all of its instructions. But that’s the good tip for running some other software that requires OpenGL 3 to run on the RPi (when you’re not focused on getting things working in 100%).
In other words – you need Blender 2.7 ES, as it’s better optimized for Raspberry Pi and doesn’t require OpenGL3.3+ to run. Don’t try newest Blender, things are broken here, even Manjaro’s unstable branch is more stable than that :wink:.

Do-it yourself part, if you don't want for updates.

If you want to provide those libraries by yourself, there’s ArchLinux ARM Unofficial Archive – not mine BTW, but worth using this repo as it saved me hours of getting some obsolete libraries for even more obsolete software, that intents to run on Debian/Raspbian. Oh, you can also get them from Raspbian, but that would be harder as Debian/Raspbian Package != Arch Package.

1 Like

It does not seem to be able to compile using the new openimageio package. :frowning:

The good idea for devs (if it couldn’t be fixed by just updating the package) would be uploading seperate set of libraries for this package – eg. libOpenImageIO-2.1 package, as newest version is newer than expected (>=2.2). The packages by themselfes would offer nothing but the content that would be installed in the /usr/lib directory and without of some links/symbolic links (to make them non-conflicting with existing/newer packages).

Oh, I forgot there’s an AUR, too (so you could upload this package by yourself). Or you can upload repo on GitHub.

Maybe then I’ll create the proper PKGBUILD soon if I’ll find some time for doing that.