[How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC

Thanks for sharing. Works well on my X96Max+ too except Wifi dosn’t work and that with the meson-sm1-sei610.dtb ethernet wans’t working neither (but works fine with the meson-sm1-x96maxplus-vim1000m.dtb). For information (if others have the same problem) my network chiset is RTL8211F for Ethernet and RTL8822BS for Wifi and BT. I’ve to figure-out why Wifi is not working.

You have driver for RTL8822BS, try installing.

Thanks. I don’t know if you are refferring to this one (GitHub - ChalesYu/rtl8822bs-aml: unoffical driver for linux). I’ tried to compile but I didn’t succeed (I’m a bit a newbie :wink: If you have any pointer on how to install or compile the driver I would really appreciate. I’m also wandering if it’s not a problem with the dtb.

Try this sudo pacman -S dkms-rtl8822cs.
I managed to get wifi working on my X96Max+ for earlier kernel, but not for latest/

==> Unable to install module rtl8822cs/2020.11.20 for kernel 5.14.10-1-MANJARO-ARM: Missing kernel modules tree.

look here https://forum.manjaro.org/t/manjaro-arm-on-amlogic-tv-box/34662/648?u=loop223

Did you install the kernel header files of 5.14.10-1 kernel?

I tried several times. I had an error with the dkms command (likely due to the GRO_DROP/GRO_MERGED_FREE issue). But managed to run the original make procedure provided by @TheMojoMan Manjaro arm on Amlogic Tv box? - #658 by TheMojoMan. I see the module running with lsmod. But the Wifi is not working. I wonder if is not due to a difference in chipset (mine is RTL8822BS and the driver is for 8822CS). I’ll try again with a re-install from scratch …

For testing purposes I have upgraded from linux-aml-5.13.rc5-1 to linux-vim-5.14.10-1. So I downloaded linux-vim und linux-vim-header files and installed them using

sudo pacman -U linux-vim-5.14.10-1-aarch64.pkg.tar.zst linux-vim-headers-5.14.10-1-aarch64.pkg.tar.zst

The rtl8822cs dkms driver then built successfully and after reboot wifi is still working with the 5.14 kernel!

However, I get a new strange error which currently renders the new system unusable for me:

My mouse cursor is invisible/not drawn anymore. Or to be more precise, after XFCE desktop is loaded it works normal for some seconds but then when the panel is fully drawn the mouse pointer is only drawn at its last position. When I e.g. move my mouse to the bottom right I can still left click and get the reboot options or if I move it the the bottom right I can click and the Manjaro menu opens. So the mouse is still functioning but the pointer is not drawn/updated.

I still need to search if this is a known error and if there is already a solution to it. Maybe I just have to fully switch to unstable branch so that the other packages are updated as well (only wanted to test if wifi still works with 5.14 so I did not switch branches and also did not do a full upgrade).

I guess you pinpointed the problem. Try to find the BS version of the driver and compile it.

As mentioned, I tried a last time to re-install all from scratch and apply the dkms. I did the following:

  • burned on SD the version Manjaro-ARM-xfce-vim3-21.03.img (it’s one of the very few that works on my box) with meson-sm1-x96maxplus-vim100m.dtb
  • Then sudo pacman -Syyu linux-vim
  • Then sudo pacman -S base-devel git bc dkms linux-vim-headers

When I do uname -a I get → Linux X96 5.11.4-11MANJARO-ARM
However, when I try to install the headers : sudo pacman -S linux-vim-headers
the system propose to install the version linux-vim-headers-5.14.10-1
And the difference of headers versions leads to a fail of the driver install (dkms-rtl8822cs).
Do you know why the system desn’t pick-up the right header version ? Thanks for any advice.

What is the result of this command ?

The only driver I could find is this one : GitHub - ChalesYu/rtl8822bs-aml: unoffical driver for linux
I tried to run the make but it didn’t work. I’m a newbie … I’ve to investigate a bit further how to build a driver (simply running the make doesn’t seem to work :wink:

nothing will get built if you have kernel and headers mismatched.

First we need to find why do you have older kernel while newer header.

A massive update :wink: But at first first sight succesful. Is there someting I should check ? Tnx

First rule of rolling release distro like Arch/Manjaro.
Never do partial upgrade. It can break the system :wink:

first do sudo pacman -Syyu linux linux-headers base-devel git bc dkms
then try dkms pkg from repo to see if wifi will work with cs pkg if not then try bs pkg from that git link/.

Good Luck, I am off to bed.

Thanks a lot ! I’ll try :wink:

I guess it should be

sudo pacman -Syyu linux-vim linux-vim-headers base-devel git bc dkms

linux and linux-headers installs the mainline kernel which might result in your box not booting or not having sound as I have experienced many times before with my X96Max+.

1 Like

Thanks ! I’ll try right now and let’s see.

1 Like

@spikerguy @TheMojoMan I tried both versions, unfortunatly neither worked. FYI the dkms-rtl8822cs package still contains the GRO_DROP issue (but I managed to copile the driver with the make procedure doing the change manually … but the wifi is not detected). Could you please advice a good (ideally simple :wink: tutorial / info page to try to compile the driver I found (GitHub - ChalesYu/rtl8822bs-aml: unoffical driver for linux), just to give it a try. Thanks again for your help.

1 Like

@spikerguy Could you please update the driver? Thanks!
See this post: Manjaro arm on Amlogic Tv box? - #1142 by TheMojoMan

1 Like

Updated repo will push it tonight. Thanks.