Manjaro arm on Amlogic Tv box?

May be it’s multibooting. Found /extlinux/extlinux.conf and finding gets tired

1 Like

Thanks Uropb, that’s very interesting.

This means that the kernel panic is resolved with 2020.10 chainloader uboot.ext

I see that it try to boot over usb when any usb drive is connected which might need some fixing.

Where did you get the updated uboot.ext from? I had it in boot-vim3 old pkg but I think it got mixed up with the old one in my newer update.

I cannot test it on my gskingx as it doesnt boot at all.
I will try it on gt king pro but I have alot of data on it so a complete backup is needed. It will take time for me to test So i hope someone can test it for us. Will ping darkstar on beelink forum.:wink:

It seems like when another usb drive is connected it will also try to boot up from that drive which causes time out, after time out… if the first usb drive it found do not have boot. But it does seems to resolved Beelink GT King Pro Kernel Panic issue.

Hi Spikerguy,

I got it from this link for_linux-vim-5101.tar — Yandex.Disk provided by “uropb” and according to “uropb” it is from LibreElec.

I have also use the same new u-boot.ext on Armbian_5.9.0 at it works and also seems to resolved the Kernel Panic issue also. I have simulate the condition that usually caused Kernel Panic on GT King Pro with the older Armbian U-Boot and with this new U-Boot, NO Kernel Panic so far just like on Manjaro.

Attached herewith the Armbian-5.9.0 initial boot up sequence. It is booting from the same address “0x8008000” just like in Manjaro-ARM-VIm3-linux-vim 5.10.1-1.

Edit: In Armbian-Focal-5.9.0 with the new u-boot.ext, if I use the old “meson-g12b-gtking-pro.dtb” Kernel Panic issue still persist.

But with the newer “meson-g12b-gtking-pro.dtb” or “meson-g12b-ugoos-am6.dtb”, No Kernel Panic on GT King Pro . This is interesting.

So it seems the dtb does play a role in the kernel panic on GT King Pro at least on Armbian-Focal-5.9.0.

Edit 2:
On Manjaro-ARM-VIM3-XFCE-Linux-Vim 5.10.1-1 with the new u-boot.ext the dtb file used doesn’t seems to have any effect in terms of kernel panic, both the newer and older “meson-g12b-gtking-pro.dtb” No Kernel Panic.

Yes, darkstar will be a good person to test it as he also uses a Beelink GT King Pro and he also built Debian/Ubuntu images. I have send him a message here in Manjaro Forum where he was participating at [How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC.

Linux sala 5.10.1-2-MANJARO-ARM #1 SMP PREEMPT Fri Dec 25 00:42:04 +03 2020 aarch64 GNU/Linux

Linux-vim 5.10.1-2
So far its ok, after updated I had to edit extlinux.conf because it automatically changed the dtb

1 Like

Yes this will always be the case but boot pkgs are not updated frequently.

But make sure after every update you verify it before rebooting.

I notice more glitches with Panfrost, but I’m in intensive testing with firefox on youtube, rendering with panfrost Opengl ( layers.acceleration.force-enabled = true)

In Firefox with layers.acceleration.force-enabled = true, does the YouTube video has high dropped frames? When I tried it with linux-vim 5.9.8-2 and mesa-git or mesa 20.2.3 I have high dropped frames.

VP9 720p@30fps is working fine (very low dropped frames, resulting only when using the cursor to maximize) other resolutions play horrible because s905x3 doesn’t have the power for software decoding. Unless we have something like vaapi so we can use vdec with firefox I don’t think that is going to be better, because panfrost only can help with render.

In the armbian forum there has been some work about vaapi using libva-v4l2-request, but I don’t know what can be used with vdec Mainline VPU - Page 3 - Rockchip 3399 - Armbian forum

1 Like

In my case if all Firefox settings is at default that is no acceleration and Panfrost not activated, I have low dropped frames with 720p/60 and 1080p/30 videos and CPU usage is also at reasonable level (meson-vdec seems to be working).

Firefox YouTube 720p/60 at view port at 1280 x 720:


Hi Spikerguy,

Just successfully updated to Stable-2020-12-30 system update (a large update size of 676MB) in one go. I can now confidently say the new u-boot.ext from LibreElec whad resolved the Beelink GT King Pro Kernel Panic issue. Have NOT reboot yet.

I notice your new boot-vim3-2020-10-1 u-boot.ext had replaced the LibreElec u-boot.ext. Taking your hint and my earlier experience when updating linux-vim 5.10.1-1, the extlinux.conf file had been modified by the system update thus need to edit the to boot with meson-g12b-gtking-pro.dtb.

Yes I think this is the same issue from the beginning u-boot.ext gets ignored due to its existence i will update all the pkgs and keep it default as before it needed manual intervention.

Thanks for informing.

Thanks, Reboot with success after Stable-2020-12-30 updates.

The boot-vim3-2020-10-1 u-boot.ext boot up linux-vim 5.10.1-2 after changing the extlinux.conf to boot with meson-g12b-gtking-pro.dtb instead on khadas-vim3.dtb.

Kernel Panic issue on GT King Pro seems resolved with your boot-vim3-2020-10-1 u-boot.ext too.

Thank you, great work… Hope you are now fully recovered.

Happy New Year.

1 Like

Hi Spikerguy,

FYI, After the latest Stable-Update-2020-10-1, the Sound does NOT work anymore.
“systemctl enable sound --now”
The above CLI did not do the trick to get sound back.

Oh dear I completely forgot to update the sound script which i did before but that was too early.

I hope this is on linux-vim can you try the new script lines and see if it works for you?

Here is the new script.

It should work fine with this one.

Please share the output of aplay -l

[jfl@MNJROGTKPRO ~]$ /usr/bin/

[jfl@MNJROGTKPRO ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: G12BGTKINGPRO [G12B-GTKING-PRO], device 0: fe.dai-link-0 () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12BGTKINGPRO [G12B-GTKING-PRO], device 1: fe.dai-link-1 (
) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12BGTKINGPRO [G12B-GTKING-PRO], device 2: fe.dai-link-2 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0

[jfl@MNJROGTKPRO ~]$reboot

Edit: Still NO Sound after reboot.


Edit2: At least one Odroid N2 user had also highlighted NO Sound after the latest Stable-Update-2020-12-30.

I just tried it on vim3 now I will try it on Gt King Pro and report back.

Update: Yes it didn’t work on GT King Pro please comment out the new conf and keep the old conf for GT KIng pro until the dts is updated for GT King Pro and GS King X.
I see that the VIm3 dts and Gt King PRO dts have different HDMI routing so I will have to check with maintainers if it will continue to be this way then we might have to add more cases in the script.

Thank you for informing.

Do you mean use the old/previous “meson-g12b-gtking-pro.dtb”?

The extlinux.conf is currently as follows:
LABEL Manjaro
LINUX /Image
INITRD /initramfs-linux.img
FDT /dtbs/amlogic/meson-g12b-gtking-pro.dtb
APPEND root=LABEL=ROOT_MNJRO rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash


meson-g12b-gtking-pro.dtb (after the latest Stable-Update-2020-12-30)

Edit: Update. Reboot by using the old/previous “meson-g12b-gtking-pro.dtb” still NO Sound.

I am not sure what you meant by “comment out the new conf and keep the old conf”