Manjaro arm on Amlogic Tv box?

Let me look into this device specification and get back to you.

Amlogic S905X3 it is similar to what @TheMojoMan have been using…

I will need help from @TheMojoMan @jfl and @tripole
Lets write a details step by step tutorial for amlogic soc.

  • Amlogic S905X3
  • Amlogic S922X(A311D)
  • Amlogic S912
  • Amlogic S905X(S905W)

I will write about the last 3 but the first one is upto @tripole @TheMojoMan as I dont have any S905X3 device and one of you have it so we might need all dtbs which are used for S905X3.

This way to be move thise tutorial to wiki slowly.

Thank you for supporting manjaro arm project, I have been working on a tutorial for using Manjaro with samba over webmin. I excepted virtualmin too but virtualmin is not supported for arch based distro.

For now you can download Vim3 image and change the dtb name in extlinux.conf

Manjaro Vim3 Image

1 Like

I have x96 air P3.
For me, the dtb from the @TheMojoMan works, and even the ones from armbian too. Depending on the kernel I use different dtb to get Ethernet and sound. But what I experience is that every time I install a new kernel I have to start with meson-g12a-sei510.dtb, for be able to boot for the first time, then change the dtb to get Ethernet (no sound in the mainline kernel) or sound on linux-vim.

1 Like

I have an Ugoos Am6 plus which has the s922x-j SoC. I have written a (small) tutorial before. I will shortly redo the process with the image that you Spikerguy provided, verify that everything works and write an updated and simplified tutorial (since now some of the previous steps have been superseded by recent developments of the Manjaro images).

Edit: Maybe I misunderstood you here, and if you want to write a (generic) set-up instruction for s922x SoCs please do so. There are only some small changes needed specifically for the Ugoos Am6 plus.

1 Like

Yes I will re-use your tutorial in a single tutorial thread as this thread have become too long for new users to go through.

Thanks for the link.

I have a Tv box: Tanix TX3 S905X3 4GB RAM 32GB ROM 2.4G 5G WiFi Android 9.0 8K TV Box Support Voice…i had install manjaro using Vim3 image succesfully …Now i like run manjaro from emmc card of the TV Box… For this I had used manjaro-arm-installer but my tv box do not run manjaro from emmc…the tv box do not load. does anyone know how to do this?

I excume for my bad english…my native language is spanish.

Hello @jbolanosg and welcome to the forum.

Can you share the dtb file you used?

There is emmc installer file already present in the installation. No need for manjaro-arm-installer that is not the right way for Amlogic boards.

Just make sure you take backup of your content of emmc.
start Manjaro with latest image over sd card.
Run this command

  • sudo /boot/

Make sure your date time is correct before running this command.

Once it show Flasing Manjaro to eMMC Completed then restart the device with sd card inserted and reboot it 2 times with Manjaro on SD card after that you can power off and remove the sd card and power it on with Manjaro on eMMC.

Try this as your own risk as we have not tested this on your device. I or Manjaro Project will not be responsible if you brick your device.

Good Luck.

Tutorial Link Up:

My TV box is bricked in this moment for failed proccess with emmc…i am going to recover it using amlogic USB burning tool…later i am going to use the tutorial and comment you as finished.

Edited (Update): I do it…My Tv Box is live other time. The items that i had used are:
Image = Manjaro-ARM-kde-plasma-vim3-22-11-2020.
dbt file = meson-g12a-sei510.dbt of the image.
Network = ok 100 Mbps.
Wifi = not tested.
sound = not tested.
Login with Desktop session (Plasma -Wayland): Not login.
Login with Desktop session (Plasma): Ok

Later i am going to comment the step of transfer manjaro to emmc.

1 Like

I had executed the command: sudo /boot/ and this process failed with follow logs:

root@tx3 boot]# sudo /boot/
Start script create MBR and filesystem
Start backup u-boot default
4+0 records in
4+0 records out
4194304 bytes (4.2 MB, 4.0 MiB) copied, 0.081489 s, 51.5 MB/s
1+0 records in
1+0 records out
512 bytes copied, 0.00158571 s, 323 kB/s
Start create MBR and partittion
Start restore u-boot
442+0 records in
442+0 records out
442 bytes copied, 0.00592617 s, 74.6 kB/s
8191+0 records in
8191+0 records out
4193792 bytes (4.2 MB, 4.0 MiB) copied, 0.173762 s, 24.1 MB/s
Start copy system for eMMC.
Formatting BOOT partition...mkfs.fat 4.1 (2017-01-24)
Copying BOOT...done.
mv: cannot stat '/ddbr/install/[]': No such file or directory
Formatting ROOT partition...
e2fsck 1.45.6 (20-Mar-2020)
ROOT_MNJRO: clean, 11/1851392 files, 160257/7401216 blocks
Copying ROOTFS.
Copy BIN
Create DEV
Copy ETC
tar: etc/pacman.d/gnupg/S.gpg-agent.extra: socket ignored
tar: etc/pacman.d/gnupg/S.gpg-agent.browser: socket ignored
tar: etc/pacman.d/gnupg/S.gpg-agent.ssh: socket ignored
tar: etc/pacman.d/gnupg/S.gpg-agent: socket ignored
Copy LIB
Create MEDIA
Create MNT
Copy OPT
Create PROC
Create RUN
tar: selinux: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
Copy SRV
Create SYS
Create TMP
Copy USR

This proccess never finished. Someone help me?

Edited: After proccess the USB drive with manjaro installed previously it doesn’t work either.

This takes long time depending on the speed of your emmc and sd card.

Did it show flashing complete?

Did you reboot 2 times with sd card inserted?

Hi Tripole,
Not sure is appropriate to ask Non-Manjaro issue here. Understand you have the above Khadas-Vim3 4.9.224 V0.9 20200530

With the Khadas-Vim3-Debian/Ubuntu kernel 4.9.224 V0.9 image were you able to run Ubuntu-Wayland? I could not get Ubuntu-Wayland to start just X11 running. Tried reinstall gdm but still doesn’t work and if restart gdm it will give blck screen. Furthermore I could not upgrade to kernel 4.9.232, understand 4.9.232 performance is better.

My issue is unless the GT KING PRO Kernel Panic on Mainline Linux is resolved the Manjaro is basically for testing and learning, waiting for kernel panic issue to resolve. Real work is on the legacy kernel linux. That is the reason seeking assistance to upgrade/update 4.9.224 to 4.9.232 v0.9.3 20200814 and try out Wayland on the legacy kernel. Tried raising the question in Khadas Forum before unfortunately no guidance.

Hope I am not violating any rules here.


Sorry, no I don’t have that image; I built my own Khadas image (with kernel 5.9.0-rc2) using their image building tool fenix (available on github). If you send me a PM we can take this discussion off line and discuss it further there.

Innocent question, how to do I send you a PM on this forum?

I think it is the way you just did, before you deleted it (so I did not have time to read it through). Doh.

I got something to work :smiley:
Guess what is it ?


5.10 kernel?
With dual boot?


Not yet.

Update: We have found the audio fix for Mainline kernel so for those who want to give it a try can download the latest kernel pushed to unstable linu-5.9.12-2 this one have AMlogic G12 audio fix and also some vdec config enabled. This will help users test panfrost support for their device.

1 Like

Great work. So now we can boot up on 5.10 kernel on TV Box using Android BSP uboot? Will give linux-5.9.12-2 when it reach Testing Branch.

Looking forwad to Beelink kernel panic solution.

Yes, great work. Amazing how manjaro arm is improving for SBC and TV boxes.

Do you think it’s viable to use such an Arm based TV box like the X96 Air P3 (S905X3) as a full fledged replacement to a more common x86 SBC (for example like the ODROID-H2+ which I have been considering as well) for a small home server with low requirements?

I mean such a TV box is really cheap compared to a regular SBC and I could think of a couple of such TV boxes for different tasks instead of one regular SBC which still comes a lot cheaper.

Yes I have been using a small ARM based device for nas drive, jellyfin server and now etherpad server and it’s working just fine.
If you want high resolution video playback then you cannot compare it with x86 against ArM on linux but on Android you can.

Depends on what task you want to fulfill with it.
The performance will almost be the same as long as the tv box have good heat dissipation. Linux still lack video processing support as vpu drivers are still not available but video processing upto 1080p on cpu load works quite well but it depends on the tv screen as it does look choppy at times in a big screen while 720p works just fine.

Yes, I just did a market search for S905X3 tv boxes and they’re dirty cheap like $30 for 4Gb Ram with 32b storage. If you plan to run it as a server for applications then it will work perfectly

1 Like