Manjaro ARM for Rockchip TV Boxes

Hi Guys, As per @spikerguy suggestion. I make this topic about booting Manjaro Arm on Rockchip TV Boxes.

So, I want to boot Manjaro Arm for my “H96 Max RK3399” box. I have tried the image RockPro64 and Rock Pi 4c, but couldn’t boot.

I also noticed that in Armbian I cannot boot from the official image, however using Balbes150 image and u-boot “u-boot-rk3399-nanopc-t4” does the trick. I download it from here: RK_AML_AW — Yandex.Disk
However, when I applied that to the Manjaro Image, it broke my SD Card Partition.

I also noticed that Armbian Reforge is working out of the box. But Twister OS Beta for both Armbian and Manjaro Arm do not work.

I addition, I can also boot in Libreelec OOTB by using the Rockpro64 image.

Help would be appreciated,

Many Thanks,



Please build an image for Nano PC T4 as it is supported in Manjaro ARM Installer

It should work if the TV box is similar to T4.

Try that and let us know.

Good Luck.

How to do this?

Is there any guide to use this installer?

Here you have my image with the latest kernel that runs on aml and rk

I hope can be downloaded

Thanks for your image, but unfortunately it cannot boot to RK3399. Even though after changing the dtb, it didn’t boot.

Have you tried with sdcard+usb?

yes, it doesn’t boot

I have built nanopc t4 image for you to try. Find it here: ‪images‬‏ - Google Drive

Password is 1234

Wait to boot 5 minutes at least. Your box seems to do very slowly with 5.x kernel.

Good luck

1 Like

Thanks for the image, but unfortunately it just boots in black screen.

I have no cpu frequency driver for rk3328 and cpupower doesn’t work. Acpi-cpufreq module is not in kernel directory and modprobe fails to load it.

How can I get this module?

I have uploaded an image for rk3328 with boot for someone to try. It’s the vim3 and works in mine with video and sound.

You can add another boot following Add u-boot to SD card of balbes150 thread in librelec forum. But this is risky as you can wipe your hardisk.

I have tried a better way to change the boot but image doesn’t fit.

Tested on : MXQ Max superpow leelbox q4

I found the solution of my H96 Max RK3399. Now it can boot…

The problem was related to the AC Adapter, the one that comes with the box seems to be underpowered. The Input was max at 0,3 A. It was ok on android but cannot boot Linux.

If I changed the AC Adapter. Input max at 0,5 A, it also cannot boot.

This morning I tried to use the AC Adapter. Input max at 0,4 A. And everything seems to work ok. Now I can boot Linux using this AC adapter

Very good.

What image are you using? All works?

At the moment, I am able to boot to armbian using Balbes 150’s image and u-boot. Have tried manjaro from official image, but couldn’t manage to boot up. It just a black screen.

TwisterOS also doesn’t boot. But Armbian Reforge is getting better, because before it causes to hang and restart everytime I used a graphic intensive task. Now it seems to be ok.

I think you should be able to boot manjaro with the same u-boot from armbian that works and vim3 image. This works for me. It’s easy to boot with sd card and have linux in an usb drive for making trials and afterwards you can insert all in the sd card.

the problem is, when I burn the u-boot. The sd card partition is broken. could you please share your u-boot?

I have to explain this a little more. You have the u-boot for nano pc-t4, and this can be written to an sd card. Insert this card with the u-boot (no linux system) in the Tv box. In a second usb drive you write minimal manjaro vim3 image and insert it in the usb of your box.

When you power on the box, sd card boots and seeks for a bootable partition, finds it in the usb drive and display starts to output messages . This happens if you have a good .dtb for your box defined in uenv or extlinux.

This way you are sure boot is fine and linux file system as well. When you get manjaro working and are satisfied then you can write the u-boot and filesystem in one sd card, but this is not so easy and first you should make sure manjaro can run with your filesystem (.dtb, bootargs, kernel …)

edited: First trial would be to use your working armbian in the usb and u-boot in the sd card, this way you are sure if your box can do it fine.

this is actually my biggest question, how to do that without breaking the manjaro partition in SD Card. On Armbian, I use etcher:

  1. burn armbian Balbes 150’s image on an SD Card
  2. burn the “u-boot-rk3399-nanopc-t4” image on the same SD Card.
  3. SD card is ready and running perfectly

meanwhile, on manjaro after step 2, my SD Card partition is broken. do you have a u-boot specific for Manjaro Partition?

No, I don’ t. See my post with balbes150 librelec link.

I have read that, but I have no idea about the process? I don’t understand Balbes150’s word at all.