Manjaro ARM Beta10 with Phosh (PinePhone)

Hello, just installed the phosh beta 10 for pinephone and the default sms (chatty?) doesn’t show the green send button! I can see it when I minimize. It is off screen to the right in full screen mode and there doesn’t seem to be an auto-rotate. Is there any solution or keybaord shortcut to send? Very frustrating. Thanks.

Looks like if you turn the keyboard to terminal mode and use the ‘tab’ key, the green send button will then be visible

1 Like

thanks, i found an auto-rotate button in the quick settings as well.

Answering my own question.

In a terminal I ran phosh --version and that showed 0.10.2, so it has been updated.

I installed Release Release 202105240313 · manjaro-pinephone/phosh-dev · GitHub and when i try to use pacman it says invalid or corrupted package. I have tried to update mirrors, tried the keyring issue wiki, even the later steps, but also some of them failed with same error.

Issue seems to be “arch linux arm build system” gives incorrect key and it is not populated into the keyring, and packages depending on it fail to install.

The only unorthodox thing i did was i changed branch from unstable to testing after installation, can this cause these kinds of errors?

edit: needed to use pacman-key --populate archlinuxarm instead of what was in the guide.

1 Like

In the Phosh Beta9 thread I posted a remark regarding the fact that both mobile and wifi connections remained dead on my phone when it came out of (deep) suspend.

Since switching to the unstable branch and updating a couple of days ago I can happily say that this behavior no longer seems to be happening, at least for the mobile connection! It seems to come back up every time, and fast too! :smile: I’ve also tested calling the phone a couple of times when it was in deep sleep for about 30 minutes, and it rang every time. So fast even that I was wondering whether the phone went into suspend at all, but that seems to be the case since the battery is not being drained like crazy.

Really happy to see this massive fix, thanks for all the efforts! Will use the phone as a daily driver for the coming time to see how it holds up! :slight_smile:

Edit: of course, I knew I should not have posted this, now I jinxed it :wink: After having updated the phone and rebooting, the phone is now regularly losing connection to the modem when coming out of suspend again, which is only ‘fixed’ by a reboot. I’ll try to obtain some logs when this happens. I have the idea that it’s happening more often when wifi is also active - but that might just be my imagination as well.

We have updated the way on how we do the modem with the latest dev-images. Give them a try.

1 Like

Hey phil, thanks for your response. That is good to hear! Just updated and rebooted, will see for the rest of the day how it goes and report back this weekend :slight_smile:

Today’s dev-build will bring more modem fixes …

3 Likes

is there any plans to release Manjaro on other Android existing phones

Hey, does Manjaro currently support 911 calls? I understand this would be somewhat hard to test without having an actual issue worthy of calling 911 lol

AFAIK, that is handled/routed by your mobile service provider (it should work fine with most popular carriers).

I can confirm that with a Verizon SIM card, dialing 411 works as expected (I do not want to test 911 - they get too many calls already)

Could use a bit of help. After updating to Manjaro Arm Beta 10 with Phosh, there is an error message that says…

warning: libtool: local (2.4.6+44gb9b44533-14 is newer than core (2.4.6+42+gb88cebd5-15

What do I do to fix this error?

Any help will be greatly appreciated.

That package has been rolled-back for some reason or another. You can run: sudo pacman -Suu which will downgrade the package to the current package version in the repo.

Thanks!. The command worked! Appreciate the super quick reply.

Hello - after updating to beta 10, I no longer receive text messages (I use t-mobile). I can send a text message, I just cannot receive one. It is a bummer. Incoming text messages was working with previous manjaro-arm betas. I read the sms posts above but could not conclude whether they pertain to not receiving text messages.

I did notice a post from two weeks ago at the bug-tracker about not receiving text message notifications, which is titled No Notifications.

Is there a fix or simply wait for a fit in the next update (beta 11)?

Appreciate all the help from this forum.

Hey drh, I thought I had this issue too, but it seems that the problem is a bit different (for me at least):

if you already have a conversation ongoing with someone you will properly receive SMS messages for them. If a conversation did not exist, the incoming SMS will not be displayed.

So I think it’s a problem with Chatty where new conversations are not properly created when SMS messages are received from “new” contacts. You can ‘fix’ this by first sending an SMS to someone (number or contact) that you expect a message from so that the conversation is created. Afterwards you will receive SMS’s in that conversation properly, I think.

At least, this is the behaviour I observed :slight_smile: None the less, it’s a bit of annoying problem indeed.

Edit: it seems that it’s still a bit different than I wrote above: it seems SMS messages are received properly only when Chatty is opened/started. If not, SMS messages will be missed - the phone comes out of sleep and the display turns on, but the SMS is not visible in Chatty. So this makes the problem a bit more serious :confused:

latest testing update seems to have brought wifi status icon visible even when wifi adapter is turned off. This is a good change.

Regarding chatty

Hi p1x3l3d - Thanks for the reply. For me, it does not matter if chatty is open or not. I left a chat (i.e., leave via the options menu) and still do not receive text messages. I have not tried deleting a chat in chatty and then see if I can receive a text message. For now, it seems receiving text messages is not working with beta 10 (i.e., not developer).