Manjaro ARM Beta7 with Phosh (PinePhone)

Manjaro ARM Beta7 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our fifth BETA release for the PinePhone running Phosh!

This image is running the 5.11 kernel from Megi, which is designed for the PinePhone.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps with working GPS
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta6

  • phosh is now at 0.9 series
  • update calls to 0.3.1
  • chatty got more fixes
  • more fixes to modemmanager, networkmanager and eg25-manager to stabilize the modem even more
  • pipewire is now at 0.3.23
  • fixed Headphone/set jack detection
  • screen fades to black for 5s before it turns it off on proximity. It won’t lock the phone, only on set timeout!
  • firefox is at 89.0.1
  • some fixes for gnome-contacts and gnome-control-center
  • regular upstream updates

A detailed list of package changes can be found here.

Currently broken:

  • Mic-Mute function in calls not working
  • GPS may not work as it should

Known issues

  • Megapixels might not show your back camera unless you had switched cameras once
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta7
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition Pre-Orders start on the 24th of March! Don’t miss it !!! Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.



If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta8 here

  • Beta6 (2021-03-20) Download
    • based on stable branch

Please update your phone to get the locale fix …

Is anbox still in this release?

I’ve just updated from Beta 6 to Beta 7 (daily driving it since beta 5) and the microphone level is now very low. I’ve opened a new issue at [Beta 7] Microphone level very low (#164) · Issues · manjaro-arm / issues / Pinephone / Phosh · GitLab.

Despite that, I’m really enjoying this new update, thank you so much guys!

Anbox is in, but it’s not starting up… flashed Beta7 to eMMC just an hour ago…

Update: starting anbox in terminal gives an error saying: error while loading shared libraries:

Update2: exists in /usr/lib… but has breaking changes… so a simple symlink → doesn’t work… I guess anbox needs to be rebuild against the new libprotobuf… :frowning:

1 Like

Hmm that’s concerning. I just finished flashing Beta7 to eMMC and I’ve initiated the software update process. Hopefully it should work. I’ll update once I’ve checked it.

Edit 1: Just updated the OS. Anbox refuses to start (just show the wallpaper). I guess you’re right about the need to rebuild.

Did you try to run it from a terminal? Just to check if it gives the same error message…

I can confirm this error

1 Like

I personally appreciated a lot the community challenge run by Pine64 for 5 distros, Manjaro ARM included, so that at the end, the winner takes all…Manjaro took all :clap:

I am proud honestly to be part of Manjaro community.
Now, sooner or later there will be Manjaro for Android and Apple devices, that’s a lot of achievements guys.
Congrats !!!

Be aware though that this is only possible via an emulator running in a browser… there might be no way to install Manjaro on physical Android and/or iOS devices. The announcements on social media made some days ago may refer to this: GitHub - copy/v86: x86 virtualization in your browser, recompiling x86 to wasm on the fly, which can run emulated x86 OSes in a web browser… just to keep the expectations and hype around the original post to a healthy level…

1 Like

Yeah :slight_smile: but everything has a begining, when i see JingOS, i feel like this is the very begining for more and more devices with Linux

1 Like

No is not :slight_smile: but indeed people went into speculation before having more information about it. Soon it will be revealed as what actually is.

1 Like

Yep. Same error.

What are the chances that this would be fixed with an OTA update in the software center?

I guess it can be fixed with an update, either in the software center or something like sudo pacman -Syu in a terminal, in a few days or weeks.

Too bad to see regressions like that in a beta release, personnaly I stick to unstable branch in pacman configuration.

1 Like

I updated this morning, with a reboot thereafter. Unfortunately I am having major issues with the modem getting lost after a while, approx 5x on a 3h walk, each time a reboot inbetween. None of that happened with beta6. I really appreciate the great development of manjaro, just now I would prefer to be able to revert back, like it is possible with opensuse on btrfs (desktop, not phone), as manjaro had become my beloved daily driver.

No modem after updating :cry:

The fix:
sudo pacman -Rs eg25-manager pinephone-modem-scripts
sudo pacman -S eg25-manager pinephone-modem-scripts

1 Like

Cannot connect TWO Bluetooth inputs at the same time.
Manjaro Phosh Beta6 and Beta7. I can connect a Mouse OR a Keyboard, but never both at the same time. In contrast, I could in Beta5 (clean image, before upgrades). Mouse is Logitech M535, Keyboard is Anker A7726 - although the mouse must always be paired first for some reason. main.conf etc. all look textbook.
I have spent a considerable amount of time searching through logs and checking via bluetoothctl etc. Both devices appear happy in their bluetooth settings etc.
If I connect the mouse first, it works but there is no keyboard. The same
occurs in reverse if I connect the keyboard first - no mouse pointer appears.

Is this a kernel issue? (between 5.10 and 5.11) Has anyone else experienced this behavior?

BTW Loving Beta7, full marks to all concerned. Your work is much appreciated and admired. And it’s better than Plasma :slight_smile:

1 Like

I am enjoying using beta 7 on Pinephone CE (manjaro edition) as daily driver (boot from sd card); however, my most critical apps are the phone, sms, and contacts. My nice to-have apps are web browser, email, podcast client, clock/alarm, image viewer, music/video player, maps, file browser.

Wishes for future release

  1. ability to delete podcasts from within the podcast application
  2. ability to import contacts directly from sd card

I find it strange that I am unable to delete a podcast from within the application.
IMHO users shouldn’t have to populate contacts list by syncing to a cloud service.

Let me know if I should communicate the two wishes upstream; however, I need instructions on how to do that. Otherwise, I will be patient for a software update that adds these features or adapt by figuring out a work-around.

What works (the essentials):

  • calls (t-mobile in USA), including number pad for conference calls
  • sms (text messages)
  • wifi
  • headphone jack

What works (other stuff):

  • web browsing via firefox (including youtube)
  • podcast application
  • camera (megapixels)
  • image viewer
  • file browser (portfolio)
  • software center
  • sound recorder
  • maps
  • email (geary)
  • clocks
  • text editor
  • to do
  • terminal

Other software installed that works

  • mpv (play movie files)

Not Tested

  • anbox
  • games (chess, 2048)
  • archive manager, authenticator
  • Other communication apps (fractal, telegram)
  • Music player (lollypop)
1 Like

I’m currently doing a rebuild of Anbox.