Manjaro ARM Beta5 with Plasma-Mobile (PinePhone)

The Manjaro ARM project is proud to announce the fifth BETA release of Plasma-Mobile for the PinePhone!

This image uses kernel 5.12.8 optimized for the Pinephone (megi), Frameworks 5.82 and Plasma 5.21.5.
Pipewire is now being used for improved audio latency.

Our Pico Setup Wizard offers easy configuration of User details, Timezone, Language and Network at initial boot.

Plasma Mobile development was again very active and is now calling their group of core applications PlaMo Gear.
Of course latest versions 1.2.2 of the Maui Apps are also included aswell as version 1.0.1 of camera-app Megapixels.

AppImageLauncher, Youtube-DL and a selection of wallpapers are now also preinstalled.

Known issues

  • The kernel currently used for the Pinephone allows charging of the battery only to about 80% capacity as a security measure to prevent overheating. However, battery life in general has been improved.
  • Automatic switching of audio-output when plugging headphones now works more or less reliably, still not 100%.
  • You my still encounter some modem and keyboard instabilities.
  • Text preditcion currently is only available for English.

Download Pinephone PlaMo Beta5

Nightly builds with latest git-packages can be found here:
Download Pinephone PlaMo Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition Pre-Orders start on the 24th of March! Don’t miss it !!! Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

8 Likes

Tried the new beta5 but I can not complete installer as when selecting any input field screen goes black.
So I can’t put anything to wifi password or user details / password fields etc.

update:
Reflashed again and I was able to finish installer.

hmm not having that issue here (on pinephone), maybe try a reflash?

2 Likes

Does mobile data work in this beta? And is the issue of the screen brightness randomly going to 0% (and then staying there) fixed? These issues are not listed in the ‘Known issues’, so I suppose so? :slight_smile:

Does mobile data work in this beta?

Yes.

And is the issue of the screen brightness randomly going to 0% (and then staying there) fixed?

Looks like it.

Hey people using Beta5 already, how is stability of the modem? (I saw that it still might not be stable) I wasn’t able to use SMS on beta 4 stably. Working alright for you guys and gals?

Switching to unstable seems to break the beta 5 installation after updating.
The brightness is set to 100 which makes the display black and after setting it back one can see that the de is stuck at the boot/kde logo with functional touchscreen (pointer is moving). For login all passwords user/kde/root need to be reseted and after trying to restart plamo with startplasma-wayland, kwin complains about a symbolerror for libkwayland.

Tested two times on fresh install of beta 5 with PP Convergence Edition

Yeah. Unstable is pretty, well yeah, unstable these days. Arch ARM seems to have pushed some plasma 5.22 packages, but not all, making Plasma brake at this point it seems.

You guys really knocked it out of the park this time!!! Not only is data much more reliable, but I was finally able to get Wireguard working! Now I can tunnel all of my traffic through my Linode wireguard to keep my browsing private from my ISP. And even better I can ssh to and from the phone and my home network wherever I am. Or check in on my Home Assistant server when I’m out. Keep up the great work.

Recently installed beta5 looks great, significant progress in usability has been made and I’d like to say THANK YOU to the KDE- and the Manjaro ARM Team for their great work. :smiley: :+1:
I hope I’ll soon find the time for a detailed test and report.

At the moment I have the following problem:
In konsole I started a package update by command pacman -Syyu.
(The screen became dark some times inbetween and one time the wifi connection was disabled by timeout. I had to reenter the password. The updating process went on after wifi was reconnected automaticly.)
In console the hint appeared “You are in selection mode”
I wanted to press the ‘disable’ button in the upper right corner
but somehow I must have locked the whole session.

Btw.: How does this work (if intended) to lock the session by a touch click/gesture?

A small vertically centered window opened: “The session has been locked by [myFullName]
Password:”

When touching into the empty password field a blue cursor appears inside that input field (instead of activating the virtual keyboard).
By swipe gestures I am able to move this blue cursor from the left to the right of the input field and back but I haven’t found a way to get the virtual keyboard, yet. I’m also able to tip on the unlock button but without the correct password the unlock request is certainly denied and the message window is refreshed (without the blue cursor until I again touch into the input field for the password).

Is there a way to get the virtual keyboard / to unlock the session by other means?
It is a bug, isn’t it? Can anybody confirm that behaviour? Or is it already known? In that case, could you please send the link of the issue?

1 Like

I’m NOT talking about the normal lock screen with the virtual numeric keypad.
Here’s a screenshot.

Could anybody please give me a hint

  • how I did get there
  • if there’s another way out than by a hard reboot.

That seems to be the regular Plasma lockscreen. Not the Mobile one.

Thank you for that info! So a hard reboot is the only way out, isn’t it?

I already tried to connect a standard keyboard via USB adapter but as I expected it didn’t work.

O.K.: Didn’t know that pressing und holding the power button forces a normal shutdown (not just a simple power off). So everything normal now, only the background picture has obviously changed. :face_with_monocle:
After an idle timeout now I have the hint for a normal PC like pictured here in opensuse forum. I can only see the middle part of it.
Obviously on my PinePhone the graphical configuration for a mobile device got lost by installing the regular updates or because I did make some strange input. :confused:

Is a reinstallation of the image the best option for me now or can I easily fix this?

Yep. By far the easiest fix. Something got messed up, and it’s not clear what.

Please check if you have plasma-nano and plasma-phone-components installed.

Thank you, I’ll check this before reinstalling!

I still have massive problems :disappointed::
When trying to reboot a second time by pressing and holding the power key the system didn’t come up anymore.
So I decided to begin with a reinstallation at once (without checking if the packages you mentioned above were installed):

  • deep format of the SD-card
  • hardware check for the SD-card (both in Windows)
  • then wrote the image by dd
  • inserted a new SIM-card and the SD-card into the PinePhone
  • activated the SIM-card (from PC)
  • booted the PinePhone into Manjaro ARM Plasma
  • executed the initial config program
  • did set a hostname by editing /etc/hostname and reboot
    → everything fine so far except of an error message “The modem shows no carrier” (with an interface name from /dev), the name of the SIM-card provider was in the upper left corner, the chosen wireless network connection was automaticly reconnected after reboot.

Then I wanted to install the updates. To be sure that an idle state inbetween doesn’t do no harm I tipped on the screen every time it became darker. The download was no problem but suddenly after having installed about 60 updates the screen became immediately black and the update process seemed interrupted.
The displayed battery state was about 45% when I started updating and about 39% when it interrupted. I didn’t have any reliability problems with the displayed battery state before.

When I boot now it begins normal (K with gear) then dark screen and it ends with the error message:
“[…] anx7688 1-0028: boot firmware load failed (you may need to flash FW to anx7688 first)
[…] anx7688 1-0028: OCM configuration failed”

  • battery state is not reliable
  • battery voltage breaks down under a heavy load
  • hardware power off because of a thermal problem
  • something else

Need your experience with the PinePhone :stuck_out_tongue_winking_eye:! What do you think is most likely the reason?

Did you also have the error message “The modem shows no carrier”?

I think the best would be to try another installation. And then I will update only when connected to the USB cable.
What do you think?

In case this is something impacting more users, I too ran into Kusgow’s “loginctl unlock-session 2” issue. Now after a reboot, it just black screens after the KDE spin gear animation.

  • Device: PinePhone (Manjaro Edition 3GB RAM)
  • Image: Flashed Manjaro Beta 3 Plasma Mobile (and have been updating since with pacman -Syu)
  • Issue Appeared: after update from Plasma 5.21 to Plasma 5.22 around 06/22/21